Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-27-2014, 09:59 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 229
Yukoncole is on a distinguished road
2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLease

Hey Everyone,

I ran a can of Seafoam through my Master Cylinder Vacuum line yesterday, let it sit for 15 minutes and then started the Jeep. It was running fine for about 5 minutes burning off the seafoam and then started to run rough. I got in the Jeep to bring up the RPMs and it stalled. It will not barely start if it will start at all. When it does after per say 20 attempts it runs really rough and barely stays running. I am at a loss as to what happened!!!! I pulled a few plugs and they appear fine. Any ideas would be greatly appreciated!
__________________

__________________
Reply With Quote
  #2  
Old 05-27-2014, 10:26 AM
Trav1s's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2012
Location: Cedar Rapids, IA
Posts: 772
Thanks: 25
Thanked 20 Times in 19 Posts
Rep Power: 1854
Trav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond repute
Garage
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

Have you tried holding the accelerator pedal to the floor while cranking? This opens the TB throttle body like it opens the butterfly on a carb. This is the trick on old cars with carbs that are flooded. Me wonders if there is still to much seafoam and not enough air.
__________________

__________________
2004 Columbia Edition WJ 4.7 HO
RB4/Moog HD Steering Stabilizer/PML trans pan 10304/ Autometer trans temp and oil pressure gauge/UpCountry springs & OME 10MM Spacers/Bilstein shocks/Rubicon Moabs/255/65r17 Cooper Discoverer AT3/Factory chrome tow hooks/Mopar hitch & a loose nut behind the wheel
Reply With Quote
  #3  
Old 05-27-2014, 10:28 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 229
Yukoncole is on a distinguished road
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

Yes nothing works!
__________________
Reply With Quote
  #4  
Old 05-27-2014, 10:59 AM
Trav1s's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2012
Location: Cedar Rapids, IA
Posts: 772
Thanks: 25
Thanked 20 Times in 19 Posts
Rep Power: 1854
Trav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond reputeTrav1s has a reputation beyond repute
Garage
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

Any codes?
__________________
2004 Columbia Edition WJ 4.7 HO
RB4/Moog HD Steering Stabilizer/PML trans pan 10304/ Autometer trans temp and oil pressure gauge/UpCountry springs & OME 10MM Spacers/Bilstein shocks/Rubicon Moabs/255/65r17 Cooper Discoverer AT3/Factory chrome tow hooks/Mopar hitch & a loose nut behind the wheel
Reply With Quote
  #5  
Old 05-27-2014, 12:21 PM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 229
Yukoncole is on a distinguished road
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

No codes, it just barely want to start and if it does start....runs like complete crap! Any kind of bleep on the throttle makes it almost stall. If I do get it to come up on the RPM range at all, it like only half of the motor is performing. No Ticks thought or Clanks so I think everything is firing. I am wondering if one CAT is plugged or if the MAP Sensor is whacked out.
__________________
Reply With Quote
  #6  
Old 05-27-2014, 06:00 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,305
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526355
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

You did reinstall the vacuum hose after the treatment? I heard of others with problems after the seafoam treatment. Sometimes new plugs fixed the issue.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 05-27-2014, 06:04 PM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 229
Yukoncole is on a distinguished road
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

Yep I sure did! It almost feels like the Fuel Pump is not giving the motor enough fuel. I am at a loss. I guess it will be going to the mechanics.
__________________
Reply With Quote
  #8  
Old 05-27-2014, 09:20 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,305
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526355
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

The MAP sensor could be full of crap due to the seafoam treatment. It sits on the front side of the intake manifold with two bolts. I would remove it and check for dirt.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 05-28-2014, 07:20 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 229
Yukoncole is on a distinguished road
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

I pulled the Plugs last night, they don't look new anymore but don't looked fouled either. I am getting new ones either way!

Does the MAP sensor sit right in the middle between the Alternator and Above the Coolant Sensor? I pulled and cleaned one that sits on the Drivers side right below the TB on the Intake. It just twists out though, no screws.
__________________
Reply With Quote
  #10  
Old 05-28-2014, 09:42 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,305
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526355
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Thumbs down Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

MAP indeed sits in between the alternator and AC compressor, on the front face of the inlet manifold. Its held in place with two bolts.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #11  
Old 05-28-2014, 09:51 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 229
Yukoncole is on a distinguished road
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

Yep...took that out along with Air Temp Sensor. I am putting new Plugs and everything back in tonight but don't expect a big change. We will see. I truly think it is fuel related.
__________________
Reply With Quote
  #12  
Old 05-28-2014, 10:03 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,305
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526355
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 4.7 HO, died and now wont restart or run after Seafoam treatment! HELP PLeas

The MAP sensor looked clean at the pressure sensing port?
Did you put any seafoam in the fueltank? If not, then I would not expect a fuel injector problem, but more a sensor problem. Do you have a scanner which shows live data?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1st Seafoam Treatment + Oil Change Drivenpromise Engine Performance/Intake/Exhaust 6 07-09-2014 03:14 PM
2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment Yukoncole Troubleshooting/Problems 10 06-03-2014 08:34 PM
seafoam treatment jtapscot Grand Cherokee - WK 15 11-20-2013 10:23 AM
seafoam treatment tom58 Grand Cherokee - WK 16 02-27-2012 09:35 AM
Seafoam gone bad! Help please tomczak Troubleshooting/Problems 4 11-16-2011 06:46 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:46 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.