Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-24-2011, 07:32 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66240
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
4.0 still running hot...

another problem with the wj, so sick of things going wrong...
so i replaced my electric fan motor and the relay within the past couple of months. fan works great now. today i was out driving for about 20 minutes and it never got hotter than 210. i went into a store for a minute or 2 and the shut the jeep, come out and start it up and go on my way and i see the gauge steadily climbing and it maxed out at 240 i wasnt using the a/c because it doesnt work lol
new water pump, coolant and thermostat last fall..
what are some things that could be. sorry if thats vague but id like to know anything that could be the problem.
im really sick of crap going wrong with my jeep, its so annoying.
thanks if you can help
__________________

__________________
-Michael-1999 Jeep Grand Cherokee WJ Laredo (oo\|||||||/oo) selec-trac 4x4. -She's gone
Now-2005 F-150 Fx4 scab, silver w/blk leather, '11 Fx4 badges, weathertech digital liners, white LED interior
Future-2.5" leveling kit, flowmaster dual exhaust, k&n intake, 5% tint, ptm handles/mirrors, Harley-Davidson headlights/tails, factory tow mirrors, kmc xd rockstars... :cool:
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 08-24-2011, 08:29 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66240
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 4.0 still running hot...

Also I should mention that this has happened once or twice before.. I'm not losing any coolant and if I get one the freeway it will drop back down below 210 so I suppose its not the radiator but I could be wrong..
Maybe the radiator cap, air in the system, coolant temp senosr, some other sensor.. Anyone have this problem or that can help I'd appreciate it.. I'd like some advice before I start replacing crap lol
__________________

__________________
Reply With Quote
  #3  
Old 08-24-2011, 08:50 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,117
Thanks: 98
Thanked 70 Times in 65 Posts
Rep Power: 331970
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: 4.0 still running hot...

Mike i hate to say it but a lot of the early wjs had cooling issues so much so that they don't recommend using a grill guard on the '99 through '01. That could be your issue if the problem started after the install. A 180 t stat helped our '99 some. You might also consider back flushing the rad and or adding an electric pusher fan in front. 240 isn't really bad considering they run at 210 normally.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #4  
Old 08-24-2011, 08:59 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66240
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 4.0 still running hot...

No not the grille guard!! Lol. I'm sure that and the hellas don't help it keeping cool lol. It was 90 out today also, and I get worried whenever I see it go over 210. I don't remember what tstat I put in dang! I guess its some maintainence time..
__________________
Reply With Quote
  #5  
Old 08-25-2011, 02:15 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653007
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: 4.0 still running hot...

Do you have a mechanical fan on the water pump?

Ultimately, IIRC you could litterally add one in the time it takes to buy one and spin it on.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #6  
Old 08-25-2011, 11:10 AM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,117
Thanks: 98
Thanked 70 Times in 65 Posts
Rep Power: 331970
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: 4.0 still running hot...

Quote:
Originally Posted by 2005JGC View Post
Do you have a mechanical fan on the water pump?

Ultimately, IIRC you could litterally add one in the time it takes to buy one and spin it on.
Great point.If that's the original fan clutch its more than worn out.I read somewhere that they lose rpms every year.You should hear the fan roar when you first start up in the morning for a moment or two and also when the temp starts to climb. If not its probably worn out.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #7  
Old 08-25-2011, 11:24 AM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66240
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 4.0 still running hot...

i do have the mechanical fan on the water pump..
also i notcied yesterday it was barely spinning at all at idle when i popped the hood to take a look at things when i pulled over on the way home..
could this be my problem?
should i be worried at 240 on a 90+ day or is this normal? it doesnt sound normal to me...
oh one more thing, if i turn my air conditioning on the mechanical fan will stop and spin the opposite way?? normal or is it due for replacement?
thanks everyone, i love this forum!!!
__________________
Reply With Quote
  #8  
Old 08-25-2011, 11:48 AM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,117
Thanks: 98
Thanked 70 Times in 65 Posts
Rep Power: 331970
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: 4.0 still running hot...

Sounds like it's shot. When you turn on the air the electric fan automatically turns on and the airflow is actually blowing the mechanical fan the other way so that tells me its not engaging at all. About $50 at Advance.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #9  
Old 08-25-2011, 12:08 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66240
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 4.0 still running hot...

ok thanks i appreciate the help, glad its cheap to replace too lol.
ok so i looked at rockauto and they have 2 different types, one says reverse and one doesnt. do you happen to know which i need?
orielly's and advance only have 1 type and it doesnt say reverse rotation, autozone has both.
id say i need the regular one since orielly's and advance only have the non-reverse type.
what do you guys think, reverse type or no?
thank you!
__________________
Reply With Quote
  #10  
Old 08-25-2011, 12:28 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,117
Thanks: 98
Thanked 70 Times in 65 Posts
Rep Power: 331970
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: 4.0 still running hot...

If I remember right it's stamped on the old clutch
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #11  
Old 08-25-2011, 12:31 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66240
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 4.0 still running hot...

alrighty thank you again!!!
__________________
Reply With Quote
  #12  
Old 08-25-2011, 01:48 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1653007
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: 4.0 still running hot...

Yeah at those temps (so long as thats actually how hot its getting and not a sender issue), that fan clutch should be locked up...

I would consider maybe its some buildup in the radiator that is killing its effiency, if there is not heat to take out of the radiator on the fins there is not enough heat going across the thermostatic fan clutch to lock it up. Not that it is not your problem, Im just puting that out there.
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
99 4.0 running hot 99PlatinumWJ Engine Performance/Intake/Exhaust 16 06-28-2011 10:16 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:09 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.