Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 06-26-2011, 04:45 AM
violant00's Avatar
Premium Member
My Jeep: 2000 4.0L WJ
 
Join Date: Feb 2010
Location: New york, NY
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2052
violant00 is on a distinguished road
Re: 99 4.0 running hot

Fan was going full blast. I also noticed when i turned the engine off and let it cool i checked the radiator and the reservoir both liquids are completely different colored (reservoir - dark brown, radiator-green)

Quote:
Originally Posted by Frango100 View Post
As long as the thermostat is closed (engine cold), there will be no flow through the the radiator. But eventhough you would see some fluid moving, its still no indication that the pump is 100%.
When the temperature went that high, was the cooling fan running normally? If yes, then your problem could be the pump, but also the thermostat or even a partly clogged radiator.
__________________

__________________
<img src=http://i955.photobucket.com/albums/ae39/violant00/IMG_0644-1.jpg border=0 alt= />\


00wj Red genIII projector head lights, K&N CAI. (more coming soon!)
Reply With Quote
  #14  
Old 06-28-2011, 08:14 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66144
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 99 4.0 running hot

Good news!! Replaced the relay and my fan works and my engine is keeping cool! Let it sit in my driveway on an 80 degree day for about 15 minutes with a/c on full blast, went for a drive, let it sit again idling and it didn't go over 210 once! so relieved I can sit in traffic! Hahah that doesn't right, but its a big deal to me
__________________

__________________
Reply With Quote
  #15  
Old 06-28-2011, 09:03 PM
mon_21's Avatar
Senior Member
 
Join Date: Jun 2009
Location: Chantilly, Virginia
Posts: 1,165
Thanks: 1
Thanked 11 Times in 8 Posts
Rep Power: 69036
mon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond repute
Re: 99 4.0 running hot

That is good news indeed....glad you got it fixed! Hope you didnt have to remove the whole bumper to get to the relay....
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #16  
Old 06-28-2011, 09:36 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66144
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 99 4.0 running hot

Yeah I did remove everything.. Brushguard(repainting it anyway lol), headlights, grille, bumper, and the plastic panel covering the relay. Wasn't bad at all since I've had my front end off many times so Its easier knowing what bolts need to come off. Only took me about an hour from start to finish so not bad at all, I was bored anyway. New relay is a duralast with a lifetime warranty for $44 at autozone.. Now on to the rest of my list lol
__________________
Reply With Quote
  #17  
Old 06-28-2011, 10:16 PM
mon_21's Avatar
Senior Member
 
Join Date: Jun 2009
Location: Chantilly, Virginia
Posts: 1,165
Thanks: 1
Thanked 11 Times in 8 Posts
Rep Power: 69036
mon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond repute
Re: 99 4.0 running hot

Might want to check this out if you haven't already, for those times that you might need a quick fix......

http://www.jeepslimited.com/index.ph...=37&Itemid=127
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
its HOT in here enzo83 Members Rides 13 06-23-2010 04:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:41 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community