Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-22-2011, 05:04 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66135
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
99 4.0 running hot

hello all,

first off i have a 1999 gc laredo 4.0 selec-trac. my jeep has been running hot while idling, usually with the a/c on. i just read a bunch of threads about this and most of the time its the fan relay under the passenger headlight. i replaced it last year with one from a wreaked wj (it was free so why not try it) as mine didnt work anyway when i bought my jeep.
this year i replaced the electric fan motor (in know it works i tested it off the battery before i installed it) and the fan still doesnt turn on even when it passes 210*
i also checked the fuse under the hood and it was not blown.
so should i buy a brand new fan relay and replace it? i think there are only 3 main parts that would effect the fan not working(the fan motor, fuse and relay) correct? with the first 2 working it should be the relay right? anything else i should look into?
please help asap, im worried to drive a lot of the time because i dont want to get caught in traffic and overheat...
thanks in advance for the help and suggestions, i appreciate it!
__________________

__________________
-Michael-1999 Jeep Grand Cherokee WJ Laredo (oo\|||||||/oo) selec-trac 4x4. -She's gone
Now-2005 F-150 Fx4 scab, silver w/blk leather, '11 Fx4 badges, weathertech digital liners, white LED interior
Future-2.5" leveling kit, flowmaster dual exhaust, k&n intake, 5% tint, ptm handles/mirrors, Harley-Davidson headlights/tails, factory tow mirrors, kmc xd rockstars... :cool:
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 06-22-2011, 05:41 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,079
Thanks: 95
Thanked 68 Times in 64 Posts
Rep Power: 331828
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: 99 4.0 running hot

Mike on our 99 4.0 the fan kicks on with the a/c so it should be running as soon as you hit the air no mater what temp the engine is. Even so if you climb a big enough hill with the a/c on it will get warm. Just the nature of the beast with a 4.0 I guess. Still your fan should kick on with the a/c. I'd say probably the relay again.
__________________

__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #3  
Old 06-22-2011, 06:01 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66135
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 99 4.0 running hot

Thanks dave,
I know they are known to run warm, but like I said even with the a/c on it doesn't kick on. I think I'm going to replace it and hopefully its one less problem I need to worry about lol
__________________
Reply With Quote
  #4  
Old 06-23-2011, 12:30 PM
mon_21's Avatar
Senior Member
 
Join Date: Jun 2009
Location: Chantilly, Virginia
Posts: 1,165
Thanks: 1
Thanked 11 Times in 8 Posts
Rep Power: 69027
mon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond reputemon_21 has a reputation beyond repute
Re: 99 4.0 running hot

I'd say go get a brand new relay. But I will also check for the fan, mine froze up one time and I had to remove it and hotwire it to the batt for a jump. Im actually due for a new fan motor....
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #5  
Old 06-23-2011, 01:38 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66135
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 99 4.0 running hot

Thanks, I'm going to get a new relay soon then!
Oh my fan motor is brand new and I tested it before installing it.
Thanks for all the help fellow jeepers
__________________
Reply With Quote
  #6  
Old 06-23-2011, 03:21 PM
violant00's Avatar
Premium Member
My Jeep: 2000 4.0L WJ
 
Join Date: Feb 2010
Location: New york, NY
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2043
violant00 is on a distinguished road
Re: 99 4.0 running hot

this just happend to me... it went all the way up to 260! when i checked under the hood the resevoir for the coolant was WAY passed the filled point turned it on and off and drove with the ac off and it went back to normal.
__________________
<img src=http://i955.photobucket.com/albums/ae39/violant00/IMG_0644-1.jpg border=0 alt= />\


00wj Red genIII projector head lights, K&N CAI. (more coming soon!)
Reply With Quote
  #7  
Old 06-23-2011, 04:00 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66135
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 99 4.0 running hot

Oh my gosh 260!?! Hopefully nothing was effected by that and your jeep is ok..
__________________
Reply With Quote
  #8  
Old 06-23-2011, 08:26 PM
violant00's Avatar
Premium Member
My Jeep: 2000 4.0L WJ
 
Join Date: Feb 2010
Location: New york, NY
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2043
violant00 is on a distinguished road
Re: 99 4.0 running hot

i agree man i really hope nothing happend i hope its not my water pump going out :/

Quote:
Originally Posted by MichaelNawrocki View Post
Oh my gosh 260!?! Hopefully nothing was effected by that and your jeep is ok..
__________________
<img src=http://i955.photobucket.com/albums/ae39/violant00/IMG_0644-1.jpg border=0 alt= />\


00wj Red genIII projector head lights, K&N CAI. (more coming soon!)
Reply With Quote
  #9  
Old 06-23-2011, 08:54 PM
99PlatinumWJ's Avatar
Member
My Jeep: 1999 4.0L WJ
 
Join Date: Nov 2010
Location: Michigan
Posts: 462
Thanks: 2
Thanked 8 Times in 7 Posts
Rep Power: 66135
99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute99PlatinumWJ has a reputation beyond repute
Re: 99 4.0 running hot

Yeah replacing the water pump is not fun!! I had to replace mine last fall, not too fun lol
__________________
Reply With Quote
  #10  
Old 06-23-2011, 11:13 PM
violant00's Avatar
Premium Member
My Jeep: 2000 4.0L WJ
 
Join Date: Feb 2010
Location: New york, NY
Posts: 438
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2043
violant00 is on a distinguished road
Re: 99 4.0 running hot

i think i do... but im not 100% sure i opened my radiator tonight and didn't see the antifreeze move or flow at all... is this normal? im not familiar with reservoir/ radiator type cooling systems so im not sure if i should see the coolant flowing


Quote:
Originally Posted by MichaelNawrocki View Post
Yeah replacing the water pump is not fun!! I had to replace mine last fall, not too fun lol
__________________
<img src=http://i955.photobucket.com/albums/ae39/violant00/IMG_0644-1.jpg border=0 alt= />\


00wj Red genIII projector head lights, K&N CAI. (more coming soon!)
Reply With Quote
  #11  
Old 06-23-2011, 11:22 PM
Member
 
Join Date: Mar 2011
Posts: 164
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1383
Sir Sam is on a distinguished road
Re: 99 4.0 running hot

Quote:
Originally Posted by MichaelNawrocki View Post
Yeah replacing the water pump is not fun!! I had to replace mine last fall, not too fun lol
IMO the 4L has one of the easiest to replace water pumps of any vehicle I have ever worked on.

You should see how much trouble it is to do on my KJ.
__________________
Reply With Quote
  #12  
Old 06-24-2011, 10:14 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,644
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525442
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 99 4.0 running hot

As long as the thermostat is closed (engine cold), there will be no flow through the the radiator. But eventhough you would see some fluid moving, its still no indication that the pump is 100%.
When the temperature went that high, was the cooling fan running normally? If yes, then your problem could be the pump, but also the thermostat or even a partly clogged radiator.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
its HOT in here enzo83 Members Rides 13 06-23-2010 04:09 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community