Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-17-2010, 08:41 PM
Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
pagokid is on a distinguished road
99 GJ 4.7 will not stay running and pings when try to accelerate slow

Put all new sensors and rebuild motor but won't stay running when idles drops below 1000 rpm. When I shift in gear it will stay runing but up and down at idles, when tries to accelerate it backfires and pings hard like a bad flow meter. Disconnected the Cat.Con. and no change. Vacuum is good and all new parts but still doesn't want to run right, my mechanic told me he crossed the battery cable when he put the battery in, would that cause any damage to the PCM or other controll units. Anybody out there that can help, I don't know what to do next. Thanks
__________________

__________________
Reply With Quote
  #2  
Old 10-17-2010, 08:46 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,752
Thanks: 827
Thanked 806 Times in 622 Posts
Rep Power: 7717318
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

sounds like a pcm issue....but who knows really without being in the Jeep. Any codes or anything?
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 10-17-2010, 11:38 PM
Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
pagokid is on a distinguished road
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

the codes keeps coming up that 3and4 cyl.are mis firing. When accelerates to about 1500-2000 rpm you can feel the misfire, but when you let off the throttle the engine comes down to idle mode and runs pretty good for about 10 seconds the shuts off. But when I put it gear the engine will stay idle and diesels up and down.
__________________
Reply With Quote
  #4  
Old 10-17-2010, 11:48 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,752
Thanks: 827
Thanked 806 Times in 622 Posts
Rep Power: 7717318
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

could be a crank or cam sensor or the tps.....hard to say
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #5  
Old 10-18-2010, 06:28 AM
Chuck's Avatar
Senior Member
My Jeep: 2004 4.0L WJ
 
Join Date: Jun 2009
Location: Queens, NY
Posts: 3,869
Thanks: 0
Thanked 4 Times in 4 Posts
Rep Power: 5751
Chuck has a reputation beyond reputeChuck has a reputation beyond repute
Quote:
Originally Posted by Scottina06 View Post
could be a crank or cam sensor or the tps.....hard to say
I was just thinking that. Have you already replaced these sensors?
__________________
2004 Jeep Grand Cherokee Special Edition 4.0
Quote:
Originally Posted by White WK Swagga View Post
I'm here, and I like black jeeps!!!
Reply With Quote
  #6  
Old 10-18-2010, 03:17 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,646
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525444
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

Idling problems many times are caused by the IAC stepper motor pintle or air passage, which gets dirty with oil and dust particles.
If the mechanic who installed the battery, also did the engine rebuild, i would cross my fingers...........................and first of all change to an other one
Is the engine completely rebuild and do you know why this was done?
A misfire is detected by the PCM by a small deceleration. This can be caused by ignition problem, fuel supply problem (fuel injector) or low compression in related cylinder(s).
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 10-18-2010, 03:40 PM
scjeep4.7HO's Avatar
Senior Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jun 2009
Location: Virginia
Posts: 1,515
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 36186
scjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond reputescjeep4.7HO has a reputation beyond repute
Send a message via MSN to scjeep4.7HO
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

If it's in those 2 cylinders (3 &4) make sure the coils and/or fuel injectors wires haven't been swapped during install. Pull and check your spark plugs in those cylinders if wires are correct.
__________________
Supercharged 4.7L HO. If you would like to know more just ask.
Reply With Quote
  #8  
Old 10-18-2010, 05:51 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,646
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525444
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

Isn't coil 3 on the left bank and coil 4 on the right bank?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 10-19-2010, 09:31 AM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113167
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

3 is drivers side. 4 is passenger side on a US vehicle.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #10  
Old 10-25-2010, 02:09 PM
Member
 
Join Date: Oct 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1382
pagokid is on a distinguished road
Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow

I decided to check the voltage on the crankshaft and it only shows .50 volts not even close to what it supposed to be at 5.0 volts. So I send the PCM out to be check and repair, hopefully this will solve the problem, I will let you know what happens.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does This Seem Slow To You? Robert Palmer Grand Cherokee - WK 33 07-13-2009 10:50 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community