Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-13-2009, 01:16 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2263
Andrew has a brilliant future
Re: 99 WJ RPM drops!

They cleaned my battery. So it's not that.

Would I gain more hp if i got a High Performance Throttle Body? What brand?

Heres one that I found. Would it fit mine?
http://www.hesco.us/shop.asp?action=...entoryID=43019
__________________

__________________
Reply With Quote
  #14  
Old 09-13-2009, 01:49 PM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2873
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: 99 WJ RPM drops!

Take it to the dealer and let them look for it! Get whatever problem you have fixed before spending anymore money on performance parts Andy...

Don't take it back to that shop if they said its your battery terminals that caused the Jeep to run bad...
__________________

__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #15  
Old 09-13-2009, 01:54 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,109
Thanks: 859
Thanked 937 Times in 670 Posts
Rep Power: 7717725
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 99 WJ RPM drops!

take a pic of your TB for me please
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #16  
Old 09-13-2009, 02:55 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2533
Denny boy is a jewel in the rough
Re: 99 WJ RPM drops!

Quote:
Originally Posted by Scottina06 View Post
take a pic of your TB for me please
that and what do you mean by shaking, also don't drive it unlesss its to the dealer. you could have a missfiring plug. the way to check is to start the engine. then pull each plug wire off one at a time till the engine doesn't make it shake worse. if one of the wires off makes no change then you have found your bad plug, plug wire or even your cap then replace it.

does it shake when you rev it? if it shakes above idle than you have an ignition issue if it cleans out after idle than theres something wrong with its breathing.
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #17  
Old 09-13-2009, 04:06 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2263
Andrew has a brilliant future
Re: 99 WJ RPM drops!

They said if your terminals are split, your vehicle will run like crap.
I never got a chance to have them check for the shaking problems.
You can hear it rumble my rear end in reverse too, so annoying.

Quote:
Originally Posted by dreamer1213 View Post
Take it to the dealer and let them look for it! Get whatever problem you have fixed before spending anymore money on performance parts Andy...

Don't take it back to that shop if they said its your battery terminals that caused the Jeep to run bad...
Denny boy, theres no shaking when i accelerate, only on idles.

Should a needle move like this?
Doesnt seem like much, but the vehicle does shake. Also includes the air intake. Enjoy!
http://www.disneylandonline.com/videos/rpms.html
__________________
Reply With Quote
  #18  
Old 09-13-2009, 04:40 PM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2873
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: 99 WJ RPM drops!

I can't open the video Andy...why is it on disneylandonline?? LOL!!
__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #19  
Old 09-13-2009, 04:41 PM
FlyinRyan's Avatar
Senior Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jul 2009
Location: Fort Myers, Florida
Posts: 2,801
Thanks: 33
Thanked 31 Times in 30 Posts
Rep Power: 88610
FlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond repute
Send a message via AIM to FlyinRyan
Re: 99 WJ RPM drops!

Quote:
Originally Posted by Andrew View Post
I cleaned the sensor. Same problem.
The vibrations seem to be bad when the vehicle is warmed up (hot).

You can see the motor shake in a pattern that it does.
Makes me exhaust pipes move too, which makes annoying sound when idling at the stop light. Kinda embarrassing to me. lol.

Anyways, maybe i should get my 2 sensors replaced brand new, and go from there.

Where can i purchase them?
What is the Original brand that comes with the jeep, or the best quality?
Just because you cleaned it doesn't mean you solved the problem. IAC sensors go bad over time.
__________________
Due to my workload, please do not PM me as I do not regularly check my PMs. Thank you :)
Reply With Quote
  #20  
Old 09-13-2009, 04:42 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2263
Andrew has a brilliant future
Re: 99 WJ RPM drops!

I was replacing video. Try again.

www.disneylandonline.com/videos/rpms.html
__________________
Reply With Quote
  #21  
Old 09-13-2009, 04:48 PM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2873
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: 99 WJ RPM drops!

Alright..I saw it....

Was the needle dead still on your other cluster?? Has it done this since you installed the electroluminescent cluster?
__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #22  
Old 09-13-2009, 04:50 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2263
Andrew has a brilliant future
Re: 99 WJ RPM drops!

I doubt its the cluster. You can see my engine shake in a pattern. Somethings off.

I never noticed this problem until I started listening to my performance and engine.

I'm so sick of my jeep.
__________________
Reply With Quote
  #23  
Old 09-13-2009, 05:01 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2263
Andrew has a brilliant future
Re: 99 WJ RPM drops!

My tranny does slip sometimes at 35 MPH. Right on the dot, everytime.
Maybe its the vacuum line to the tranny, or other vacuum lines. Where can i search for these?
__________________
Reply With Quote
  #24  
Old 09-13-2009, 06:10 PM
FlyinRyan's Avatar
Senior Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jul 2009
Location: Fort Myers, Florida
Posts: 2,801
Thanks: 33
Thanked 31 Times in 30 Posts
Rep Power: 88610
FlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond repute
Send a message via AIM to FlyinRyan
Re: 99 WJ RPM drops!

I saw the video. If you had a misfire, you'd have a CEL.

Replace your IAC sensor. Could be a bad MAP sensor but doubtful, as you'd likely have a CEL.
__________________

__________________
Due to my workload, please do not PM me as I do not regularly check my PMs. Thank you :)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community