Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-12-2009, 06:26 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2282
Andrew has a brilliant future
99 WJ RPM drops!

So I thought I'd begin a thread to solve my RPM problems!
I had to cancel my appointment to get that diagnose because I had a problem getting my vehicle started. So it got towed and brought to Kinneys shop.

Anyways, my jeep is back and running again, terminals were split.

When I'm driving, I go to pull into a friends house, and when I brake, my RPMs needle goes down to almost 0, almost conking out, but not quiet. You can hear it, like its about to shut off the engine, and then it goes back up.

It also seems like my rpm is low when idling.
I should film it now, and have you watch it idle.

Vacuum hose for sure?
__________________

__________________
Reply With Quote
  #2  
Old 09-12-2009, 08:47 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2552
Denny boy is a jewel in the rough
Re: 99 WJ RPM drops!

could be trans, vacuum, Throttle position sensor, bad air filter. Its hard to tell, do you have the 4.0? your low idle could be a dirty intake thats what mine was, also could be parts of your ignition system like coil plugs wires etc.
__________________

__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #3  
Old 09-12-2009, 09:27 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2282
Andrew has a brilliant future
Re: 99 WJ RPM drops!

I have the 4.0L. When I put it in drive or reverse repeatively, you can notice the rpms gets close to 0, almost wanting to stall. Has to be the idle senors or needs cleaning. I hope.

Tomorrow I'm going to clean out my Throttle body throat.
I can clean it with the throttle body cleaner stuff i got tonight.
I can clean it with the throttle still attached to my jeep by going through directions on wjjeeps.com. But one of the steps isnt very clear on what to do.

You start your jeep, until normal temperature.
You spray the cleaner into the hole, until you hear it about to stall.
Turn off your jeep, and let it sit for 2-3 hours with hood down.
Then it says to drive the jeep at high speeds, and full throttle several times. This is where i get lost, do i put the K&N air intake back on before driving? lol.

Heres WJJeep.com Directions.
1. Operate the vehicle until operating temperature is reached.
2. Remove air cleaner duct clamp closest to resonator. Disconnect breather tube at resonator. Remove two bolts securing resonator to manifold and remove resonator by twisting up and away from throttle body.

3. With the engine at an idle, spray the entire contents of the combustion cleaner (Mopar P/N 04318001 recommended) directly into the throttle body. Allow the vehicle to load up with the cleaner to the point of almost stalling out.

4. Shut the engine OFF after the entire can is ingested.

5. With the hood closed and the vehicle parked inside the garage, allow the vehicle to soak for two to three hours. This will ensure that the engine will maintain its temperature and will allow proper solvent penetration.
6. Drive the vehicle on a highway/freeway that will allow the vehicle to be driven safely at the posted speed limit. Upon entering the highway/freeway, accelerate hard to the posted speed limit and maintain speed. Slow down and then perform 5 to 10 Wide Open Throttle (WOT) upshifts. Continue driving at the maximum speed limit for 1-2 miles (if conditions allow).

Also, they say to have your Jeep running in park and put force against the sensors, push and pull on them and see if the RPM changes. If it does then that sensor is bad and should be replaced.

Quote:
Originally Posted by Denny boy View Post
could be trans, vacuum, Throttle position sensor, bad air filter. Its hard to tell, do you have the 4.0? your low idle could be a dirty intake thats what mine was, also could be parts of your ignition system like coil plugs wires etc.
__________________
Reply With Quote
  #4  
Old 09-12-2009, 09:54 PM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 25 Times in 25 Posts
Rep Power: 63397
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: 99 WJ RPM drops!

SeaFoam!
__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #5  
Old 09-12-2009, 10:43 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2552
Denny boy is a jewel in the rough
Re: 99 WJ RPM drops!

It's up to you but i have never like the idea of leaving it on just doesn't seam like it would clean it well enough to how can clean it by hand. its not hard to take off its four bolts and unclip some sensors and its off. i take the sensors all off to clean but you dont need to. i don't like the idea of cleaning with it on because i don't want that crap going into my motor. i know it does go in even without cleaning but not at that large amount. i think it maybe the trans because my buddys 86 gmc allmost stalls when shifting into gear. it has a 454 and some trans that i can't remember but someone said it could be the clutch kicking in or something i cant remember. i would take it in if the TB clean doesnt fix it. may have a bigger problem that could be caught early enough to fix.

thats the extent of my knowledge someone else might know more.
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #6  
Old 09-12-2009, 10:46 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,235
Thanks: 866
Thanked 973 Times in 688 Posts
Rep Power: 7717870
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 99 WJ RPM drops!

I think you have a vacuum hose leak or collapse under pressure. Check to see if any of them are easily pinched shut with your fingers
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #7  
Old 09-12-2009, 11:07 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2552
Denny boy is a jewel in the rough
Re: 99 WJ RPM drops!

both lines off the valve cover are thick plastic check the gromets on both ends but i dont think both would fail at the same time everytime. i drove with one plugged for a day so i could paint one than the other and had no problems. there are two coming off the side drivers side of the intake manifold but one is for your evaporation system and the other is for your cruise control. there are no others i can think of i am out of town so i cant run out and look. are there anymore i can't think of?
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #8  
Old 09-13-2009, 06:33 AM
dreamer1213's Avatar
Founding Member
 
Join Date: May 2009
Location: Jacksonville, FL
Posts: 918
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2891
dreamer1213 has a reputation beyond reputedreamer1213 has a reputation beyond repute
Re: 99 WJ RPM drops!

If you clean that TB on the Jeep....you for sure as heck want to put the intake back on before you go and drive it hard like its telling you to do...

IF you want to clean the TB...take it off! Its the best way to make sure nothing falls into the intake manifold...and its a couple of screws I'm sure...

They didn't check it out for you at the shop??
__________________
{ Hannes }

02 WJ Overland 4.7L H.O V8

Reply With Quote
  #9  
Old 09-13-2009, 08:57 AM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2282
Andrew has a brilliant future
Re: 99 WJ RPM drops!

They were positive that it was the terminals that made my jeep run like crap. lol.
I'm like, so everything else works fine? They are like "yes"!

I'm going back there sooner or later if i can't get my jeep running good today.

So all i need to do is take off my throttle body?
Can i just clean the sensor IAC?

Where are ALLL the vacuum hoses located, so i can check them, because i dont see anything wrong. It could be hidden.
__________________
Reply With Quote
  #10  
Old 09-13-2009, 11:35 AM
FlyinRyan's Avatar
Senior Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jul 2009
Location: Fort Myers, Florida
Posts: 2,802
Thanks: 33
Thanked 31 Times in 30 Posts
Rep Power: 88630
FlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond repute
Send a message via AIM to FlyinRyan
Re: 99 WJ RPM drops!

IAC sensor.
__________________
Due to my workload, please do not PM me as I do not regularly check my PMs. Thank you :)
Reply With Quote
  #11  
Old 09-13-2009, 01:00 PM
Andrew's Avatar
Member
 
Join Date: Jun 2009
Location: Traverse City, Michigan
Posts: 330
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2282
Andrew has a brilliant future
Re: 99 WJ RPM drops!

I cleaned the sensor. Same problem.
The vibrations seem to be bad when the vehicle is warmed up (hot).

You can see the motor shake in a pattern that it does.
Makes me exhaust pipes move too, which makes annoying sound when idling at the stop light. Kinda embarrassing to me. lol.

Anyways, maybe i should get my 2 sensors replaced brand new, and go from there.

Where can i purchase them?
What is the Original brand that comes with the jeep, or the best quality?
__________________
Reply With Quote
  #12  
Old 09-13-2009, 01:05 PM
Dylans3960ccs's Avatar
Senior Member
 
Join Date: Jun 2009
Location: Alpharetta ,GA
Posts: 3,808
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 5814
Dylans3960ccs has a reputation beyond reputeDylans3960ccs has a reputation beyond reputeDylans3960ccs has a reputation beyond reputeDylans3960ccs has a reputation beyond repute
Re: 99 WJ RPM drops!

did you clean the battery terminals like the mechanic suggested?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:22 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community