Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 10-12-2011, 09:23 PM
Member
 
Join Date: Aug 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1192
qbny94 is on a distinguished road
Re: Acceleration Problem

the engine revs without proper acceleration. when i press down on the accelerator it feels sluggish and i notice its not as powerful as it use to be. i press on the gas and it revs to about 2000-2200 rpm but its slow to increase speed. It could be that its skipping first gear.. i only notice the problem really from 0- to about 35 mph. but like i said sometimes at dead stops like a stop sign theres sometimes a delay when i step on the gas of about 2-3 seconds before moving.
__________________

__________________
Reply With Quote
  #14  
Old 10-12-2011, 10:09 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,910
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525862
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Acceleration Problem

But when you try to accelerate faster, does the engine rev higher and does it make any difference on the acceleration?
When you put the tranny in 1 or 2 and not in Drive, does that make any difference?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #15  
Old 10-12-2011, 10:36 PM
Member
 
Join Date: Aug 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1192
qbny94 is on a distinguished road
Re: Acceleration Problem

it does rev higher but it makes a slow gain in acceleration. and i haven't tried using 1,2 its just been in drive
__________________
Reply With Quote
  #16  
Old 10-13-2011, 06:51 AM
Senior Member
 
Join Date: Feb 2011
Posts: 3,143
Thanks: 73
Thanked 43 Times in 36 Posts
Rep Power: 534000
Amelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond repute
Re: Acceleration Problem

Quote:
Originally Posted by qbny94 View Post
it does rev higher but it makes a slow gain in acceleration. and i haven't tried using 1,2 its just been in drive
I would say if you have a Jeep Garage near you to contact them about the problem and see if you can take it for a diagnostic maybe.
__________________
Reply With Quote
  #17  
Old 10-13-2011, 08:23 AM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 597
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 2701
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Acceleration Problem

Your torque converter could be roasted. With the limited information given, I would throw it in with the possible causes. It wouldn't be my number 1 suspect, but I would keep it in the options.
__________________
Reply With Quote
  #18  
Old 10-13-2011, 10:03 AM
Senior Member
 
Join Date: Feb 2011
Posts: 3,143
Thanks: 73
Thanked 43 Times in 36 Posts
Rep Power: 534000
Amelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond repute
Re: Acceleration Problem

Quote:
Originally Posted by JeepMe View Post
Your torque converter could be roasted. With the limited information given, I would throw it in with the possible causes. It wouldn't be my number 1 suspect, but I would keep it in the options.
I never thought of that, Good suggestion!
__________________
Reply With Quote
  #19  
Old 10-14-2011, 05:26 PM
Member
 
Join Date: Aug 2011
Posts: 59
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1192
qbny94 is on a distinguished road
Re: Acceleration Problem

Well guys i got my problem fixed i took the jeep to my mechanic today and he said my throttle cable was stretched out really far and my throttle body was dirty. He installed a new throttle cable and cleaned the body. After a test drive it was back to new acceleration was back to normal. Just happy it was that easy of a fix! thanks guys
__________________
Reply With Quote
  #20  
Old 10-14-2011, 05:38 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,910
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525862
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Acceleration Problem

Good to hear its fixed
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #21  
Old 10-15-2011, 03:41 AM
Senior Member
 
Join Date: Feb 2011
Posts: 3,143
Thanks: 73
Thanked 43 Times in 36 Posts
Rep Power: 534000
Amelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond repute
Re: Acceleration Problem

Quote:
Originally Posted by Frango100 View Post
Good to hear its fixed
Yeah, What he said!
__________________
Reply With Quote
  #22  
Old 10-24-2011, 12:34 AM
Gus9890's Avatar
Premium Member
My Jeep: 2001 4.0L WJ
 
Join Date: Apr 2011
Location: Amelia Island, FL
Posts: 4,473
Thanks: 38
Thanked 48 Times in 47 Posts
Rep Power: 408130
Gus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond repute
Re: Acceleration Problem

I've been startin to have the same issue I think, but I haven't checked out everything to make sure it's clean. I'm doing that tomorrow cause I'm off.
__________________
2001 Silverstone Metallic WJ Limited:
Gen III Clear/Chrome Projector/CCFL Halos/LEDs, 8K HIDs, 8K HID Projector/Halo fogs, Clear/Chrome Tail Lights and 3rd Brake Light with LEDS, Diamond Mesh Upper and Lower Fascia, Spectre CAI, Breather Filter, Cabin Air Filter, Low-Temp Thermostat, Jet Stage 1 Chip, MagnaFlow Exhaust with Resonator Tip, Shorty Antenna, Front/Back De-badged
Reply With Quote
  #23  
Old 10-24-2011, 06:27 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,910
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525862
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Acceleration Problem

Hi GUS9890, is your problem now different then you had with the tranny a while back?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #24  
Old 10-28-2011, 11:48 PM
Gus9890's Avatar
Premium Member
My Jeep: 2001 4.0L WJ
 
Join Date: Apr 2011
Location: Amelia Island, FL
Posts: 4,473
Thanks: 38
Thanked 48 Times in 47 Posts
Rep Power: 408130
Gus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond repute
Re: Acceleration Problem

Same problem but not as bad as before, sounds like same as above
__________________

__________________
2001 Silverstone Metallic WJ Limited:
Gen III Clear/Chrome Projector/CCFL Halos/LEDs, 8K HIDs, 8K HID Projector/Halo fogs, Clear/Chrome Tail Lights and 3rd Brake Light with LEDS, Diamond Mesh Upper and Lower Fascia, Spectre CAI, Breather Filter, Cabin Air Filter, Low-Temp Thermostat, Jet Stage 1 Chip, MagnaFlow Exhaust with Resonator Tip, Shorty Antenna, Front/Back De-badged
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rattle on acceleration jdubgrand Troubleshooting/Problems 23 06-03-2013 11:44 AM
wj acceleration problems patriotmfd Engine Performance/Intake/Exhaust 15 02-01-2011 04:58 AM
Stalls on acceleration Canyon Dancer Trouble Shooting/Problems/Service 9 10-30-2010 10:31 AM
3.6L acceleration hesitation and shudder problem abby Trouble Shooting/Problems/Service 4 10-17-2010 08:35 PM
Dip in acceleration Frango100 Engine Performance/Intake/Exhaust 10 04-13-2010 11:38 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community