Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 07-25-2012, 08:49 AM
mopar01bk's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Aug 2009
Posts: 83
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2281
mopar01bk is on a distinguished road
Re: Acceleration Problem

I don't know if my problem is the same but it takes a while it the it to start up and when it does it spudders a bit some like a v6 rather than a v8 and acceleration is not the same it will slow down then drive normal but with the exhaust spudders, I open the hood no noises coming from motor idles fine what you guys think it could be
__________________

Reply With Quote
  #26  
Old 07-25-2012, 02:21 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 6,380
Thanks: 14
Thanked 234 Times in 226 Posts
Rep Power: 527922
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Acceleration Problem

Low fuel pressure? I would start changing the fuel filter/regulator or if you have a fuel pressure indicator, measure the pressure at the right fuel rail (seen from drivers seat) You could do a quick check and push the schrader valve on the right fuel rail after priming once (no start and engine cold, to prevent a fire), the fuel should come out under a high pressure.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #27  
Old 08-22-2015, 09:38 PM
New Member
 
Join Date: Aug 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GigityBW is on a distinguished road
Re: Acceleration Problem

I have pretty much that same problem bur my engine light is on
Reply With Quote
  #28  
Old 08-23-2015, 05:00 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 6,380
Thanks: 14
Thanked 234 Times in 226 Posts
Rep Power: 527922
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Acceleration Problem

Welcome to the garage.
Did you check for fault codes using the key dance? Ignition switch off/run three times and leave in run at the third time. The odometer will show DONE when no faults, or a fault code(s).
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #29  
Old 08-23-2015, 02:39 PM
New Member
 
Join Date: Aug 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GigityBW is on a distinguished road
Re: Acceleration Problem

Yes no codes show up
Reply With Quote
  #30  
Old 08-24-2015, 07:17 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 6,380
Thanks: 14
Thanked 234 Times in 226 Posts
Rep Power: 527922
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Acceleration Problem

Quote:
Originally Posted by GigityBW View Post
Yes no codes show up
That is strange, because the check engine light on means that the PCM has seen some problem, so it should have saved something in its memory. It did show DONE during the test?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rattle on acceleration jdubgrand Troubleshooting/Problems 23 06-03-2013 11:44 AM
wj acceleration problems patriotmfd Engine Performance/Intake/Exhaust 15 02-01-2011 04:58 AM
Stalls on acceleration Canyon Dancer Trouble Shooting/Problems/Service 9 10-30-2010 10:31 AM
3.6L acceleration hesitation and shudder problem abby Trouble Shooting/Problems/Service 4 10-17-2010 08:35 PM
Dip in acceleration Frango100 Engine Performance/Intake/Exhaust 10 04-13-2010 11:38 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:57 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.