High Engine RPM on Startup - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Reply
 
Thread Tools Display Modes
 
  #13  
Old 09-21-2014, 04:50 PM
Member
 
Join Date: Dec 2009
Location: las vegas, nv
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2768
intlaero is on a distinguished road
Re: High Engine RPM on Startup

I wrote a bit too early. Today on start up, high idle RPM. I took off the IAC stepper motor and it was very dirty, looked like carbon build up. Cleaned it up, started engine and sprayed cleaner in the throttle body and replaced. Engine ran very poorly for about 10 minutes, would not idle at all, then smoothed out and ran like normal. We'll see how it starts tomorrow when cold. I did have to reset the trouble code for IAC. To be expected since it ran with it off and disconnected.

Thanks for the reply Frank. I did not have problems with Cruise Control, worked perfectly. I appreciate your responses. I'll keep working on this until I get it right with your help and others.

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 10-01-2014, 01:00 PM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,281
Thanks: 59
Thanked 12 Times in 12 Posts
Rep Power: 3915
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: High Engine RPM on Startup

Seafoam has a tb cleaner in an aerosol
Reply With Quote
  #15  
Old 10-04-2014, 11:18 AM
Member
 
Join Date: Dec 2009
Location: las vegas, nv
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2768
intlaero is on a distinguished road
Re: High Engine RPM on Startup

I cleaned the IAC and the air channel very well. It improved the fast idle but it is still very erratic. Starts at 1500 rpm and then never really settles down. I see 600 to 1100 rpm just sitting at idle in neutral after driving for 30 minutes. Suggest TPS or IAC replacement?
Reply With Quote
Sponsored Links
Advertisement
 
  #16  
Old 10-04-2014, 11:32 AM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,281
Thanks: 59
Thanked 12 Times in 12 Posts
Rep Power: 3915
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: High Engine RPM on Startup

Iac
Reply With Quote
  #17  
Old 10-04-2014, 11:33 AM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,281
Thanks: 59
Thanked 12 Times in 12 Posts
Rep Power: 3915
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: High Engine RPM on Startup

Totally irrelevant but subaru 2.0l and 2.5l have iacv issues Alot! So your symptoms are iacv
Reply With Quote
  #18  
Old 10-04-2014, 11:57 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,615
Thanks: 23
Thanked 424 Times in 409 Posts
Rep Power: 529936
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: High Engine RPM on Startup

Erratic idle like you have is the TPS. A faulty IAC would give a constant idle (high or low) and a fault code for the IAC.
Erratic is normally the TPS. If you have a scanner which shows live data, you can see the TPS % going up and down a bit. Its normally around 12 % at idle.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #19  
Old 10-05-2014, 12:06 PM
Member
 
Join Date: Dec 2009
Location: las vegas, nv
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2768
intlaero is on a distinguished road
Re: High Engine RPM on Startup

Thanks, no fault codes. I took the TPS off but no obvious faults. Desert weather here with temps well into the 100's during summer so plastic and rubber parts just cook. Jeep is over 11 years old with only 78k miles. I'll get a replacement and see if that fixes the issue.
Reply With Quote
  #20  
Old 10-14-2014, 10:22 PM
Member
 
Join Date: Dec 2009
Location: las vegas, nv
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2768
intlaero is on a distinguished road
Thumbs up Re: High Engine RPM on Startup

I removed and inspected and replaced the TPS and strangely, the problem went away. This confirmed the TPS was the problem. I bought a new Mopar TPS, $100, and installed it and start up idle is back to normal. Thanks Frango100 for all the great advice.
Reply With Quote
  #21  
Old 10-16-2014, 08:57 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,615
Thanks: 23
Thanked 424 Times in 409 Posts
Rep Power: 529936
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: High Engine RPM on Startup

Good to hear its fixed, happy jeeping.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High RPM and fuel consumption while driving K_SRT8 Trouble Shooting/Problems/Service 11 11-19-2012 06:13 PM
Which part(s) to change when engine shakes at startup? Laredo2006 Engine Performance/Intake/Exhaust 1 10-18-2012 04:13 PM
GC CRD 2012 RPM too high? wimbers Diesel Powered 2012+ Export Grand Cherokee 12 07-20-2012 04:30 AM
Hemi startup RPM cypressres Trouble Shooting/Problems/Service 5 04-02-2011 12:14 PM
02 high RPM 02 WJ 4.7 V8 Engine Performance/Intake/Exhaust 8 04-18-2010 09:15 PM

» Premium Vendor Showcase
Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:25 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.