Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-27-2011, 10:09 PM
New Member
My Jeep: 1999 4.7L
 
Join Date: Oct 2011
Location: Hill AFB UTAH
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
4923CREW is on a distinguished road
High idle but clean intake and IAC port????

Hello all,
I am having an issue where my 4.7L is idling high randomly. I have taken off the throttle body and thoroughly cleaned all carbon off of it and still the issue exists where when I am in gear the RPM is at about 1500 and if you put it in to PARK the rpm then goes rapidly up to about 2500 RPM. Also some times if I just restart the motor it will be fine (normal) for a while.

Is there a way of testing the IAC? also could this me a PCM issue that is just annoying me?

thanks for your help

jeremy
__________________

__________________
Reply With Quote
  #2  
Old 10-27-2011, 10:29 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,914
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525867
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: High idle but clean intake and IAC port????

I presume that you removed the IAC stepper motor when you cleaned the TB?
Many times the plunjer of the IAC motor is dirty and the air passage as well.
When you look closely to the IAC motor connector, are the wires properly connected (just wiggle gently to see if there is some wire breakage). If that looks ok, your problem could be the IAC stepper motor itself, or your TPS. You could try wiggling the TPS connector with the engine running and see if idle changes.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 10-28-2011, 10:51 AM
New Member
My Jeep: 1999 4.7L
 
Join Date: Oct 2011
Location: Hill AFB UTAH
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
4923CREW is on a distinguished road
Re: High idle but clean intake and IAC port????

thanks for the quick reply frank. to answer your question i already looed at the wires and all are good. the other thing i forgot was the previous owned just replaced the IAC only ablut 300 miles ago. so heres my new question, could the motor just be stuck and not move?
__________________
Reply With Quote
  #4  
Old 10-28-2011, 02:02 PM
nwb300's Avatar
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Jan 2010
Location: Saginaw, MI
Posts: 202
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1914
nwb300 is on a distinguished road
Re: High idle but clean intake and IAC port????

I agree with the TPS. They are cheap to replace ($32 at Autozone). My RPS went wacky a few months back and I replaced that and it went away. Also, be careful when cleaning the stepper motor. Don't twist the plunger when cleaning it. Its pretty fragile.
__________________

04' Freedom Edition, 4.7 H.O., flowmaster 40 exhaust, semi de-badged, superchips perfomance 91 tune, K&N 57 series FIPK,
FlyinRyan Ported TB, daystar leveling kit, 4" ZONE lift with BDS front upper control arms, Tom Woods custom front driveshaft, IROR adjustable rear A-arm, IROR rear lower control arms, Addco rear 1" sway bar, 32" Grabber AT2's.
Reply With Quote
  #5  
Old 10-30-2011, 03:14 PM
Member
 
Join Date: Jul 2010
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1557
mtp78 is on a distinguished road
Re: High idle but clean intake and IAC port????

Anything is possible and you could have a pcm or IAC issue. First thing you could check is for clean and tight computer grounds on the engine. Any check engine light?

Before you just start replacing parts. If you have acess to a scan tool you can monitor data. You can always scope a tps sensor and see the voltage to real time throttle response. It is a 5 volt refrence input sensor. At idle you should see proper values of .50 to .80 of a volt.

You might also check for a vacuum leak. On a fuel injected vehicle a small leak will cause a idle surge or higher than normal idle speeds.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle Issue RaZX6R Engine Performance/Intake/Exhaust 12 07-13-2011 03:04 PM
Trouble with a high idle speed. Kpurintun Engine Performance/Intake/Exhaust 3 04-29-2011 03:12 PM
High idle j-lien Engine Performance/Intake/Exhaust 3 11-14-2010 04:48 PM
High idle problems farefax Troubleshooting/Problems 24 10-11-2010 06:25 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:22 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community