Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-11-2011, 03:20 PM
RaZX6R's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jul 2011
Location: Wilkes-Barre, PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1182
RaZX6R is on a distinguished road
High Idle Issue

Hello all,
I'm new to these forums... my name's Al and just got a 2004 GC Limited...ok well 6 months ago... and couldnt be happier...until 2 days ago when I was driving on the interstate and floored it to get past someone and ever since then its been idleing at 1800 RPM constant in park and neutral.. changed out IAC and cleaned TB....searched for vacuum leaks in the lines and couldnt find anything.. there is a whistling coming from behind the TB and goes away when in gear or the AC is on... checked the throttle cable but thats fine... was told to drive it after changing the IAC so it can relearn idle settings... still idles high... there are no codes being kicked out at all.....when I drove it today the tranny was acting really weird (was not shifting right it seemed). I'm tearin my hair out tryin to figure this out so any info or experiences with somethin like this that you all can help me out with would be great... Thanks
__________________

__________________
Reply With Quote
  #2  
Old 07-11-2011, 03:36 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54345
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: High Idle Issue

I would check the throttle position sensor. Could be that it is telling the computer to increase the idle to keep the engine running at idle but im not sure on that one. However, I did have a problem with a sometimes erratic idle, and at the end harsh erratic shifting, and then it threw a code for a bad throttle position sensor. I swapped it out and havent had an issue since.
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 07-11-2011, 03:39 PM
RaZX6R's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jul 2011
Location: Wilkes-Barre, PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1182
RaZX6R is on a distinguished road
Re: High Idle Issue

a few people told me to replace the TPS too.... but wouldnt it throw out a code if it were bad?? or is it just that the computer isn't reading it as bad?
__________________
Reply With Quote
  #4  
Old 07-11-2011, 03:43 PM
RaZX6R's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jul 2011
Location: Wilkes-Barre, PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1182
RaZX6R is on a distinguished road
Re: High Idle Issue

oh, and it seems ok on a cold start-up then the rpm's go up as the engine warms up
__________________
Reply With Quote
  #5  
Old 07-11-2011, 04:20 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54345
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: High Idle Issue

It should throw a code but mine acted erratically for a while before the CEL came on. The part only cost me about $35-40 so its fairly inexpensive and very easy to replace. Thats about the extent of my experience, hopefully somebody else will have other ideas.
__________________
Reply With Quote
  #6  
Old 07-11-2011, 05:07 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,892
Thanks: 9
Thanked 91 Times in 86 Posts
Rep Power: 525841
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: High Idle Issue

If you have a scanner you could check the TPS output. Mine in idle normally is at 12%.
When you did clean the TB, did you see that the throttle plate was completely closed? If not, it could be that something is preventing the throttle/cable to return to the full closed position. There could also be a vacuum leak, as you mentioned some noise behind the TB. The PCV line ends somewhere in the inlet duct downstream of the TB, so check this out for loose line or something. Could explain the noise you are hearing. If this is ok, i also would think about the TPS itself.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 07-13-2011, 09:56 AM
RaZX6R's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jul 2011
Location: Wilkes-Barre, PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1182
RaZX6R is on a distinguished road
Re: High Idle Issue

checked the PCV line....and it's totally disconnected at the other end...(behind TB) would this cause the high Idle??? Just makin sure so I dont have to a parts run....Thanks!!
__________________
Reply With Quote
  #8  
Old 07-13-2011, 11:48 AM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54345
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: High Idle Issue

It could, fix that first and see if your idle returns to normal.
__________________
Reply With Quote
  #9  
Old 07-13-2011, 12:17 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652968
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: High Idle Issue

if its disconnected from the intake manifold then YES, you have a large vacuum leak that will cause a high idle!
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #10  
Old 07-13-2011, 02:37 PM
RaZX6R's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jul 2011
Location: Wilkes-Barre, PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1182
RaZX6R is on a distinguished road
Re: High Idle Issue

That was the problem!!!! Thanks guys for all the help...I woulda never checked that line.... and it was quite the PITA to get at but its all good now.....Thank You All again!!!
__________________
Reply With Quote
  #11  
Old 07-13-2011, 02:45 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54345
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: High Idle Issue

Quote:
Originally Posted by RaZX6R View Post
That was the problem!!!! Thanks guys for all the help...I woulda never checked that line.... and it was quite the PITA to get at but its all good now.....Thank You All again!!!
You're welcome, glad you got it working! was the tubing damaged or did it just slip off? If it didnt fit on very tight you might want to replace it or use a wire tie or something to keep it from falling off again.
__________________
Reply With Quote
  #12  
Old 07-13-2011, 02:47 PM
RaZX6R's Avatar
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Jul 2011
Location: Wilkes-Barre, PA
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1182
RaZX6R is on a distinguished road
Re: High Idle Issue

replaced it....it was the wrong sized hose on the intake side (too big) and it popped off...so I changed it out with the correct size and a new clamp
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
low idle and stalling issue SvenskaJeepGuy Troubleshooting/Problems Discussion 11 05-26-2014 05:44 PM
Trouble with a high idle speed. Kpurintun Engine Performance/Intake/Exhaust 3 04-29-2011 03:12 PM
High idle j-lien Engine Performance/Intake/Exhaust 3 11-14-2010 04:48 PM
High idle problems farefax Troubleshooting/Problems 24 10-11-2010 06:25 PM
More idle/stalling issue questions brent Grand Cherokee - WK 50 03-07-2010 01:57 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:34 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community