Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-11-2011, 04:03 PM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Nov 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1154
nrlewellen47 is on a distinguished road
Question Jeep has problems starting

I have a 2004 jeep grand cherokee with a 4.7 V8 in it, bought it back in february. Two days ago i took out the IAC and cleaned it as well as the throttle body because it was running close to 2000rpms when you would start it up. While I was doing that i went ahead and changed my spark plugs (they were WAY overdue to be changed). Put it all back together, took it for a spin and all seemed fine, idling at about 800rpms. Now it wants to turn over a whole mess of times before it wants to start, I have to pump the gas multiple times before it takes off. Once it gets running and is at idle speed, if you just tap the gas you can hear it hesitate as if it is going to stall before it takes off. It also sounds as if one of the headers might have a hole or be cracked (dont think i noticed this sound before i clean the IAC and changed the plugs...but it could have been there) not sure if that has anything to do with it. It seems to be one thing after another with this Jeep.

*update*
I just went back out and listened to the *manifold leak*, and Im pretty sure that is NOT what it is. It makes that sound only at a low idle, between 600-900 rpms. When i rev the engine up to 1000-1200 rpms, this sound goes away. Deos this have anything to do with the starting problem?
__________________

__________________
Reply With Quote
  #2  
Old 11-11-2011, 06:58 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,293
Thanks: 9
Thanked 127 Times in 120 Posts
Rep Power: 526338
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep has problems starting

Are you sure you didn't forget to put back all the hoses? An air leak in fact should increase the idle speed, but you never know.
When cleaning the IAC stepper motor, did you take care to not turn the plunjer? Because when you do, 2 small plastic cams will shear off and the plunjer will most probably not function as required (how do i know that). If it turns with the stepper motor, it will not move in or out.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 11-11-2011, 07:20 PM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Nov 2011
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1154
nrlewellen47 is on a distinguished road
Re: Jeep has problems starting

I did check all the hoses. When i first put it back together I had missed one so i went back and checked them. The is a good chance I turned the plunger, I had read that you shouldnt push them in and out, but had not heard about not twisting them, I guess that would be a good place for me to start. Thanks for the info, I would have never known.
__________________
Reply With Quote
  #4  
Old 11-11-2011, 10:56 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,293
Thanks: 9
Thanked 127 Times in 120 Posts
Rep Power: 526338
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep has problems starting

In fact you can't pull the plunjer out or push it back in. The plunjer has internal thread (kind of spindle like) and the motor external. The 2 plastic cams prevent the plunjer from rotating. When the cams break off (not that much force needed to do so), the plunjer will be free to rotate with the motor and will not open or close the idle air passage anymore.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep not starting FredoinSF Engine Performance/Intake/Exhaust 11 08-24-2011 10:38 PM
Starting problems vwkg Engine Performance/Intake/Exhaust 8 08-10-2011 01:27 PM
Delay in delivery is starting to cause me problems.... rdalcanto Grand Cherokee - WK2 - 3 11-22-2010 10:34 PM
Problem starting Jeep StoneCold Troubleshooting/Problems 15 02-23-2010 07:13 PM
Problems with 2000 4.7 v8 starting StoneCold Engine Performance/Intake/Exhaust 13 02-15-2010 11:09 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.