Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 04-20-2011, 06:32 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,643
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525439
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Lopey idle on an 02' Overland / 4.7HO

The fuel filter is in fact not a regular service item, its more if trouble shooting shows its the problem. But inside the filter is also the fuel pressure regulator, and that one can give some problems sometimes. I also had suddenly a higher fuel consumption and also a gap in power when accelerating at highway speeds. I didn't measure the fuel pressure at the rail, but after changing the fuel filter/regulator, fuel consuption returned to normal (at least for a Jeep) and the acceleration problem was over as well.
You will find quite some info on maintenance at www.wjjeeps.com
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #14  
Old 10-06-2013, 05:32 PM
New Member
My Jeep: 2004 4.7L
 
Join Date: Sep 2013
Location: Birmingham, Al.
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
rdradcliffe is on a distinguished road
Re: Lopey idle on an 02' Overland / 4.7HO

I had some of the same issues with 04 JGC limited Quadra. Rev's up almost 1800 rpm at a start, tranny downshifting then up shifting, cruise at 70mph and the RPM's would raise 300rpm then drop back. It was horrible to drive, didn't know what to do as no check engine code. I watched this forum and BINGO! replaced the TPS and start up is normal, idle is great, shifting is like a new tranny, cruise if perfect 70mph and 2000 rpm and it stays level. FIXED!! Thanks so much for all of the post and helping me fix my JGC.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
3.6 Overland - Shudder? while in idle but driving in a parking lot HEADSHOCK Trouble Shooting/Problems/Service 48 04-26-2011 11:50 AM
What spark plugs go into an 02' GC Overland with the 4.7 HO engine jpilk99 Engine Performance/Intake/Exhaust 17 01-16-2011 01:23 PM
02' Overland - want some beefier tires... jpilk99 Wheels/Tires/Brakes 5 12-29-2010 08:26 PM
04 4.7ho into 02 4.7ho. help please HxcJohnny Engine Performance/Intake/Exhaust 5 12-15-2010 10:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community