Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-02-2011, 08:02 PM
New Member
 
Join Date: Aug 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
CAM MASTER is on a distinguished road
No idle on a 03 w 4.0l

Can't find a discussion on this yet, so I'll ask. My 03 GC keeps giving me the same idle control code and it will not idle on cold start. Have replaced the TPS(broke it on removal) and IAC valve. Cleaned the TB, replaced base gasket. New fuel filter. Replaced cracked hoses found after smoking the system to no avail. Did find a lot of smoke coming from the TB linkage shaft area. New O2 sensors, however the "lean conditions" persists. Other than replacing the TB with a new one I humbly ask the forum members for suggestions.
Among other symptoms there is stalling when taking off.

Thanks
__________________

__________________
Reply With Quote
  #2  
Old 08-02-2011, 08:45 PM
Chaoul1's Avatar
The Original

My Jeep: 2010 6.1L WK
 
Join Date: May 2009
Location: Fairfax, Virginia
Posts: 6,913
Thanks: 2
Thanked 24 Times in 24 Posts
Rep Power: 63327
Chaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond reputeChaoul1 has a reputation beyond repute
Re: No idle on a 03 w 4.0l

Crank Sensor?
__________________

__________________
-Paul-
2010 Jeep Grand Cherokee SRT8

PaulsProfessional Automotive Detailing

PPAD's Custom Headlights

Contact for both DetailingPPADscustomwork@yahoo.com
Reply With Quote
  #3  
Old 08-02-2011, 08:45 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 582
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2617
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: No idle on a 03 w 4.0l

You get a lean code? How many miles and have you replaced the fuel filter? If it's a 03 and the original filter, it's probably due for a new one.
__________________
Reply With Quote
  #4  
Old 08-02-2011, 08:57 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,644
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525442
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: No idle on a 03 w 4.0l

Which code(s) you exactly have?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 08-02-2011, 09:13 PM
New Member
 
Join Date: Aug 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
CAM MASTER is on a distinguished road
Re: No idle on a 03 w 4.0l

Thanks for taking the time. Yes, new FF on Saturday. New O2s back in April. Still lean on both sensors. Have not thought about the crank. Frango, will have to hook it up again to get you specific #s and actual descriptions. About 140K miles and 2WD.
__________________
Reply With Quote
  #6  
Old 08-05-2011, 03:08 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652903
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: No idle on a 03 w 4.0l

what brand O2 sensors were installed? chryslers dont like aftermarket sensors for some reason.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #7  
Old 08-15-2011, 10:55 AM
New Member
 
Join Date: Aug 2011
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
CAM MASTER is on a distinguished road
Re: No idle on a 03 w 4.0l

Sorry for the late response, I managed to blow my radiator and had to play mechanic for 4 hrs. (never claimed to b skilled at "mechaniking") replaced rad, fan relay and motor. Thanks to a friend's generosity was able to use all his tools and space. Did not have a scanner only a code reader.

Pulled codes again and gave me PO505 as IAC malfunction. Runs a lot better after "upgrading" the cooling system, however I still have inconsistent idle.
Thx for any help!
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Won't idle westcoast Engine Performance/Intake/Exhaust 9 01-30-2011 10:23 AM
Squeaky idle. JeepKid Grand Cherokee - WK 3 11-14-2010 09:45 PM
High idle j-lien Engine Performance/Intake/Exhaust 3 11-14-2010 04:48 PM
idle problem cameo571 Trouble Shooting/Problems/Service 2 11-12-2010 04:32 AM
Idle at what RPM? White05 Grand Cherokee - WK 4 06-17-2010 12:07 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community