Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-11-2011, 04:45 PM
Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1526
ylimits will become famous soon enough
Not Running Right...

Ok this is kinda of hard to explian but I will do me best I have a 2004 limited and sometimes it runs fine but other times when im driving and i nail the gas to pass someone all it seems to do is bog or just really not pick up speed at all but other time i can nail it and it will set u back in the seat i hope yall can help me out on this one. Also there are no codes and the check engine light does not come on.
__________________

__________________
Reply With Quote
  #2  
Old 03-11-2011, 07:18 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,753
Thanks: 827
Thanked 806 Times in 622 Posts
Rep Power: 7717320
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Not Running Right...

4.7 v8 ho.....hmmmm...let me do some thinkin'
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 03-11-2011, 11:33 PM
Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1526
ylimits will become famous soon enough
Re: Not Running Right...

im sorry i forgot to put that it is not an ho
__________________
Reply With Quote
  #4  
Old 03-11-2011, 11:47 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,753
Thanks: 827
Thanked 806 Times in 622 Posts
Rep Power: 7717320
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Not Running Right...

no traction control light or can you feel traction control kick in?
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #5  
Old 03-12-2011, 12:07 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12305
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: Not Running Right...

Does your engine die?

If not check your transmission fluid level and see if there's a leak from the pan. Usually if it's low in fluid the torque converter is not catching right and it's slipping therefore causing it to bog at times and when it does catch it goes.

That's the cheapest and easiest check if that doesn't work we can try guiding you through the next steps
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #6  
Old 03-12-2011, 09:15 AM
Member
 
Join Date: Jun 2010
Posts: 23
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1526
ylimits will become famous soon enough
Re: Not Running Right...

Checked the tranny fluid and its fine it was. and no traction control light and i dont feel it kick in at all.
__________________
Reply With Quote
  #7  
Old 03-12-2011, 12:26 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,648
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525447
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Not Running Right...

Do we have a traction control light on our WJs? Or do you have a 2004 WK?
I had a similar problem some time ago, it was only always there and not once in a while. Driving around town all ok, but when accelerating on the highway there was just lack of power. Passing some other car was just a risky thing. After changing my fuel filter/pressure regulator the problem was solved. Problem could also be with the fuel pump or even with the TPS sensor. If you have the possibility to measure the pressure at the fuel rail, you will know more.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 03-12-2011, 06:49 PM
Member
My Jeep: 2002 4.0L WJ
 
Join Date: Jan 2011
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1302
bigboy189 is on a distinguished road
Re: Not Running Right...

"Driving around town all ok, but when accelerating on the highway there was just lack of power." the tps sensor did it for me
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone running Kumhos? 1_\/\_WK Off Road Modifications 3 12-24-2010 02:31 PM
Running boards on my WK suzieque Off Road Modifications 9 04-22-2010 01:03 AM
running new exhaust jdcollins86 Engine Performance/Superchargers/Turbos 2 02-25-2010 12:30 PM
Anyone running a EGT on their 5.7 or 6.1? Escape Performance Modifications 0 11-29-2009 09:53 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community