Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-26-2012, 05:55 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Oct 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 580
04JGCSpecialEdition is on a distinguished road
Rough Start after install CAI

I have installed a K and N on my 04 4.0L. Cold starts are perfect but if the engine is any bit warm I have issues. Rough starts and sometimes seems like it wants to just shut off. During a rough start if I try to rev the enigine the Intake will back fire. Any ideas??? I also just recently changed the spark plugs
__________________

__________________
Reply With Quote
  #2  
Old 11-01-2012, 05:40 AM
JeepFreak12's Avatar
Premium Member
My Jeep: 2010 6.1L SRT8
 
Join Date: Mar 2011
Location: Roseville, Michigan
Posts: 1,487
Thanks: 56
Thanked 43 Times in 43 Posts
Rep Power: 7475
JeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond reputeJeepFreak12 has a reputation beyond repute
Garage
Re: Rough Start after install CAI

Maybe something became unplugged on the install. Did you check the boots running to your spark plugs to see if they are on all the way? If not it would misfire and cause rough idle.
__________________

__________________
Reply With Quote
  #3  
Old 11-03-2012, 07:08 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,330
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Rough Start after install CAI

Did you check if any error code is set? (ignition switch off/on 3 times and leave it in on at the third time. The odometer will show "Done" when all ok, or error code(s).
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 11-07-2012, 12:22 PM
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Oct 2012
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 580
04JGCSpecialEdition is on a distinguished road
Re: Rough Start after install CAI

No error codes... If the boots weren't fully seated wouldn't it be a constant thing instead of when the engine warms up?
__________________
Reply With Quote
  #5  
Old 11-21-2012, 03:27 PM
Gus9890's Avatar
Premium Member
My Jeep: 2001 4.0L WJ
 
Join Date: Apr 2011
Location: Amelia Island, FL
Posts: 4,061
Thanks: 38
Thanked 32 Times in 31 Posts
Rep Power: 407367
Gus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond repute
Re: Rough Start after install CAI

Sounds like something may have got knocked a lil loose during install
__________________
2001 Silverstone Metallic WJ Limited:
Gen III Clear/Chrome Projector/CCFL Halos/LEDs, 8K HIDs, 8K HID Projector/Halo fogs, Clear/Chrome Tail Lights and 3rd Brake Light with LEDS, Diamond Mesh Upper and Lower Fascia, Spectre CAI, Breather Filter, Cabin Air Filter, Low-Temp Thermostat, Jet Stage 1 Chip, MagnaFlow Exhaust with Resonator Tip, Shorty Antenna, Front/Back De-badged
Reply With Quote
  #6  
Old 11-26-2012, 03:31 PM
FlyinRyan's Avatar
Senior Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jul 2009
Location: Fort Myers, Florida
Posts: 2,797
Thanks: 33
Thanked 29 Times in 28 Posts
Rep Power: 87938
FlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond repute
Send a message via AIM to FlyinRyan
Re: Rough Start after install CAI

Sounds like it is fuel pressure related
__________________

__________________
Due to my workload, please do not PM me as I do not regularly check my PMs. Thank you :)
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
8.7 MPG After TB / CAI install??!? mcalc55 Troubleshooting/Problems 11 06-27-2012 05:25 PM
Mopar CAI install instructions foster Tech Tips/DIY/How To 1 02-29-2012 12:36 AM
K"&N CAI Intake install question Metz1374 Engine Performance/Intakes/Exhausts 9 11-20-2011 12:55 AM
Rough idle on first start of the day rhodesian Grand Cherokee - ZJ 2 11-13-2010 05:58 PM
Rough WJ OBA install 206WJ Off Road Modifications 2 02-12-2010 03:33 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:18 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community