Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-29-2011, 02:36 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Starting problem

I've got an 03 grand cherokee laredo. I replaced the battery about two weeks ago. I just tried to start the car and it wouldn't. Everything lights up but the engine won't even crank. Back when the battery was bad if I tried to crank the engine i'd get a clicking noise, but i dont get a noise this time around. any ideas?
__________________

__________________
Reply With Quote
  #2  
Old 07-29-2011, 03:02 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,801
Thanks: 37
Thanked 60 Times in 59 Posts
Rep Power: 54276
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Starting problem

That clicking noise is the starter solenoid. If you get lights but absolutely no click when you try to turn over the engine either you are not getting any power at all to the solenoid or it went bad. Check the fuses and relay for the starter first, then make sure the cables to the starter are good. If that all checks out ok then most likely the solenoid/starter motor needs replacing. I believe they are all one unit. Hope this helps you.
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 07-29-2011, 03:27 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,647
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525446
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Starting problem

The starter relay is in the PDC and there are several other same relays in there, so you can swap them for trouble shooting. If this doesn't help, you could hit the solenoid with a hammer or so (not too hard ofcourse) and see if that helps. If yes, your solenoid is bad.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 07-29-2011, 03:36 PM
New Member
My Jeep: 2007 3.7L WK
 
Join Date: Jul 2011
Location: Puerto Rico
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Mrkritter is on a distinguished road
Re: Starting problem

I had the same problem first was the starter, changed it and the problem was fixed and then the same symptom but was the battery.
__________________
Reply With Quote
  #5  
Old 07-29-2011, 03:50 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Re: Starting problem

I tried the hammer trick, nothings working. and i get absolutely 0 clicking noise
__________________
Reply With Quote
  #6  
Old 07-29-2011, 04:22 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Re: Starting problem

I checked all the wiring, fuses, and relays and everything looks good. the dealership told me that it could be either the starter, the ignition switch, or the neutral switch. whats next?
__________________
Reply With Quote
  #7  
Old 07-29-2011, 04:29 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Re: Starting problem

actually it just came to my attention that the starter relay thats in the fuse box under the hood isnt the only starter relay, does anyone know the location of any other starter relays on an 03 WJ?
__________________
Reply With Quote
  #8  
Old 07-29-2011, 04:44 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,801
Thanks: 37
Thanked 60 Times in 59 Posts
Rep Power: 54276
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Starting problem

There are some fuses under they dash on the drivers side, also on the side of the dash when you open the passenger door i believe. Your manual should say, if you dont have one check out http://wjjeeps.com/fuses.htm. Try wiggling your trasmission shifter, I had a problem like that on my old ZJ where the neutral switch was going out, wiggling the shifter would be enough for the switch to make contact and allow the vehicle to start.

Could be ignition switch, but the only time I have seen problems with that you would know it when you tried to turn the key, it would be loose instead of offering resistance.

Good luck!
__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #9  
Old 07-29-2011, 05:47 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Re: Starting problem

replaced starter and didnt solve my problem...next best guess is the neutral switch im guessing?
__________________
Reply With Quote
  #10  
Old 07-29-2011, 06:09 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,647
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525446
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Starting problem

There should be only one starter relay and one starter solenoid. The relay is in the PDC and it switches the current to the solenoid, which is part of the starter. The solenoid in its turn connects the starter motor to the engine and switches the high current to the starter motor. There is a 40 A fuse in the PDC (fuse 8) and a 10 A fuse on the junction block (fuse 31), under the steering wheel.
Did you feel on the starter relay if it clicks when you try to start? The click is very light, so you really have to feel it. When no click, most probably everything after the relay is ok and your problem is the neutral switch or ignition switch. You could remove the starter relay and check for 12 V between point 86 and ground when trying to start. When ok, your ignition switch is ok.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #11  
Old 07-29-2011, 06:13 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Re: Starting problem

I checked all of the fuses and relays and everything was ok. I replaced the entire solenoid/starter and that didn't solve my problem. I was told that if it was the ignition switch that needed to be replaced then there wouldn't be much resistance when i turn the key but there is...so neutral switch is probably the problem right? Where exactly is the neutral switch located?
__________________
Reply With Quote
  #12  
Old 07-29-2011, 06:57 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Jul 2011
Posts: 68
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1163
jdb2797 is on a distinguished road
Re: Starting problem

ok so i took a look at what i believe is the neutral safety switch. it was above the oil pan and pretty easily accesible. what i found was what almost looks like something chewed through the wiring. now the wire still connected to the neutral switch is much to short to connect via connector butts or anything of the sort? im 150 miles from home. what can i do to get it working so i can get home?

im not sure if it is the neutral safety switch that i found though because it looks nothing like the pictures ive seen or pictures of replacement parts
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ZJ Not starting...??? Navigtor Grand Cherokee - ZJ 21 11-06-2012 08:52 PM
05 Limited GC 5.7 Hemi starting problem rfctexas Troubleshooting/Problems 16 10-28-2012 06:34 PM
jeep starting problem jdubgrand Grand Cherokee - WK 10 07-03-2011 04:14 PM
Weird Starting Problem silversx05 Grand Cherokee - WK 7 06-06-2010 06:43 PM
Problem starting Jeep StoneCold Troubleshooting/Problems 15 02-23-2010 07:13 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:08 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community