Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-17-2010, 11:48 AM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2010
Location: Sheffield UK
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1575
pitman1031 is on a distinguished road
WJ 4.7 2000 starting probs when cold

Does anyone have any ideas why my WJ 4.7 takes around 5 seconds of cranking when cold before the engine starts and then runs perfectly. This car has done 114000mls and is fully serviced.
__________________

__________________
Reply With Quote
  #2  
Old 05-17-2010, 03:10 PM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,214
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153406
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: WJ 4.7 2000 starting probs when cold

Could be dirty IAC valve, throttle body needing cleaned. I cleaned both of mine and that stopped the problem

I imagine if it's been fully serviced it's not the spark plugs, but you never know.

Only other thing coud be fuel pump or filter.

Try turning the key to full on, so the dash lights up, but don't actually start it, wait a couple of seconds and start it. If it starts ok, it's possibly fuel pump. I'm sure there's an o ring in the pump that can go bad.
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #3  
Old 05-20-2010, 03:41 PM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2010
Location: Sheffield UK
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1575
pitman1031 is on a distinguished road
Re: WJ 4.7 2000 starting probs when cold

I dont think its the fuel pump oring as leaving the ignition on makes no difference, where's the IAC valve situated ?
__________________
Reply With Quote
  #4  
Old 05-20-2010, 04:04 PM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,214
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153406
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: WJ 4.7 2000 starting probs when cold

It's on the lower right side of the TB. Just disconnect the plug and take out the two screws (torx T20).

I posted something about this before, hang on I'll go look for it

Found it, just scroll down to the pics

http://jeepgarage.org/showthread.php...701#post189701

Should be good to go at that.


Aaron
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #5  
Old 05-20-2010, 05:58 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,706
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525523
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: WJ 4.7 2000 starting probs when cold

Leaving the ignition on for more then a few seconds with the engine off will not make a difference, because as soon as the ignition is turned on, the fuel pump starts for 3 seconds and shuts off, until you start the engine. If the O'ring is really bad, waiting longer will only reduce more the fuel pressure. Maybe you can switch the ignition on for 3 seconds, switch it off and on again and try to start quickly. But only a fuel pressure test will show you if the pressure will stay (as it should for quite some time) , or drops quickly, which could be the O'ring of the fuel pump, or the fuel filter/pressure regulator.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 05-21-2010, 11:34 AM
Member
My Jeep: 2004 4.7 HO WJ
 
Join Date: Apr 2010
Location: Sheffield UK
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1575
pitman1031 is on a distinguished road
Re: WJ 4.7 2000 starting probs when cold

Thanks boys I am on it..
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ZJ Not starting...??? Navigtor Grand Cherokee - ZJ 21 11-06-2012 08:52 PM
Starting issues JeepKid Grand Cherokee - WK 13 05-02-2010 03:39 PM
Not starting... Gunswinger Troubleshooting/Problems 8 04-03-2010 08:26 PM
Trouble Starting 99 4.7 jimd4x4 Troubleshooting/Problems 4 03-16-2010 02:03 PM
Problems with 2000 4.7 v8 starting StoneCold Engine Performance/Intake/Exhaust 13 02-15-2010 11:09 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community