Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Engine Performance/Intake/Exhaust

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-30-2011, 09:44 AM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Angry wj acceleration problems

02 WJ 4.7L with 90k miles engine problems or transmission problems… starts fine , good low end power but as you accelerate power dies off - dash lights blink trans light blinks “trans over heat” light comes on…no codes through.. I installed new plugs and air filter no change. condition does not seam to happen all the time. Also just did trans fluid and filters. Still does not want to power up any suggestion appreciated
__________________

__________________
Reply With Quote
  #2  
Old 01-30-2011, 09:50 AM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,220
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153439
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: wj acceleration problems

What trans fluid did you use and how much did you put in? Could you have knocked a sensor when you changing the filter?
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #3  
Old 01-30-2011, 10:01 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,796
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: wj acceleration problems

Did you have those problems before changing plugs and fluids? Does it feel like the tranny/torque converter can not transfer the torque, or does it feel like the engine doesn't have enough power? I had some similar problem on my WJ. It was driving normally, but when accelerating it was lacking power. After changing the fuel filter/pressure regulator my problem was solved. Strange though that you also have the TRANS OVERHEAT light on. Is this light on all the time?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 01-30-2011, 10:18 AM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Re: wj acceleration problems

This problem was happening before the Trans fluid change; I used ATF+4 fluids as per spec. And it feels to me like it is some kind of computer problem like a sensor is telling the unit to go to survival mode and limp home
__________________
Reply With Quote
  #5  
Old 01-30-2011, 11:20 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,796
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: wj acceleration problems

Is the tranny not changing gears? You probably have to go to some place where they can read the tranny faults. It can be an input/output sensor problem or some other senor in the tranny.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 01-30-2011, 11:33 AM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Thumbs up Re: wj acceleration problems

Trans changes gears fine.. just came back fron auto store and if i accerelate real easy it runs fine, as soon as i ask it to get up an go it stumbles if i keep accerelating it would probley stall when i baby it it will act normal and i can get it up to 60mph I am checking fuel rail pressure next thanks for the help
__________________
Reply With Quote
  #7  
Old 01-30-2011, 03:00 PM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Re: wj acceleration problems

just changed the throttle position sensor no luck. still will only run to anbout 1/2 throttle and than breaks up error code 0300 "all cylinders misfire" ananyone been here please help
__________________
Reply With Quote
  #8  
Old 01-30-2011, 04:00 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,796
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: wj acceleration problems

Not sure if this could have to do with a cam or crankshaft sensor.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 01-30-2011, 09:49 PM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Re: wj acceleration problems

2002 jeep Grand Cherokee, Limited Silver with Black leather oil changed every 3000, K wife’s car babied been on the beach a couple of times but 99 percent a commuter car to and from work a (5 mile commute)

Started out the coldest day of the year 5 degrees. jeep gave wife problems did not want to get her to work. had code 0203 number 3 cylinder injector failure. I took # 3 injector out and switched it with number 4 injector no problem - no code but jeep still does not want to run pass ˝ throttle if you baby it will run as soon as you push it quits.

Day two Replaced spark plugs with Mopar copper core # Mopar® P/N SPRC12MCC4
No change still quits above 50% throttle position
Pass ˝ throttle if you baby it will run as soon as you push it quits


Day three had Trans code over heat so I changed the Trans fluid with ATF+4 fluid and both filters took for test run code 0300 “all cylinder misfire “
No change still quits above 50% throttle position
Pass ˝ throttle if you baby it will run as soon as you push it quits


Day four replaced throttle body position sensor no change to performance
Still quits above 50% throttle position “all cylinder misfire”
Pass ˝ throttle if you baby it will run as soon as you push it quits

Day four replaced manifold air sensor
No change to performance
Still quits above 50% throttle position “all cylinder misfire”
Pass ˝ throttle if you baby it will run as soon as you push it quits. If you turn off key rough idle goes away but as soon as you push it pass 50% accelerator miss returns it will run a low speed all day long but as soon as you ask it to perform it gets all choked up a quits

Does mopar have a shrink I can sent this unit too because I am at my wits end
__________________
Reply With Quote
  #10  
Old 01-31-2011, 07:46 AM
cheapjeep's Avatar
Amber Instigator
My Jeep: 1997 2.5L TJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,101
Thanks: 97
Thanked 68 Times in 64 Posts
Rep Power: 331897
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: wj acceleration problems

I would check the fuel pressure at the rail and if low change the filter/regulator like Frango did.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #11  
Old 01-31-2011, 07:56 AM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Re: wj acceleration problems

Thanks I did check fuel pressure at rail and it was 50 psig and held for quite a while so I don't think that is the problem…. I also do not think it is the trans because the miss accrues in neutral when the accelerator is pushed pass 3000rpm runs fine up to 3000rpm than stumbles if I shut it off and restart the miss is gone until I accelerate past 3000k.
__________________
Reply With Quote
  #12  
Old 01-31-2011, 10:11 AM
Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jan 2011
Location: new jersey
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1321
patriotmfd is on a distinguished road
Re: wj acceleration problems

I am down to three item’s either the crank position sensor CPS or the engine control module ECM unit is malfunctioning or possibly the catalytic convertor is somehow restricted. The CPS I have purchased from Mopar but I can not see it and it appears like a difficult job… has anyone had experience doing this replacement? (Most problems with the CPS seam to be they fail when the car heats up an restores after cool down) my problem is fairly consistent.

All help is appreciated thanks
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
rattle on acceleration jdubgrand Troubleshooting/Problems 23 06-03-2013 11:44 AM
3.6 slight whistle on acceleration jeepin4ever Grand Cherokee - WK2 - 7 12-23-2010 10:16 PM
Stalls on acceleration Canyon Dancer Trouble Shooting/Problems/Service 9 10-30-2010 10:31 AM
Still stalls on acceleration NJ99 Engine Performance/Intake/Exhaust 17 10-10-2010 01:14 AM
Dip in acceleration Frango100 Engine Performance/Intake/Exhaust 10 04-13-2010 11:38 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:07 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community