Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Interior/Exterior/Visual

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-16-2011, 10:39 AM
JeepinInBlacK's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Oct 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1465
JeepinInBlacK is on a distinguished road
Please help!

I connected my halos yesterday and all of a sudden my turn signals don't work not inside outside front or back! I connected my LEDs to my blinkers and everything was working fine at first but then at night I found out they went working at all! so I thought that would be the problem but then I took out the LEDs from the blinkers but still no turn signals. Do you guys have any ideas on what might be the problem any help will be appreciated thanks!
__________________

__________________
[SIGPIC][/SIGPIC]
New TOY!
1979 z28 Camaro!
Reply With Quote
  #2  
Old 04-16-2011, 02:07 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,925
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525880
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Please help!

Did you check the fuses?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 04-16-2011, 04:36 PM
JeepinInBlacK's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Oct 2010
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1465
JeepinInBlacK is on a distinguished road
Re: Please help!

I just did and it was burnt andi switched itand blink, blink haha thanks frango
__________________
[SIGPIC][/SIGPIC]
New TOY!
1979 z28 Camaro!
Reply With Quote
  #4  
Old 04-16-2011, 04:52 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,925
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525880
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Please help!

Yeh, when something electrical stops working suddenly, always first check the fuses before tearing down anything. But that the fuse melted is a sign that some shortage occured or too much current was applied.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:38 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community