Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Wheels/Tires/Brakes

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-03-2014, 08:48 AM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Nov 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 709
girard215 is on a distinguished road
ABS Issue

Need some input on a brake issue. I have 2000 Grand Cherokee and the ABS pump will activate intermittently under normal dry surface braking. I scanned it with a brake scanner and it gave 2 codes
1. Right front wheel speed sensor
2. ECM internal failure.

I replaced the wheel speed sensor and the ABS pump and also the vehicle speed sensors on the transmission.
Can someone explain what the ECM failure means and where the ECM is located?
__________________

__________________
Reply With Quote
  #2  
Old 05-03-2014, 10:53 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,056
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526043
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: ABS Issue

The ECM is the electronic control module. It is mounted to the ABS HCU ( hydraulic control unit), which also has the pump in it. Did you check the ABS fuses?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 05-06-2014, 06:51 AM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Nov 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 709
girard215 is on a distinguished road
Re: ABS Issue

Yes I checked both fuses and they are good. I have pulled the one under the dash so I can drive it.
__________________
Reply With Quote
  #4  
Old 05-06-2014, 06:55 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,056
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526043
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: ABS Issue

So you said you changed the pump, i presume that you changed the whole assy of HCU, ECM and pump? Does it still give the ECM as fault?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 05-06-2014, 12:23 PM
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Nov 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 709
girard215 is on a distinguished road
Re: ABS Issue

Yes I did change the whole module which I now know included the ECM and I no longe get any codes but still have the issue.
__________________
Reply With Quote
  #6  
Old 05-07-2014, 07:32 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,056
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526043
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: ABS Issue

I would have a look at the other wheel speed sensors if they are fixed well and if the wires to them are not rubbing against something.
You changed the transmission sensors you said? You probably have the 5-45RFE transmission, which has an input and output speed sensor, but none of them are used for vehicle speed. Vehicle speed is coming from both rear wheel speed sensors via the ABS controller.
There is furthermore a G sensor mounted under the rear seat. The input from this sensor is also used, together with the wheel speed sensors, to calculate the wheel slip. The system doesn´t wait until a wheel is really slipping, but already modulates the braking pressure when the wheel speed differs around 30 % from the actual vehicle speed. There are three channels for control, one channel for each front wheel and a single channel for both rear wheels.
One other thing, did you check your shocks? A bad working shock can cause a wheel loosing contact with the ground and this could activate the ABS to release that brake.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Liberty odometer/ABS issue Redriver65 SouthWest 0 03-22-2014 10:04 AM
ABS issue blown84 Troubleshooting/Problems Discussion 2 12-08-2013 07:57 PM
Diablo Trinity new update 1R10A ABS disable issue damien79 Grand Cherokee - WK2 - 5 09-01-2013 06:10 PM
ABS Brake module/ABS lamp on GreggyBear Grand Cherokee - ZJ 1 04-03-2011 10:09 AM
Switch to disconnect the ABS pump fuse Tim@NCTSLLC Performance Modifications 2 10-26-2009 10:15 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:24 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.