Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-14-2012, 09:12 AM
Member
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 780
sergioad89 is on a distinguished road
Thumbs up 01 auto 4.0 - CEL after fill-up?

I'm not an expert or mechanic, but I think I know most terms by now because I've had this problem for a while now...

Here is the brief: Sunday I filled up the tank, and ti ran fine for 55 miles, after which it sat for 5 hours, and then turned on, and it REV'd up to ~3.5k before wanting to shift (i had to play with pedal & no CEL yet).

Then I parked it somewhere, adjusted the kick down cable, turned it back on which it now had the CEL on. It wouldn't rev up to 3000 anymore, but it wouldn't rev up to the regular 2k rpm before shifting to 2nd (hard acceleration/hesitation/low speed from stop/red light). All other gears seemed fine.

This morning, I drive 0.2 miles to the gas station, put 3 gallons in, and the car goes back to the ~3.5k rev before "wanting" to shift. It was fine after it shifted to 2nd and beyond.

And so I'm more leaning to believe that it only happens every time I open my gas tank door and stick it in (as wrong as that may sound)... Car is parked as I'm at work now, so I will update when I leave for home.

Any ideas on what it could be? I got the governor sensor/solenoid replaced.

Spark Plugs? MAF? TPS? O2 Sensor? Fuel Filter?
__________________

__________________
Reply With Quote
  #2  
Old 06-14-2012, 09:35 AM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 48,737
Thanks: 816
Thanked 797 Times in 617 Posts
Rep Power: 7717301
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: 01 auto 4.0 - CEL after fill-up?

pull the code
__________________

__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED Edition" 1 of 1
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2013 JKU 10th anniversary-white
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #3  
Old 06-14-2012, 10:36 AM
Member
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 780
sergioad89 is on a distinguished road
Re: 01 auto 4.0 - CEL after fill-up?

Last 2 times I pulled code, it was P1757 and P1762/3 codes.

I'll check codes today when I get home, but what if they are those 2 codes again?
__________________
Reply With Quote
  #4  
Old 06-14-2012, 11:16 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,642
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525438
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 01 auto 4.0 - CEL after fill-up?

Yes, pulling the codes is the first step to see what is wrong. Where the governor pressure sensor/solenoid replaced for the same symptoms you have now?
If you get all 3 codes back again, then have a look at the fuses 5 (30A) and 28 (15A) in the Power Distribution Center and swap the transmission control relay with auto shutdown relay.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 06-14-2012, 11:33 AM
Member
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 780
sergioad89 is on a distinguished road
Re: 01 auto 4.0 - CEL after fill-up?

Quote:
Originally Posted by Frango100 View Post
Yes, pulling the codes is the first step to see what is wrong. Where the governor pressure sensor/solenoid replaced for the same symptoms you have now?
If you get all 3 codes back again, then have a look at the fuses 5 (30A) and 28 (15A) in the Power Distribution Center and swap the transmission control relay with auto shutdown relay.
The first time, mechanic cleaned some plug/cable that went from transmission to somewhere (engine?), and after that the car ran like before.

Second time, same symptoms, he replaced the cable from junker, and put in sensor/solenoid.

Third time, to be continued...
__________________
Reply With Quote
  #6  
Old 06-14-2012, 12:02 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,642
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525438
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 01 auto 4.0 - CEL after fill-up?

Ok, let us know the codes first. i presume that you know that you can pull the codes yourself using the key dance: ignition switch off/on 3 times and leave it in on after the third time, the odometer will show the fault codes one by one or DONE when no faults set. I presume that the fault where cleared from the memory after the repair was done?
The gov pressure sensor and solenoid where no junkyard parts i presume?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 06-14-2012, 09:56 PM
Member
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 780
sergioad89 is on a distinguished road
Re: 01 auto 4.0 - CEL after fill-up?

The code shows up in odometer... P1762. Only one this time...

Gov. and Solenoid were from junker.
__________________
Reply With Quote
  #8  
Old 06-15-2012, 08:30 AM
Member
 
Join Date: Jun 2012
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 780
sergioad89 is on a distinguished road
Re: 01 auto 4.0 - CEL after fill-up?

Update:

Last night, the CEL went off, and the car ran like before... great shifting, great speed, great acceleration..

However, when doing the key dance, it still shows P 1762.

Why is that?
__________________
Reply With Quote
  #9  
Old 06-15-2012, 03:02 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,642
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525438
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 01 auto 4.0 - CEL after fill-up?

Most DTC's only go away after several key cycles (and no fault). You could reset the fault with a scanner or just disconnect the battery for some minutes.
If the code returns and the shifting misbehaves itself again, its probably time for a NEW gov press sensor/solenoid.
Buying this from a junkyard you will never know what you get.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CEL Trouble Lori Compass and Patriot 5 09-20-2012 08:33 AM
How to make a cel? NHWK05 Troubleshooting/Problems 5 05-16-2012 04:39 PM
Cel duce95 Trouble Shooting/Problems/Service 2 05-19-2011 08:16 PM
Wk cel p0562 Camaro614 Troubleshooting/Problems Discussion 4 01-01-2011 04:27 PM
Need help JG!!! CEL AND CODES RYANSWJ Troubleshooting/Problems Discussion 6 06-03-2010 08:59 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community