Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-10-2012, 08:24 AM
djluski's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Nov 2010
Location: White Meadow Lake
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1402
djluski is on a distinguished road
01 gc laredo hard starting...help please

I have an 01 GC Laredo that recently developed an issue starting (on a cold start)....It used to start on the first crank. Then it would start on the 2nd crank. Like the first crank is always an absolute failure then within 5 seconds of the 2nd crank it would fire up. The problem has gotten worse! Now it starts MAYBE on the 2nd crank and always on the 3rd crank. Once running, it is rough and hesitates for the first 30 seconds of warming up. After this it runs fine on the road. When accelerating, i feel a slight bit of lag when i step on the gas. If i start the jeep after its been running for a while, i only sometimes experience this issue. I am very handy and can handle most repairs myself so any information would be greatly appreciated.

Background info:
Aftermarket Dynamax Muffler
JetChips Power Chip
Cold Air Intake
Throttle Body Spacer (removed since this issue, will reinstall)
__________________

__________________
Reply With Quote
  #2  
Old 06-10-2012, 09:06 AM
FlyinRyan's Avatar
Senior Member
My Jeep: 2002 4.7L WJ
 
Join Date: Jul 2009
Location: Fort Myers, Florida
Posts: 2,801
Thanks: 33
Thanked 31 Times in 30 Posts
Rep Power: 88597
FlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond reputeFlyinRyan has a reputation beyond repute
Send a message via AIM to FlyinRyan
Re: 01 gc laredo hard starting...help please

Keep the spacer off.

I noticed a difference in.starting with replacing the cam position sensor.
__________________

__________________
Due to my workload, please do not PM me as I do not regularly check my PMs. Thank you :)
Reply With Quote
  #3  
Old 06-10-2012, 11:02 AM
djluski's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Nov 2010
Location: White Meadow Lake
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1402
djluski is on a distinguished road
Re: 01 gc laredo hard starting...help please

thanks, i'll try that. where is it located? is it a difficult install?
__________________
Reply With Quote
  #4  
Old 06-10-2012, 05:42 PM
Hitchhiking
My Jeep: 2008 6.1L SRT8
 
Join Date: Nov 2011
Location: middleburg fl
Posts: 909
Thanks: 0
Thanked 10 Times in 10 Posts
Rep Power: 0
kennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond reputekennzz05 has a reputation beyond repute
Re: 01 gc laredo hard starting...help please

plugs, wires? how old
__________________
Reply With Quote
  #5  
Old 06-10-2012, 07:58 PM
djluski's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Nov 2010
Location: White Meadow Lake
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1402
djluski is on a distinguished road
Re: 01 gc laredo hard starting...help please

plugs are relatively new. i think the previous owners got a tune-up at 100K and i currently have 138K. it has coil packs.
__________________
Reply With Quote
  #6  
Old 06-10-2012, 10:35 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,771
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525692
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 01 gc laredo hard starting...help please

Next time try to prime the system first. Put the ignition switch in on and after 3 seconds in off again, repeat this 2 or 3 times and then see if it will start immediately. If it does, you loose the pressure in the fuel rail after some time. This can be caused by the fuel pressure regulator (inside the fuel filter just in front of the tank), or by an o-ring from the fuel pump (inside the tank)
If you would decide to change the cam sensor, its on the RH cylinder head almost at the fwd RH side.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 06-12-2012, 12:58 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652941
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: 01 gc laredo hard starting...help please

If you have an external fuel filter there is a pressure regulator in it... I had a customer come in with a WJ running like a bag of asses, another shop litterally pulled the head off of it and did a head gasket to repair the concern, I knew instantly it was fuel starvation as when you leaned into it, the thing fell on its face... I hooked my fuel pressure gauge up and wouldnt ya know it it was like 15-20 psi, I hooked my gauge up pre filter and had great pressure 55-65psi or so, so I knew the problem was the filter in the regulator.

I agree with frank, it seems like a fuel bleed down issue.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #8  
Old 06-13-2012, 05:50 PM
djluski's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Nov 2010
Location: White Meadow Lake
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1402
djluski is on a distinguished road
Re: 01 gc laredo hard starting...help please

thanks so much guys, i just replaced the cam and crank shaft sensors to be safe, was not all that expensive. next i will check the fuel pressure by doing what Frango100 said. thanks again guys, will report back soon.
__________________
Reply With Quote
  #9  
Old 06-13-2012, 10:31 PM
djluski's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Nov 2010
Location: White Meadow Lake
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1402
djluski is on a distinguished road
Re: 01 gc laredo hard starting...help please

I tried "priming" the fuel system by turning the key 3 times before cranking it. it seemed to help a little but still stuttered starting. any other ideas? this weekend i will replace the fuel filter to eliminate another possible cause/future problem
__________________
Reply With Quote
  #10  
Old 06-14-2012, 01:17 AM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jan 2012
Location: Denver,Colorado
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 965
2KWJ* is on a distinguished road
Re: 01 gc laredo hard starting...help please

After you replace the filter check the fuel pressure with a guage. 50-60 psi should be good with Key on engine off and a steady 50 to 55 with it running. Specs may be off a bit but usually close enough.
__________________
Reply With Quote
  #11  
Old 06-14-2012, 11:02 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,771
Thanks: 9
Thanked 67 Times in 65 Posts
Rep Power: 525692
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 01 gc laredo hard starting...help please

Ok, let us know how it runs after the filter/regulator change. If that doesnt help and when the fuel pressure is not within specs, you probably have a problem with the fuel pump.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #12  
Old 06-15-2012, 09:08 PM
djluski's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Nov 2010
Location: White Meadow Lake
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1402
djluski is on a distinguished road
Re: 01 gc laredo hard starting...help please

well i replaced the fuel filter today. then i "primed" the fuel lines by turning the key 3 times and it took a bit of effort to start still but then again the lines were dry and had air gaps. once i started it i ran it for about 5 minutes. left it for an hour and then started it again. this time it started up almost normally. i found this technical service bulletin that prettymuch defines my problem...i really don't wanna fork over the money for a fuel pump.http://www.wjjeeps.com/tsb/tsb_wj_1400201.pdf
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard tops? Kev- Wrangler-JK 3 09-03-2011 05:00 PM
Hard Drive Medichic Audio/Visual/Navigation 4 06-29-2011 10:45 AM
Hard upshift? J13ntv Trouble Shooting/Problems/Service 5 04-28-2011 10:25 AM
Hard drive AAAA Audio/Visual/Navigation 7 03-05-2011 12:27 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:38 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community