1999 JGCL running break lights not working - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-28-2015, 06:13 PM
New Member
 
Join Date: Jun 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
joshc13 is on a distinguished road
1999 JGCL running break lights not working

I have a 1999 Jeep Grand Cherokee Laredo and my night time running brake lights and third light won't turn on. When I press on the brake the two bottoms ones turn on, but when I release it they don't dim back down they just turn off.

I have checked my connections, fuses and bulbs (bulbs are brand new and were working a few days ago when I put them in, and are the correct bulbs)

Anyone have any ideas on what it could be?

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 06-28-2015, 06:36 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,266
Thanks: 17
Thanked 366 Times in 353 Posts
Rep Power: 529380
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 JGCL running break lights not working

Welcome to the garage.
Many times the problem are the light sockets. Try to bend the small copper tabs out a little bit. For the third brake light, if the light bulb is ok (check with ohm meter), i would check with a voltmeter to see if voltage is available at the socket when braking. If it is, then check the ground side with an ohm meter.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 06-28-2015, 07:28 PM
New Member
 
Join Date: Jun 2015
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
joshc13 is on a distinguished road
Re: 1999 JGCL running break lights not working

Quote:
Originally Posted by Frango100 View Post
Welcome to the garage.
Many times the problem are the light sockets. Try to bend the small copper tabs out a little bit. For the third brake light, if the light bulb is ok (check with ohm meter), i would check with a voltmeter to see if voltage is available at the socket when braking. If it is, then check the ground side with an ohm meter.
You are the man thanks for the help. And while at I'm at it I saw that you have 8000k HIDs, what brand are they / where did you get them from?
Reply With Quote
  #4  
Old 06-28-2015, 08:04 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,266
Thanks: 17
Thanked 366 Times in 353 Posts
Rep Power: 529380
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 1999 JGCL running break lights not working

I will have to check which brand it is, but since im in Brazil, i wonder if you could get the same ones. There is a vendor on here who gives discount, have a look in the vendor section.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trailer running lights not working windsurfnut Trouble Shooting/Problems/Service 11 08-31-2016 11:52 AM
1999 Interior Functions Stopped Working: interior lights, air, key chime ect.. RONWHO Troubleshooting/Problems 7 11-16-2012 03:15 PM
Need help 2003 JGCL tnboo Troubleshooting/Problems 2 04-27-2012 10:11 PM
SuperChips - 09 JGCL silicastorm Grand Cherokee - WK 28 09-16-2010 04:58 PM
2009 JGCL - "WH" Export Install Viper 5901 silicastorm Technical Tips/DIY/How-To 7 08-08-2010 06:50 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:15 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.