Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-24-2013, 09:18 PM
Shift.91's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jul 2013
Location: Calgary AB
Posts: 131
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 575
Shift.91 is on a distinguished road
Garage
2000 Wj random electrical issue

2000 with a 4.7. Installed my intake with no issues, no pinched wires or anything. Left it for a bit and then went to drive away and my abs light and brake light were on. My wipers started going veeeeerrrryyyyyy slowly, I had one low beam light on and both my high beams and every once in a while the no key light would come on and jeep would shut off. WHAT THE HE**!!! Anybody?
__________________

__________________
'00 WJ Limited(Pre-SRT8)
4.7L; AFE Stage 2 CAI; Whipple performance intake manifold; SuperChips FlashPaq programmer; Staggered OEM SRT 20" wheels; Nitto NT420S performance rubber; Spyder projector HID headlamps and LED fogs; Blackout rear lamps; Full 5000k interior LED kit; Bilstein 4600 series shocks; StraightPipe exhaust; Carbon wrapped interior trim; Chrome/Leather shift knobs; Custom badging . . . More to come!:cool:
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 07-24-2013, 11:01 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,969
Thanks: 9
Thanked 93 Times in 88 Posts
Rep Power: 525931
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2000 Wj random electrical issue

Wipers and high/low beam switching goes via the BCM (body control module). The key light is part of the SKIS (sentry key immobilizer system) and it comes on when there is no valid key. With the key light on, the engine will start, but shut down after a few seconds. I would have a look at the Junction Block under the steering wheel. It is the interior fuse panel, but has also the BCM bolted to it. Check for any loose wire/connector.
This is the first time that strange electrical behaviour occured? Is it still doing it, or was it just once?
The wipers and headlights where coming on by itself?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 07-25-2013, 12:10 AM
Shift.91's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jul 2013
Location: Calgary AB
Posts: 131
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 575
Shift.91 is on a distinguished road
Garage
It was continuously happening. But I found the culprit. I had loosed the ground bolt to mount the cold air intake shield and had forgotten to do it back up! Haha. Silly me!! On a side note: has anyone had issues making the shield fit? I bought an AFE cold air stage 2 and it takes place of the entire air box. So the shield that gets mounted in its place doesn't seem to fit. It's like it's too big. The metal hoses right along the fender seem to be in the way as well as the EVAP hoses that run along the fender are in the way.
__________________
'00 WJ Limited(Pre-SRT8)
4.7L; AFE Stage 2 CAI; Whipple performance intake manifold; SuperChips FlashPaq programmer; Staggered OEM SRT 20" wheels; Nitto NT420S performance rubber; Spyder projector HID headlamps and LED fogs; Blackout rear lamps; Full 5000k interior LED kit; Bilstein 4600 series shocks; StraightPipe exhaust; Carbon wrapped interior trim; Chrome/Leather shift knobs; Custom badging . . . More to come!:cool:
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Used 2000 WJ Electrical Gremlins JeepLover1984 Troubleshooting/Problems 14 03-01-2014 06:24 PM
2000 Grd. Cherokee Ltd. Electrical troubleshooting RLM67 Troubleshooting/Problems Discussion 4 07-30-2012 04:43 PM
Help! Electrical issue. Urgent CPT2010 Troubleshooting/Problems Discussion 11 02-07-2011 07:54 PM
Electrical issue Mistereblack Troubleshooting/Problems 9 05-18-2010 01:15 AM
i have an electrical issue!!!!!!!!!! BUDAKANE Troubleshooting/Problems 5 11-25-2009 08:42 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:05 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community