2001 WJ electrical issue - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-07-2016, 08:28 AM
New Member
My Jeep: 2001 4.0L WJ
 
Join Date: Aug 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mjr76ks2008 is on a distinguished road
2001 WJ electrical issue

Ok, first off I want to apologize ahead of time as this post may be slightly long to explain issue:

Extremely proud owner of a 2001 WJ Grand cherokee Laredo, this vehicle has not had any issues in its life! Wondering if my luck has ended.... Ok, so the problem started a few days ago, I drove to work (I only work 1.5 miles from the house) Everything totally fine. Im a driver, so i returned from my route and went to head home, heres where everything goes south. I opened the door to leave and hear a clicking the second i open the door, then notice that none of my interior lights are on like normal. Go to start my jeep, and nothing! No click, no notta. Tried to jump start it to no avail. Anyway i left it at work and had the wife drop my off the next day, so when i finish i said, what the hell, ill go check it. So i open the door and low and behold, no clicking anymore and all interior lights are on (faintly). Tried to start and did get the clicking, so we jumped it and now it wont stay idling without throttle applied, even when pulling upto stoplight/stop signs. Get it home and my buddy who has been a GREAT mechanic for me for about 15 years+ started the trouble shooting.

((Had this abbreviated problem before and thought it had a bit to do with my negative terminal on my battery was TOTALLY corroded away, he replace the ends and we got a brand new battery just to be safe. didnt have the problem again for a cpl months(so we thought it was fixed))

With the problem coming back, we new it was nothing to do with the battery so with its age, i didnt even check, i just had him replace the starter. Still problem, so he wanted to get the Alternator checked, so we took it to 2 different parts stores, both cleared it with NO issues. He put it back on and has sat in the driveway for 2 days.

I have gone out periodically to check it and it is still sporadicly 1) clicking when door is opened to start with no interior lights and nothing when trying to start. 2) open door no clicking all interior lights on(faintly) and clicking when trying to start. Then jump start it, no throttle applied it will idle for a few seconds, then just die. wont start again without jump start and then dies over and over. Apply throttle after jump start and it stays running (did this for 30 min, lol) then let go of throttle, fell down to idle rpm held for 5 secs'ish then died again.

My poor buddy is getting very frustrated, so just looking for some possible help to get my baby back to tip top shape.
*Starter replaced, Alternator tested and GOOD, Brand new battery, new fuel filter also replaced 6 mnths ago. He just brought up, possible vacuum scenario.

Just looking to see if anyone has seen this issue or has any further suggestions, if anymore info is needed to help diagnose please just holler. Im in serious desperation mode, please helppppppp!!!!!!!!!!!!

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 08-07-2016, 08:43 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,267
Thanks: 17
Thanked 366 Times in 353 Posts
Rep Power: 529382
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2001 WJ electrical issue

There is clearly something wrong with the power supply from the battery. What is the battery voltage when you have the problem? (engine off and engine running)
Since the problem was fixed after installing the new battery terminal and only after some months returning again, i would have a better look at the wires close to the battery terminals. Corrosion internally of the isolation could be the problem. Remove the isolation close to the terminals for inspection.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 08-07-2016, 09:08 AM
New Member
My Jeep: 2001 4.0L WJ
 
Join Date: Aug 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mjr76ks2008 is on a distinguished road
Re: 2001 WJ electrical issue

Okie Dokie, I will relay the info to my buddy and post updates as we continue attempting this fix.

BTW, he did volt test the battery while it was not running and got 12.4 i believe he said, i will see if he can check again after i can get it jump started.
Reply With Quote
  #4  
Old 08-07-2016, 09:28 AM
MDBones's Avatar
OVERLAND HIGH ALTITUDE
My Jeep: 2016 3.6L WK2
 
Join Date: Mar 2014
Location: Wisconsin's West Coast
Posts: 3,564
Thanks: 623
Thanked 607 Times in 499 Posts
Rep Power: 10541
MDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond reputeMDBones has a reputation beyond repute
Garage
Re: 2001 WJ electrical issue

There are a few other things you can check...

Make sure all of your positive and negative ground cables are in good shape and properly connected. These vehicles are extremely sensitive to voltage drops. A drop below 10.2V will cause the PCM to freak out, so you may want to check that as well.

Check your vehicle's security system as the start and failure to keep running are a classic symptom encountered when a battery goes dead or has a severe drop in voltage. There's a reset procedure for the security system... you can either find that in your owner's manual or you can try to find it on wjjeeps.com

Check your idle air control (IAC) as that is another common cause for the start and failure to keep running condition. An IAC is not an expensive part and is easy to replace.
__________________

THE GHOST
Reply With Quote
  #5  
Old 08-07-2016, 09:37 AM
New Member
My Jeep: 2001 4.0L WJ
 
Join Date: Aug 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mjr76ks2008 is on a distinguished road
Re: 2001 WJ electrical issue

Great, thanks for the added sugestions. any more are appreciated as i am making a checklist, my buddy is coming back over monday to try and tackle some more. Thanks all
Reply With Quote
  #6  
Old 08-07-2016, 09:37 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,267
Thanks: 17
Thanked 366 Times in 353 Posts
Rep Power: 529382
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2001 WJ electrical issue

A fully charged battery reads 12.7V, half an hour after being charged. 12.4V is already quite low.
With engine running it should go to 13.5-14.5V.
Probably your PCM has lost its idle air control settings due to the low voltage supplied to the PCM. It will take several starts for the PCM to fine tune this figures in its memory again, but when you still have low voltage, it will start all over again. So i would first try to solve the voltage issue, before attempting to solve the idle.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Grand Cherokee Laredo... Intermittent fuel / electrical problems. BexNLex Troubleshooting/Problems 1 07-29-2014 12:52 PM
2001 WJ :: 2001 Jeep Grand Cherokee 4.0_4x4 Member Garage Discussions 0 01-02-2014 03:13 PM
i have an electrical issue!!!!!!!!!! BUDAKANE Troubleshooting/Problems 5 11-25-2009 08:42 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:51 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.