Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 12-29-2012, 01:43 PM
Member
 
Join Date: Apr 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1562
LionheartUK is on a distinguished road
2002 WJ alarm issue after dead battery

Hi,

I wanted to share an issue I recently had with my 02 WJ (UK 2.7 CRD).

Having tried to start it one morning the battery was flat so it barely turned over and the alarm siren chirped a few beeps. I took the battery off to charge it but my charger said it was only operating at 40% capacity.

With this in mind I left it off and decided to buy a new battery the following day.

I installed the new battery and pressed the unlock button on the keyfob, the doors unlocked with 2 "beeps" from the alarm siren..

Odd I thought, but got in put the keys in the ignition and turned the key to ON, waiting for the glow plugs to warm the alarm started chirping high speed morse code, "uh oh" (in Homers voice) I thought, but proceeded to start the car without issue, the morse code continued!

I switched off and hit the forums, all advice to no avail, resetting alarm actively/passively, battery off for 30 minutes then on with doors shut etc. etc.

I was about to admit defeat and take it to a dealership......

Then my wife stated that perhaps something needed "energising" after the flat battery - BINGO! the Alarm has an internal battery that is only used when the main battery is disconnected, but once flat only charges when the engine is running. (info pulled from the service manual section VEHICLE THEFT SECURITY 8Q - 13)

So the cure is : Leave the engine running enduring the morse code until the battery has enough charge in it and stops all by itself. I would recommend leaving it running to add more charge before switching off.
__________________

__________________
Reply With Quote
  #2  
Old 12-29-2012, 07:47 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2002 WJ alarm issue after dead battery

Yes, that is a good one. Your jeep must have the premium alarm system installed, which has ultrasonic sensors inside the cabin, but also a separate siren module with a backup battery. I had seen a problem like this before, but never heard about the solution. Good to know in case others come up with this.
I donīt think they sold this premium alarm in the US.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Random dead battery? foster Trouble Shooting/Problems/Service 14 11-04-2012 08:39 AM
Battery Dead or.. Starter?! illmortal Troubleshooting/Problems 7 07-27-2012 01:45 PM
Battery dead...can't open rear liftgate! Dan JGC Tech Tips/DIY/How To 12 05-10-2012 04:41 PM
2010 with a dead battery RiverCityOffroad Troubleshooting/Problems 14 09-23-2011 11:54 AM
Battery is dead need help ASAP on replacment CentralTexHemi Trouble Shooting/Problems/Service 18 09-02-2009 03:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:49 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community