Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-27-2014, 09:57 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 230
Yukoncole is on a distinguished road
2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Hey Everyone,

I ran a can of Seafoam through my Master Cylinder Vacuum line yesterday, let it sit for 15 minutes and then started the Jeep. It was running fine for about 5 minutes burning off the seafoam and then started to run rough. I got in the Jeep to bring up the RPMs and it stalled. It will not barely start if it will start at all. When it does after per say 20 attempts it runs really rough and barely stays running. I am at a loss as to what happened!!!! I pulled a few plugs and they appear fine. Any ideas would be greatly appreciated!
__________________

__________________
Reply With Quote
  #2  
Old 05-27-2014, 06:33 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 633
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 2836
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

I would start by pulling all the plugs to see if any of them are fouled.
__________________

__________________
Reply With Quote
  #3  
Old 05-27-2014, 07:29 PM
Yadkin's Avatar
Senior Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Location: Yadkin Valley, NC
Posts: 1,254
Thanks: 0
Thanked 19 Times in 19 Posts
Rep Power: 202410
Yadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

My guess would be clogged fuel injectors.
__________________
Reply With Quote
  #4  
Old 05-28-2014, 07:22 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 230
Yukoncole is on a distinguished road
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Pulled the Plugs they do not look new any longer but not fouled either. I am getting new ones today either way.

How can you unclog a Fuel Injector?
__________________
Reply With Quote
  #5  
Old 05-28-2014, 09:54 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,307
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526357
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Quote:
Originally Posted by Yukoncole View Post
Pulled the Plugs they do not look new any longer but not fouled either. I am getting new ones today either way.

How can you unclog a Fuel Injector?
I would not expect this to be a clogged injector, or it would be a mere coincidende that it happened now. The seafoam was ingested via the brake booster vacuum line and therefore will not come inside the injectors. You could run some seafoam in the fuel to remove any eventual dirt.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 05-28-2014, 10:02 AM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 230
Yukoncole is on a distinguished road
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

A can was also dumped into my 3/4 full fuel tank, so it could of busted something lose I suppose!
__________________
Reply With Quote
  #7  
Old 05-28-2014, 09:35 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,307
Thanks: 9
Thanked 131 Times in 124 Posts
Rep Power: 526357
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Check the fuel pressure at the fuel rail. I had some funny things going on after putting injector cleaner in the tank. never measured the pressure, but after changing the fuel filter/pressure regulator it was all ok.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 05-29-2014, 06:31 AM
Yadkin's Avatar
Senior Member
My Jeep: 2012 3.6L WK2
 
Join Date: Mar 2012
Location: Yadkin Valley, NC
Posts: 1,254
Thanks: 0
Thanked 19 Times in 19 Posts
Rep Power: 202410
Yadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond reputeYadkin has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Quote:
Originally Posted by Yukoncole View Post
Pulled the Plugs they do not look new any longer but not fouled either. I am getting new ones today either way.

How can you unclog a Fuel Injector?
How to Clean Fuel Injectors: 11 Steps (with Pictures) - wikiHow
__________________
Reply With Quote
  #9  
Old 06-01-2014, 04:06 PM
Member
 
Join Date: May 2014
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 230
Yukoncole is on a distinguished road
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

damn Fuel Pump went out....that seafoam in the tank surely highlighted an issue...lol
__________________
Reply With Quote
  #10  
Old 06-02-2014, 11:46 AM
Premium Member
My Jeep: 2014 5.7L WK2
 
Join Date: May 2013
Location: Colorado
Posts: 2,659
Thanks: 41
Thanked 98 Times in 91 Posts
Rep Power: 44201
lstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond reputelstowell has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Quote:
Originally Posted by Yukoncole View Post
damn Fuel Pump went out....that seafoam in the tank surely highlighted an issue...lol
Hey, at least you found it.
Did the Seafoam dislodge rust/crud/dino-poo, and clog the pump, or was it just sheer coincidence?
__________________
Reply With Quote
  #11  
Old 06-03-2014, 08:34 PM
cherryredjeep's Avatar
Member
My Jeep: 2013 5.7L WK2
 
Join Date: Oct 2013
Location: southeast pa.
Posts: 195
Thanks: 12
Thanked 9 Times in 8 Posts
Rep Power: 662
cherryredjeep has a reputation beyond reputecherryredjeep has a reputation beyond repute
Re: 2004 4.7 HO Wont Start barely Runs after SeaFoam Treatment

Happy your back on the road[trail]
__________________

__________________
13 JGC OVERLAND
04 JGC LIM.
01 DODGE RAM 2500 CUMMINS
68 DODGE DART GTS 340
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
1st Seafoam Treatment + Oil Change Drivenpromise Engine Performance/Intake/Exhaust 6 07-09-2014 03:14 PM
seafoam treatment jtapscot Grand Cherokee - WK 15 11-20-2013 10:23 AM
seafoam treatment tom58 Grand Cherokee - WK 16 02-27-2012 09:35 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:10 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.