Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-20-2012, 08:06 PM
GeneralTJWillys's Avatar
New Member
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GeneralTJWillys is on a distinguished road
4.0 WJ Ltd. cooling fan issue

OK, so I got this '99 WJ Limited a short time ago. Previous owner thought it was a blown head gasket due to constant overheating. (4.0 engine...thank God!)

After looking at it, bought it immediately. (well cared for, fantastic condition, other than the alleged gasket issue, $400.....you'd buy it too! )

So I found that the head gasket is fine. Also found;

1) Fan not turning on.
-checked to battery....fan works
-replaced relay

2) Hairline crack in radiator due to fender bender
-new radiator and replaced busted up header panel while front was apart and repaired the fender bender damage.

Figured the relay, would have done it but the fan will still not come on.

Temp sensor works fine b/c I'm getting good reading at temp gauge.

So with good fan, new relay, and apparently properly working temp sensor, can anyone help me find what else could be wrong?

I'm assuming that either the signal is not making it to the ECU or not making it from the ECU to the relay. I seriously doubt the ECU is bad. There is NOTHING in this Jeep that does not work as it should EXCEPT the fan!

I'd hate to think that the brand new relay is bad right out of the box, but I suppose that it's a possibility.

Driving it to/from work because I have only one or two stops and a straight shot. No issues as long as it's moving and getting airflow. Temp stays stable at about 205.

Pics forthcoming

THANKS for any input/opinions you may have!
__________________

__________________
Reply With Quote
  #2  
Old 07-20-2012, 09:50 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,705
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525522
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 4.0 WJ Ltd. cooling fan issue

I presume that you have checked the fuse 10 ( 40A ) in the power Distribution Center first?
Other then that, wiring, relay or PCM.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 07-20-2012, 10:16 PM
GeneralTJWillys's Avatar
New Member
 
Join Date: Jul 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
GeneralTJWillys is on a distinguished road
Re: 4.0 WJ Ltd. cooling fan issue

Yep, forgot to add that. All fuses checked good.

Going to try to replace the fan motor next. I've read elsewhere in these forums that "when one goes, they both go". I'm assuming that means that the fan motor starts going bad and building resistance (and heat) in the circuit and fries the relay. Only fix.....replace fan motor AND relay.

So, since I've replaced the relay, but not the fan, I hope that I have not just fried the new relay. They are not cheap.
__________________
Reply With Quote
  #4  
Old 07-20-2012, 11:02 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,705
Thanks: 9
Thanked 57 Times in 55 Posts
Rep Power: 525522
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: 4.0 WJ Ltd. cooling fan issue

Yeh, many times the fan itself is drawing too much current and fries the relay in no time. When the fan works directly from the battery and not with the relay, there is a good change that the new relay is fried again.
But it can still be a wiring problem as well.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
== Hydraulic Cooling Fan WK 2008 Hac_PTR Troubleshooting/Problems 0 08-29-2011 07:36 PM
Cooling Fan Relay uniquetreatone Troubleshooting/Problems 5 04-05-2011 10:08 AM
Cooling Fan rayray Engine Performance/Intake/Exhaust 2 01-26-2011 12:29 PM
Engine cooling fan 4.7 HO Tim2 Engine Performance/Intake/Exhaust 23 04-14-2010 03:18 PM
Electric cooling fan mjl2610 Grand Cherokee - WK 21 06-30-2009 06:42 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:57 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community