Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-10-2010, 06:23 PM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,220
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153438
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
A bit odd...

I've not used the Jeep for about a week now. Just jumped in it to start it and it started ok, the hazard lights flashed, then the engine seemed to lose power. All the internal/external electrics work fine, I'm presuming it's just down to it not being used. There was also a ticking noise coming from inside, that went away once I started it. The other thing is the switch for unlocking all the doors didn't work to start with (no power) but is fine now. I've taken it for a run and all seems well.

I've not driven it cause I'm tinting my windows and I have had the stereo on while doing it, so hopefully it is just battery drain.

Anyone any ideas if this could be something else?
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #2  
Old 08-10-2010, 06:49 PM
Long Live the Graphite Ghost

 
Join Date: May 2009
Posts: 13,418
Thanks: 55
Thanked 132 Times in 114 Posts
Rep Power: 542611
robpp has disabled reputation
Re: A bit odd...

my wk will act funny for a bit after i reconnect the battery . like the power locks may not work until i once start the car.

did you have it disconnected? or just run down?
__________________

__________________
Reply With Quote
  #3  
Old 08-10-2010, 08:31 PM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12350
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: A bit odd...

sounds like battery
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #4  
Old 08-11-2010, 03:33 AM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,220
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153438
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: A bit odd...

Just run down Rob. Checked it this morning and all is fine. I guess it was just me spending hours farting around with tint whilst listening to David Hasselho...I mean Metallica on my stereo.
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #5  
Old 08-11-2010, 08:51 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12350
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: A bit odd...

freakin homo LOL
__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #6  
Old 08-11-2010, 07:53 PM
08Hemi's Avatar
Senior Member
My Jeep: 2008 5.7L WK
 
Join Date: Jun 2009
Location: Santa Barbara, CA
Posts: 4,296
Thanks: 0
Thanked 25 Times in 30 Posts
Rep Power: 330395
08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute08Hemi has a reputation beyond repute
Re: A bit odd...

Haha lmfao! FYI u should always start your vehicle after u have had the stereo/lights/nav etc on for over an hour. Just let it idle for a couple mins and it will def help. Everytime u let your battery die like that, some of the cells will not reach full capacity again. The extent of the damage is dependent on the age of the batter and usage/ use conditions.
__________________
Reply With Quote
  #7  
Old 08-12-2010, 03:38 AM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,220
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153438
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: A bit odd...

Quote:
Originally Posted by boniomario View Post
freakin homo LOL
Am not! That's it I'm going home...where's my purse?
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #8  
Old 08-12-2010, 03:40 AM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,220
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153438
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: A bit odd...

Quote:
Originally Posted by 08Hemi View Post
Haha lmfao! FYI u should always start your vehicle after u have had the stereo/lights/nav etc on for over an hour. Just let it idle for a couple mins and it will def help. Everytime u let your battery die like that, some of the cells will not reach full capacity again. The extent of the damage is dependent on the age of the batter and usage/ use conditions.
Ah, I didn't know that, excellent info. Thanks I'm probably needing a new battery soon anyway.

Just had a brief moment of panic when it didn't start. Thanks guys.
__________________

__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Have This Odd Noise When Braking: Help Chuck Troubleshooting/Problems Discussion 31 08-26-2010 02:49 PM
2011 WK with odd bumpers....LOL Scottina06 Grand Cherokee - WK2 - 28 10-07-2009 09:09 AM
Odd idle when shifting... Martyp Grand Cherokee - WK 25 08-17-2009 05:58 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:03 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community