Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-25-2013, 09:27 AM
Member
 
Join Date: Aug 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 336
verboden1 is on a distinguished road
Another issue with '04 WK 4.0

I have noticed over the past few weeks that when driving at about 1500 RPM, the engine stutters a bit until I accelerate...here are the problems that I have diagnosed.

OBD codes - 0505, which I know is the IAC. I removed it and cleaned it, but the code just popped again last night.

O2 sensor codes had shown before, so I replaced both upstream O2 sensors last weekend. I used Denso O2 sensors

The exhaust blows heavy black smoke under acceleration, and STINKS. Like a cat converter issue (I've posted before about this)

Just got a 1195 code -1/1 O2 Sensor Slow During Catalyst Monitor. This sensor was just replaced last saturday.

I suspect, based on tapping on the muffler that it has a fair share of carbon build up in the muffler, so I will be replacing it this weekend.

My average MPG, based on the overhead computer is.....wait for it.....9.8mpg.

Question....if the muffler is clogger, or if the cat is bad...would the extra backpressure cause the pitiful MPG?

I am a loyal jeep fan, but a crappy mechanic, so at least it's small issues for now.

Any ideas? Will be ordering the bluetooth Dongle and torque app as Frango suggested.

2004 grand Cherokee 4.0 I6
__________________

__________________
Reply With Quote
  #2  
Old 09-25-2013, 10:29 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Another issue with '04 WK 4.0

Just for the records, your jeep is a WJ.
The P0505 could be the iac stepper motor, wiring or PCM. Was it not you who had the iac wiring damaged? A split second an open or shorted wire could already give this code, while it otherwise could idle normally.
Strange that the 1-1 sensor is showing as slow for cat performance monitoring, but doesn't have a fault for normal fuel trim operation. The torque app would be handy now, for monitoring the O2 sensor output.
I wonder if a clogged or restricted bank 1 precat could be the problem here. Did you check for any exhaust leak from the headers?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 09-25-2013, 11:26 AM
Member
 
Join Date: Aug 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 336
verboden1 is on a distinguished road
Re: Another issue with '04 WK 4.0

Ehhh, I'm an idiot.....Yes...a 2004 WJ. Thanks Frango. your Jeep knowledge makes me jealous sometimes!

I am suspecting that there is an exhaust leak, just not sure where yet....I'll be under this weekend and check while replacing the muffler. I'm tempted to remove the rear cat (I know, it's illegal) temporarily until I can shell out the 200+ dollars to replace it. I'm sure that it must be restricted based on the amount of carbon emissions and the fact that my muffler sounds like its filled with sand.

yes, I did find a two wires with bad insulation, and taped them. I'd like to repair the wires with new wire, but there isn't much to work with. Can one buy a new wiring harness for the IAC motor??? It's hard to buy all these parts when I'm filling up every other day.
__________________
Reply With Quote
  #4  
Old 09-25-2013, 01:16 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Another issue with '04 WK 4.0

Rockauto.com does has a new connector with a part of the wiring for the IAC.
I would check the gasket from the exhaust headers, which seems to be a common point for leaks.
If the main cat and muffler are partly cloged, what about the pre-cats?
And if the muffler and/or main cat are clogged, why then only bank 1 would have the carbon buildup on the plugs?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 09-25-2013, 02:33 PM
Member
 
Join Date: Aug 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 336
verboden1 is on a distinguished road
Re: Another issue with '04 WK 4.0

Ughhh, I guess the pre-cats would probably clogged too then, huh?? I'll start with the muffler and look for leaks in the exhaust system this weekend. Any way to tell if the pre cats are clogged? all in all, I can't be mad at the jeep. The previous owner obviously didn't take care of it, the 1/1 O2 sensor looked like a charcoal briquette.....
I'll keep you updated.
__________________
Reply With Quote
  #6  
Old 09-25-2013, 05:46 PM
Member
 
Join Date: Aug 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 336
verboden1 is on a distinguished road
Re: Another issue with '04 WK 4.0

Hey Frango.....any particular dongle that seems to work well with the Torque app?? There are a few on eBay that are cheap, but you get what you pay for. Any suggestions before I order one?
__________________
Reply With Quote
  #7  
Old 09-25-2013, 06:26 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Another issue with '04 WK 4.0

I bought one from China, but i don't know if one is better then an other.
I think i spend USD 15 or so on it. On mine is written ELM OBDII (when i remember well).
What i understood regarding clogged muffler or cat is that it would create acceleration problems due to the increased back pressure.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #8  
Old 09-26-2013, 02:51 PM
Member
 
Join Date: Aug 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 336
verboden1 is on a distinguished road
Re: Another issue with '04 WK 4.0

You are the MAN, Frango.......I'll screw around with it. Changing the muffler tomorrow and I'll tap the cats. Then I'll go from there. Gonna order a dongle from ebay tonight. Even if I don't understand what the app is telling me, it will be pretty cool.
What am I saying???? All I have to do is ask you!!

thanks for all your help!! Won't let me add to your rep again just yet, but you definitely are a Jeep Guru!
__________________
Reply With Quote
  #9  
Old 09-26-2013, 04:27 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Another issue with '04 WK 4.0

The P1195 code you have now is normally caused by an inlet vacuum leak, MAP sensor failure or fuel injector leaking.
Because the problem is for cylinder 1-2 and 3, there should be something common, but not affecting all 6 cylinders.
The strange thing is that if there was a vacuum leak, that the expected mixture should be lean, while the carbon buildup on the plugs showed a too rich mixture
Would not expect the MAP sensor or leaking fuel injector yet, because the MAP would influence all 6 cylinders and a leaking fuel injector only the respective cylinder.
Would be interresting to see the O2 sensor voltage and the fuel trim figures, but they probably will show a very positive long term fuel trim (LTFT) and short term fuel trim (STFT) for bank 1 and a high voltage from the O2 sensor 1-1 (around 0.9 V)
An exhaust restriction (for the common exhaust pipe/muffler) would decrease the entire respiration of the engine and would cause power loss, but the O2 sensors together with the PCM should be able to control the mixture.
And you only see black smoke when accelerating, at which point the O2 sensors are not used, since it will run in open loop mode.
We maybe have to wait for the dongle to arrive, to have a look what is happening with the fuel trimming and maybe other inputs.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #10  
Old 09-26-2013, 06:11 PM
Member
 
Join Date: Aug 2013
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 336
verboden1 is on a distinguished road
Re: Another issue with '04 WK 4.0

Regardless of all of this driving me crazy, I do have one thing going for me........I own a Jeep!! I will let you know when the dongle comes in11

Peace
__________________
Reply With Quote
  #11  
Old 09-26-2013, 10:02 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,641
Thanks: 9
Thanked 54 Times in 52 Posts
Rep Power: 525436
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Another issue with '04 WK 4.0

Quote:
Originally Posted by verboden1 View Post
Regardless of all of this driving me crazy, I do have one thing going for me........I own a Jeep!! I will let you know when the dongle comes in11

Peace
Maybe one is a concequence of the other?
I hope you know what JEEP is standing for:
J(ust) E(mpty) E(ach) P(ocket)
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
04 KJ trans issue stevusprime Troubleshooting/Problems Discussion 8 05-31-2013 04:34 AM
Well this is a new issue... JEEPYOU Trouble Shooting/Problems/Service 6 02-11-2013 02:42 PM
Tranny Issue radbushi Trouble Shooting/Problems/Service 10 12-10-2012 06:51 PM
Accelerate issue 303WK Troubleshooting/Problems 6 01-20-2012 06:08 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:05 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community