Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-02-2012, 06:36 PM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Unhappy another trany problem

Hi everyone, I just purchased a 2000 WJ. I,m having issuues with the trans, feels like its stuck in 3rd, no noticable shifting but manualy moving the selector does work. had a "p1698" code (no com between tcm and ecm) I reseated all plugs (at the trans and tcm/ecm) checked grounds, found all apearing ok. Then i reset code by disconecting neg bat cable (probably messing up by doing that) code was gone but drive abilty still there, by the way forgot to mention new engine install (er used) any ideas what i might have missed or where to go from here. any help would be apreceated,

thanks Jim
__________________

__________________
Reply With Quote
  #2  
Old 06-03-2012, 07:58 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,318
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524710
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: another trany problem

Did you check the wire bundles in the engine bay? No wire damage?
Also when you removed the connectors from TCM and PCM, did you check for bend pins or pushed back connectors?
Did the jeep run fine after the engine change, or was it acting up from the beginning?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 06-03-2012, 10:31 AM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Re: another trany problem

after unpluging and removing everything on the passenger side of the engine compartment, i found a coated ground strap hanging from behind the PCM. i conected that to the mounting/ holddown stud for the 3rd coil.
Inspected the loom and the plugs for damage and corrosion,found none. reinstalled everything, pluged in the harness (after coating with dielectric grease) test drove and the same thing limp mode.

going to pick up a used TCM at the scrap yard this morn. i hate just parts changing, but until my repair manuals show up this is all i can do.
__________________
Reply With Quote
  #4  
Old 06-03-2012, 10:39 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,318
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524710
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: another trany problem

But did the jeep drive ok after the engine change? Was only the engine changed, or the PCM as well?
Did you check all fuses, in particular fuse 5 (30A) in the PDC?
Regarding the ground strap, there should be a ground strap under the holddown stud for coil #7 and #8 (both most aft coils)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 06-03-2012, 12:02 PM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Re: another trany problem

welp no TCM at the yard.

Only engine was changed checked intake part # against # on wj jeeps.com, correct part for year.

will check fuse after post.

swapped relays.

and yes the uncovered braided strap was connected, firewall to 7 and 8 on both sides.

fuse is ok.

what else am i missing?
__________________
Reply With Quote
  #6  
Old 06-03-2012, 04:46 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,318
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524710
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: another trany problem

But did the jeep run well after the engine change?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 06-03-2012, 05:12 PM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Re: another trany problem

change was done before i bought it. I was told it ran ok after the change. yes i bought it knowing there was a problem. sorry for not answering that question the first time.
__________________
Reply With Quote
  #8  
Old 06-03-2012, 05:49 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,318
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524710
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: another trany problem

You said you swapped relays, was that the transmission control relay in the PDC?
Also fuse 28 (15A), in PDC should be checked. If ok, i think you will have to start measuring voltage to see if the TCM power feed is ok. Tomorrow i can send you some wiring diagrams to aid in trouble shooting.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 06-04-2012, 05:02 AM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Re: another trany problem

yes the relay in the PDC. i will check the fuse,

thank you for your help.
__________________
Reply With Quote
  #10  
Old 06-04-2012, 09:22 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,318
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524710
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: another trany problem

In case you want to measure the wiring, attached some wiring schematics.
Attached Files
File Type: pdf TCM1.pdf (136.5 KB, 10 views)
File Type: pdf TCM2.pdf (202.3 KB, 5 views)
File Type: pdf TCM3.pdf (123.9 KB, 4 views)
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #11  
Old 06-04-2012, 08:34 PM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Re: another trany problem

thanks for the diagrams
__________________
Reply With Quote
  #12  
Old 06-08-2012, 09:33 PM
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jun 2012
Location: Mchenry
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 696
jdmhvac3 is on a distinguished road
Send a message via Skype™ to jdmhvac3
Re: another trany problem

Hey all thanks for the help found the problem, the idots that installed the motor not only didn't install the back Grounds but it apears that if it wasn't plugable it wasn't connected. I found the the 4 ground wires that go to the front of the engine just stuffed behind the motor mount. connected them and trany is working like a champ.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
another problem please help tyler05wk Troubleshooting/Problems 0 01-09-2012 01:18 AM
What is the problem??? smack82 Troubleshooting/Problems Discussion 6 05-03-2011 04:07 PM
has anyone else had this problem? 99limited Audio, Video, Navigation & Electronic Modifications 14 04-01-2010 05:17 PM
'04 Jeep WJ | Engine/Trany Issues Jester86 Troubleshooting/Problems 26 03-14-2010 06:23 PM
omg trany pan hurting josef15111 Grand Cherokee - WJ 8 02-02-2010 03:45 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:13 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community