Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 06-02-2013, 03:07 PM
Member
 
Join Date: Apr 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 391
Viper05 is on a distinguished road
Bad ignition coil?

Recently my 99 WJ had been having hesitation problems. It also seems to stall once warmed up. I checked all my fluids. No error codes. The only thing that looks weird is on of the ignition coils.

I have the 4.7 V8.

The first picture is how 7 of them look. Smooth on the top. The last pic is how the one looks that I suspect to be bad and the cause of my problems. Any feedback? It's only $25 for the coil if that one does look bad.
Sent from my HTC One X using Tapatalk 2
Attached Images
File Type: jpg uploadfromtaptalk1370203526971.jpg (47.8 KB, 15 views)
File Type: jpg uploadfromtaptalk1370203540816.jpg (55.6 KB, 16 views)
__________________

__________________
Reply With Quote
  #2  
Old 06-02-2013, 05:02 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,329
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524724
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Bad ignition coil?

That coil indeed looks suspisious, seems that it was overheated.
I would give it a try with a new one. A real bad coil will give you the check engine light, but maybe its still working, but not with the full high voltage.
Did you check the respective plug?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 06-05-2013, 04:26 PM
Member
 
Join Date: Apr 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 391
Viper05 is on a distinguished road
I replaced the coil and all 8 plugs yesterday. Haven't driven it enough to see if it helped.

Sadly yesterday I noticed my motor seems to be burning oil. Get some black smoke when it fires up and it was down to the add a quart mark. I had already added a quart. So 2 quarts in 3 months.

Sent from my HTC One X using Tapatalk 2
__________________
Reply With Quote
  #4  
Old 06-05-2013, 05:34 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,329
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524724
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Bad ignition coil?

This looks as bad valve stem seals. With the engine off, the oil can pass by the seals and will burn at startup. If it are really the seals, you can especially see it when letting off of the gas. The extra suction created by the closed throttle valve, will suck extra oil through the seals and that gets burnt.
Changed the seals on my engine, some time ago, was a hell of a job on my own, but i managed it. Probably a lot easier when you have a pair of extra hands.
I made a tool myself to compress the valve springs to remove the keepers.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 06-05-2013, 06:02 PM
Member
 
Join Date: Apr 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 391
Viper05 is on a distinguished road
Would that cause fouled plugs? All my plugs were fine just normal wear when I pulled all 8.ps I hate the back two on the passenger side. The oil and transmission fluid check tubed were in the way

Sent from my HTC One X using Tapatalk 2
__________________
Reply With Quote
  #6  
Old 06-05-2013, 06:27 PM
Member
 
Join Date: Apr 2013
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 391
Viper05 is on a distinguished road
Follow up question is could those valve seals leaking cause it to hesitate and stall? It hesitates at highway speed. Especially when accelerating. The stalling happens at idle in and out of gear.

Sent from my HTC One X using Tapatalk 2
__________________
Reply With Quote
  #7  
Old 06-05-2013, 09:12 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,329
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524724
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Bad ignition coil?

My engine was burning 2 lts of oil per 1000 km and the plugs where clean as could be.
A bad ventilation system can also contribute to high oil consumption. Have a look at the PCV valve or just change it. This valve should be changed on regular basis according to the maintenance schedule. When you want to take it out be carefull not to break it. Mine broke when i was trying to get the hose of. If it was not changed for a while, you better put a new one in.
Do you see smoke after idling for some time and then driving away?
If it smokes continuously during acceleration, it could be a bad piston ring.
The oil consumption should not let the engine hesitate and stall, or the valves should be covered with carbon. You could give it a seefoam treatment, to clean out the valves and combustion chambers. I would also check the idle air control stepper motor, its mounted just below the TPS with 2 screws. You will probably find a lot of dirt on the stepper motor plunjer and inside the air canal. This can cause unstable idle. If the seefoam treatment doesn´t help on the acceleration problem, you could try a new fuel filter/pressure regulator. My jeep was hesitating during acceleration on highway speeds and the new filter did the trick.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bad,Bad Week for Ole Silver cheapjeep Grand Cherokee - WJ 12 01-05-2013 09:13 PM
Coil spring spacers, or coil springs for 2" lift? Kaczman Suspension/Brakes/Wheels/Tires 5 06-18-2012 11:40 AM
Ignition Coil and spark plugs Texas Jeep Engine Performance/Intake/Exhaust 3 11-30-2010 09:11 AM
ignition coil carlitobregante Engine Performance/Intake/Exhaust 3 01-26-2010 09:02 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:06 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community