Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-03-2011, 08:34 AM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Blower Motor Not Blowing Air

So I have a 01 Limited, yesterday while driving it quit blowing air and when I would turn the car off and back on, it would work for a few minutes and now that is not working at all.

I can feel hot or cold air at the vent when I have the switch in the on position, but it's just not being blown out of the vents.

Any ideas what could be wrong before I go buy the parts or how to test the motor or something.

Thanks!
__________________

__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #2  
Old 09-03-2011, 08:57 AM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Re: Blower Motor Not Blowing Air

I guess I'm trying to distinguish whether I need to fix the resister or the actual motor based on searches.
__________________

__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #3  
Old 09-03-2011, 10:54 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,777
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525700
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Blower Motor Not Blowing Air

Have a look first at the connector on the blower motor, many times its melted due to bad contact. If you have the duel zone system, there is a blower motor controller and no resistor.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 09-03-2011, 11:00 AM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Re: Blower Motor Not Blowing Air

I pulled the glove box down, and all I see is 1 harness up to left connected to something that the plug and wiring look fine on, everything else under there is just a bunch of black plastic. So I'm guessing that was the connector you mentioned, but it appears fine.

And yes, I have dual zone.
__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #5  
Old 09-03-2011, 01:25 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,777
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525700
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Blower Motor Not Blowing Air

When i'm not wrong, the blower motor is sticking out from the underside of the HVAC housing and is the wiring also at the underside.
The connector you can see through the glovebox is from the passenger side blend door actuator.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 09-03-2011, 01:31 PM
StoneCold's Avatar
Senior Member
My Jeep: 2000 4.7L WJ
 
Join Date: Feb 2010
Location: Bankfoot, Scotland
Posts: 3,220
Thanks: 8
Thanked 28 Times in 27 Posts
Rep Power: 153433
StoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond reputeStoneCold has a reputation beyond repute
Garage
Re: Blower Motor Not Blowing Air

Franks right about the thing melting, happened to mine. The motor is just a black box from memory, sits under the glovebox. It could just be the plug that's had it though
__________________
Tinted tails - Custom intake with mushroom filter - Superchips performance tuned - 20" SRT reps - Alcantara headliner - Magnaflow exhaust - Roush performance tips - LED conversion - Carbon Fibre/Alcantara interior - 20% tint -Bright Jeep pedals - Matte black viper stripes - Gauge pod - Gen 3 halo projectors & HID's - Airbrushed engine bay - Mesh grille - Snakeskin green calipers and accents(inspired by DAVY27)

www.facebook.com/stonecoldpaintwerks
Reply With Quote
  #7  
Old 09-04-2011, 04:16 PM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Re: Blower Motor Not Blowing Air

I took the motor out and tested it, it works fine. I inspected end of wire harness that plugs into motor and it appears fine, where does the other end go to? It has to be just getting a bad connection I assume. If I need that harness replaced, where can I get one and what is the name of the part?
__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #8  
Old 09-04-2011, 05:30 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,777
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525700
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Blower Motor Not Blowing Air

The wire should go from the blower to the controller, which is also mounted on the HVAC housing. I know that jeep has a repair kit with the connector, but i don´t think that you will change the whole harness in that way. First try to duplicate the problem and then wiggle with the cable loom until the blower stops working. You first need to know where the problem exactly is, before you start changing anything.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #9  
Old 09-04-2011, 08:18 PM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Re: Blower Motor Not Blowing Air

well it has to be the harness, because when I connected it to battery, no problems. When I plugged it back in it worked until I started driving i'm assuming from vibration. If the other end of the plug is the other end of this harness, it all appears to be okay.
__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #10  
Old 09-04-2011, 08:18 PM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Re: Blower Motor Not Blowing Air

Should I take a picture?
__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #11  
Old 09-04-2011, 08:41 PM
Member
 
Join Date: May 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1294
UrbanAssaultJeep is on a distinguished road
Re: Blower Motor Not Blowing Air

Alright here is some pictures...

This first photo is of the plug that attaches to the blower itself


This 2nd photo is of the plug that is to the upper left behind glove box


This 3rd photo is under the dash and close to the firewall
__________________
01 GC Limited - Mods: V-LEDS Interior & Ext | Shorty Antenna | 20" Black SRT8 Repo Wheels | Tint: 5% Strip, 15% Fronts, 15% over rear privacy glass | Kolak 3" Exhaust | Hertz HSK 165 Components F&R | Hertz Mille Subwoofer | Rockford Amps
Reply With Quote
  #12  
Old 09-04-2011, 09:07 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,777
Thanks: 9
Thanked 68 Times in 66 Posts
Rep Power: 525700
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Blower Motor Not Blowing Air

The second picture is as i told you the passenger side blend door actuator with connector, has nothing to do with the blower.
The third picture is the blower motor controller, which could be the culprit.
But there is quite some wiring going from the power distribution center fuse 1 (40A) to the blower motor controller, so only by wiggling with the wires you can find any internally broken wire or bad contact from connectors or fuses.
Also check the connectors and wiring behind the airconditioning panel.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Blowing Blower Motor Fuses gemspeaker Troubleshooting/Problems 7 05-28-2011 05:37 PM
Heater blower motor resistor? TimmyB Troubleshooting/Problems Discussion 25 03-30-2011 12:59 PM
Blower motor issues peepersjeepers Troubleshooting/Problems Discussion 3 02-14-2011 10:39 AM
Blower Motor connector repair karen Tech Tips DIY/How To 10 01-20-2011 02:59 PM
Wierd (?) blower motor issue Delta Dog Troubleshooting/Problems 9 10-28-2010 06:54 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:53 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community