Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 02-07-2013, 04:17 PM
Member
 
Join Date: Dec 2012
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 39766
fin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond repute
Quote:
Originally Posted by Hacksaw View Post
For great info about the 99-04 Grand Cherokee check out www.wjjeeps.com I believe there is a listing of available drivetrains http://www.wjjeeps.com/tcases.htm

Think Outside !- No Box Required.
Seems like I'll have to be going with quadra drive, but I guess I shouldn't be complaining.

Looking at trading in my 02' laredo(pretty bare bones, 4.0L, selec trac, aftermarket stereo), for an 03'-04' limited or overland with the 4.7L HO. Sound like a plan?
__________________

__________________
Reply With Quote
  #14  
Old 02-07-2013, 04:38 PM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1951
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
It's a great truck no matter which way you go !

Think Outside !- No Box Required.
__________________

__________________
Reply With Quote
  #15  
Old 02-07-2013, 10:14 PM
Member
 
Join Date: Dec 2012
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 39766
fin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond repute
Quote:
Originally Posted by Hacksaw View Post
It's a great truck no matter which way you go !

Think Outside !- No Box Required.
Awesome. I mean, love my car as is, but the 4.0L just lacks the spunk. It IS a very solid sounding/seems to be reliable type engine. But I am having this weird squealing sound upon cold start up, goes away in a few minutes. Cold fluid?

Yesterday, ignition was locked(key wasn't engaging in the key cylinder), so I threw some graphite powder in the ignition, tapped in the key, and voila. Works fine, but I think I should replace the key cylinder...
__________________
Reply With Quote
  #16  
Old 02-07-2013, 10:49 PM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1951
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
Maybe but believe it or not that could be a shifter issue...Transmission Brake Safety Interlock

Pm me an email address and I will send you a big book that may or may not contain letters representing itself as the factory service manual for a WJ

Think Outside !- No Box Required.
__________________
Reply With Quote
  #17  
Old 02-08-2013, 07:28 PM
Member
 
Join Date: Dec 2012
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 39766
fin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond repute
Re: Can't get my wj outta 4lo?

Ran into another problem today(lol this is gonna be my "fin is having a problem" thread). Snowed/iced last night, didnt have enough time to fully remove all the ice, so I ran the defroster for a while and then turned on the wipers. Immediately the wipers started to stutter, almost like a motor belt was slipping, and they are still doing this tonight. Also, the wipers aren't returning to the bottom of the windshield after I turn them off, so I have to time it right to get them at the bottom. Whats going on here?

Also, found my dream WJ:
2003 Jeep Grand Cherokee Overland, $9,650 - Cars.com
__________________
Reply With Quote
  #18  
Old 02-08-2013, 07:58 PM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1951
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
Did you get my email ?

Think Outside !- No Box Required.
__________________
Reply With Quote
  #19  
Old 02-08-2013, 07:59 PM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1951
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
On the wiper front it sounds like the linkage has jumped or bent

Think Outside !- No Box Required.
__________________
Reply With Quote
  #20  
Old 02-08-2013, 08:09 PM
Member
 
Join Date: Dec 2012
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 39766
fin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond repute
Re: Can't get my wj outta 4lo?

Hacksaw, did not receive your email. Once again, it is fin(dawt)elliott@gmail.com

And could you explain what you said about the linkage being jumped or bent? I have good experience in electronics, but when it comes to car terms I'm lost.
__________________
Reply With Quote
  #21  
Old 02-08-2013, 08:54 PM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1951
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
I'll try to send from the pc ...there is one motor that controls both wiper arms, there are linkages that connect the arms to eachother and that linkage to the motor. I'm not sure how it all goes together in a Jeep but my email will help ...stand by

Think Outside !- No Box Required.
__________________
Reply With Quote
  #22  
Old 02-08-2013, 09:14 PM
Hacksaw's Avatar
Member
 
Join Date: Dec 2012
Posts: 674
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 1951
Hacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond reputeHacksaw has a reputation beyond repute
It's on the way...all 73mb of it

Think Outside !- No Box Required.
__________________
Reply With Quote
  #23  
Old 02-08-2013, 09:41 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,888
Thanks: 9
Thanked 90 Times in 85 Posts
Rep Power: 525836
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Can't get my wj outta 4lo?

Quote:
Originally Posted by fin1211 View Post
Ran into another problem today(lol this is gonna be my "fin is having a problem" thread). Snowed/iced last night, didnt have enough time to fully remove all the ice, so I ran the defroster for a while and then turned on the wipers. Immediately the wipers started to stutter, almost like a motor belt was slipping, and they are still doing this tonight. Also, the wipers aren't returning to the bottom of the windshield after I turn them off, so I have to time it right to get them at the bottom. Whats going on here?

Also, found my dream WJ:
2003 Jeep Grand Cherokee Overland, $9,650 - Cars.com
Good change that you broke some teeth on one of the gears in the wiper motor transmission.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #24  
Old 02-08-2013, 09:46 PM
Member
 
Join Date: Dec 2012
Posts: 234
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 39766
fin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond reputefin1211 has a reputation beyond repute
Re: Can't get my wj outta 4lo?

Hacksaw, still haven't received anything.

Frango, hard fix?
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
4LO problems nesbitt32 Engine Performance/Intake/Exhaust 14 12-15-2011 07:05 AM
Spray outta radiator cap JeepCoop Troubleshooting/Problems Discussion 7 10-01-2011 05:42 PM
08 jeep wk gets stuck in 4lo TJcust Troubleshooting/Problems Discussion 5 12-30-2010 01:04 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community