Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #25  
Old 12-27-2012, 05:59 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,665
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525473
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Car wont run

Did you try wiggling the wires of the cam sensor and crank sensor with the engine running? maybe an internal wire problem.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #26  
Old 01-09-2013, 04:01 AM
Member
 
Join Date: Nov 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 649
IxIconvict is on a distinguished road
Re: Car wont run

Ok bud I have wiggled all the wires no change is there a chance that my throttle body is falty and is putting the car in some form of limp home mode I know it happens in alot of jap imports
__________________

__________________
Reply With Quote
  #27  
Old 01-09-2013, 06:50 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,665
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525473
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Car wont run

The throttle body faulty itself i donīt believe.
But due to the fact that you got a message that the cam or crank signal is intermittent and wiggling the wires didnīt make any difference, i wonder if one of these sensors is the culprit.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #28  
Old 01-09-2013, 07:59 AM
Member
 
Join Date: Nov 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 649
IxIconvict is on a distinguished road
Re: Car wont run

I thort of the t-body coz every time I do a deleat and rescan with the obd2 the mass air flow code is the only content one that comes up . I'll start getting prices on the sensors and just try them sooner or later I will run out of things to check
__________________
Reply With Quote
  #29  
Old 01-09-2013, 09:04 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,665
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525473
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Car wont run

Maybe that i missed something, but you stated before that the p1391 was the only code which came back. That one is for an intermittent cam or crank sensor signal.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #30  
Old 01-09-2013, 03:41 PM
Member
 
Join Date: Nov 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 649
IxIconvict is on a distinguished road
Re: Car wont run

Iv done about 4 scans every time iv replaced parts iv removed the check engine light and run a scan just to check to see if we are good every now and then all codes are gone and I'll have the crank sensor one the next time I do it it's gone and I get the mass air code. I seam to get a 1 to 5 diffrent codes but the main one iv seen come back are the mass air and crank that's what I mean it's like it's playing with me. Most of the work shops and guys I know that fix cars iv asked to help to see if I v missed some thing all do say and do the same thing and I'm getting sick of the smart comments I get from them
__________________
Reply With Quote
  #31  
Old 01-10-2013, 03:58 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652913
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
If you have 5 sensor codes coming up I would lean towards a shorted sensor or a shorted 5v feed considering you fiend melted wires you could easily still be dealing with harness damage elsewhere.

Sent from my SCH-I500
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #32  
Old 01-10-2013, 04:17 PM
Member
 
Join Date: Nov 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 649
IxIconvict is on a distinguished road
Re: Car wont run

I'll check it out and let you know over the weekend I'm going to spend the day on it
__________________
Reply With Quote
  #33  
Old 02-27-2013, 05:10 PM
Member
 
Join Date: Nov 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 649
IxIconvict is on a distinguished road
Re: Car wont run

Ok since my last post iv gone over the car rechecked every thing and the problem is still there so I think it's time to drop it off at jeep to fix and while it's there they can deal with the airbag recall to
__________________
Reply With Quote
  #34  
Old 03-07-2013, 12:44 AM
Member
 
Join Date: Dec 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 604
Madmacc is on a distinguished road
Re: Car wont run

Unfamiliar with the CRD but maybe a clogged catalytic converter. Just throwing it out there.
__________________
Reply With Quote
  #35  
Old 04-15-2013, 05:53 AM
Member
 
Join Date: Nov 2012
Posts: 46
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 649
IxIconvict is on a distinguished road
Re: Car wont run

Ok just a update I got the car back today and was told it was a shaterd timing kit that was my problem and making all the codes come up runs like a dream now thanks every one for the help
__________________
Reply With Quote
  #36  
Old 04-15-2013, 06:45 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,665
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525473
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Car wont run

Did they change the timing chain kit? If the timing chain skipped a tooth or more, then you are very lucky that no other internal damage was done. The pistons can touch the valves when timing is off and bend them.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I love this car! Wait, it's my car!!! carioca Interior/Exterior/Visual 19 05-05-2012 04:20 PM
Fingerprints that wont come off! nick1146 Grand Cherokee - WK 7 05-29-2011 09:47 AM
My OTHER car!! '01 Roush Conv. Stg2 --Show Car -- HRE's BOYCHIKS Members Rides 31 03-24-2010 12:38 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:34 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community