Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-07-2012, 08:01 PM
Member
 
Join Date: May 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1159
IntimiGators is on a distinguished road
Coolant system issue!!!

Hey All,
I apologize now if this gets to be a bit long winded, but I just wanted to fill you in on everything I have done thus far and still have not corrected the issue. I originally had the problem of losing coolant from my reservoir/overflow tank and was frequently refilling it, no signs of leaks or overheating of any sort. I first had a pressure check done and there were no signs of leaks anywhere. a few weeks passed and i noticed my radiator began to leak quite profusely, because of that I had my radiator and cap replaced. still the problem of coolant loss persisted but now I was beginning to overheat with in town driving I took it back and they replaced a cooling fan relay. none of this seemed to correct anything! after replacing the radiator and relay it ran fine for about a week or so and then the problems came back. At this point I thought I'd have someone else look at it and give me their opinion. with the time he had he bled/burped the coolant system by removing the radiator cap and slowly filling it while the truck was running and clearing any air in the system. This seemed to have fixed it! Only for about two weeks though, now I'm back to the same issue and don't know what else to do. I replaced my thermostat just this last week and my water pump, and fan clutch were replaced in the last two years at least. I don't know much about repairing vehicles but I'm thinking somehow I've gotten air back in the system. Is it a matter of replacing my hoses at this point and if so which are the most common. I don't know what to do anymore, PLEASE HELP!!!
__________________

__________________
Reply With Quote
  #2  
Old 03-07-2012, 10:45 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,803
Thanks: 37
Thanked 60 Times in 59 Posts
Rep Power: 54290
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: Coolant system issue!!!

Which engine do you have?
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 03-08-2012, 03:18 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652916
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Coolant system issue!!!

If you have a 4.7l the bleed screw must be removed to properly bleed the system. Also know a common failure that kids the relay is a failing fan, your failing fan drawing too much current may have killed your new relay already.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #4  
Old 03-08-2012, 05:09 AM
Member
 
Join Date: May 2011
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1159
IntimiGators is on a distinguished road
Re: Coolant system issue!!!

My jeep is a 2000, 4.0 I-6.
__________________
Reply With Quote
  #5  
Old 03-09-2012, 02:22 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652916
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: Coolant system issue!!!

I have a power probe that has an internal circuit breaker, I cannot remember the technical term for its operation but basically there is a graph for how much amperage it can take for how long, like it can only take 30A for like 2 seconds but it can take 4A for 15 minutes before it blows... typically when I can actuate a fan without tripping the breaker on my power probe i dont worry about the fan (as a known good will spin up to full speed comefortably without blowing the breaker) but it is NOT uncommon for my breaker to pop within a second or two, the fan will just start to spin up and blow the breaker... its not scientific, I dont have an actual number to give the customer but it is very clear that it is drawing ALOT more amperage than a known good fan. I would look into your fan and possibly another relay.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions about a possible belt issue and coolant Black Betty Troubleshooting/Problems 9 01-01-2012 10:10 PM
Where Is My Coolant Going?? WJeeper Engine Performance/Intake/Exhaust 26 12-11-2011 10:42 AM
Ignition system Issue - the bigger picture Sgmigsy Export & Diesel Powered Jeep Models 5 11-08-2011 04:20 PM
coolant system Overland 2004 Troubleshooting/Problems 4 08-09-2011 08:58 PM
aFe intake issue with 2010 coolant reservoir size - info needed fivespeed6 Grand Cherokee - WK 6 12-23-2010 06:35 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community