Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 11-21-2012, 03:22 PM
Gus9890's Avatar
Premium Member
My Jeep: 2001 4.0L WJ
 
Join Date: Apr 2011
Location: Amelia Island, FL
Posts: 4,021
Thanks: 38
Thanked 32 Times in 31 Posts
Rep Power: 407323
Gus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond reputeGus9890 has a reputation beyond repute
Re: Coolant Tank Problems

Do you drive with Over Drive on or off? I've noticed with mine, with O/D off, it will suck down the coolant really quickly and I have to fill it up every other day or two. When it's on it stays normal.
__________________

__________________
2001 Silverstone Metallic WJ Limited:
Gen III Clear/Chrome Projector/CCFL Halos/LEDs, 8K HIDs, 8K HID Projector/Halo fogs, Clear/Chrome Tail Lights and 3rd Brake Light with LEDS, Diamond Mesh Upper and Lower Fascia, Spectre CAI, Breather Filter, Cabin Air Filter, Low-Temp Thermostat, Jet Stage 1 Chip, MagnaFlow Exhaust with Resonator Tip, Shorty Antenna, Front/Back De-badged
Reply With Quote
  #14  
Old 11-22-2012, 09:39 PM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 799
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2017
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Yeah my 4.7 #8 gasket failed and cracked my spark plug white insulation

Sent from my LG-P999 using Tapatalk 2
__________________

__________________
Reply With Quote
  #15  
Old 11-26-2012, 02:22 PM
hoffmanestates's Avatar
Member
 
Join Date: Nov 2011
Posts: 799
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 2017
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Quote:
Originally Posted by Madanio24 View Post
Check of there is a small hole or crank in the rad tank. In my friends Malibu I just fixed he was loosing coolant and couldn't figure out what it was. It ran fine oil was fine and eventually I found a small pin hole on the rad tank. When the coolant expanded it would leak out, got some job weld and problem solved!
I have this issue.currently when i am in stop and go traffic or drive through i smell coolant on left.side of truck. I.have a leak on radiator and evaporates before hitting ground. I go through a gallon of.coolant about every other month.....

Sent from my LG-P999 using Tapatalk 2
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Leaking Coolant Reservoir tank IntimiGators Troubleshooting/Problems 3 09-17-2011 04:51 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community