Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 09-29-2012, 06:54 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 133988
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Current Issues:

First issue: Every now and then I lose power to my dash/radio and eventually it comes back. However, when it does this all of my needles go from the left allllll the way to the right. Essentially they go from resting at 7 o'clock to about 5 o'clock and then bounce back. PROBLEM: My tachometer for whatever reason went all the way around and now is stuck under the needle resting thing (i can provide a picture if this doesnt make sense). Not a big issue but it bugs me and I can't figure out how to get it back.

Bigger Issue: This is the second time this has happened. I get in and turn the Jeep over and it cranks and turns over but it doesn't idle. So I put key in, turn key, engine cranks and turns over and then goes . Its sounds like its running out of gas. To overcome this I have to feather the gas and keep her revving and then throw it into gear and get it moving. Once it's moving, it idles fine. No fault codes pop up.
__________________

__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
  #2  
Old 09-29-2012, 07:01 PM
Duff Daddy's Avatar
Member
My Jeep: 2007 5.7L WK
 
Join Date: Jun 2012
Location: Ma
Posts: 259
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1109
Duff Daddy is on a distinguished road
Re: Current Issues:

The idle thing is uber common complaint especially with the gauge issue, test your battery, its more then likely giving less then the needed 12v to run the vehicle. Do a full draw and load test and I guarentee it will fail on a mid-tronics tester.
__________________

__________________
Steve Duffy Performance
2007 Grand Cherokee Limited HEMI
1996 Mustang GT RacecaR
Reply With Quote
  #3  
Old 09-29-2012, 09:16 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,050
Thanks: 9
Thanked 102 Times in 95 Posts
Rep Power: 526035
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Current Issues:

For the needle which is resting on the wrong side of the stop, do the instrument self test. With ignition switch in off, push the odometer button and switch the ignition in on. The instrument self test will start and all needles will move and lamps will be lit. As soon as the test start, you can release the odometer button.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 10-25-2012, 02:11 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 133988
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Re: Current Issues:

So this is occurring more commonly. I have fixed the needle/gauge issue since then. When I'm driving my headlights will flicker when the subs hit and within seconds the entire dash cuts out. If I turn down my volume, headlights still flicker but nothing cuts out. This was happening maybe once every 3 to 4 weeks and now it's down to about every 2 weeks.

As well, the engine did its thing again where it would idle if I was revving and of course I was about to get in stop and go traffic. that was an adventure.

Does this mean my battery is going or something else?
__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
  #5  
Old 10-25-2012, 02:30 PM
ekaz's Avatar
Member
My Jeep: 2009 7.0L SRT8
 
Join Date: Oct 2009
Location: Chicago
Posts: 562
Thanks: 1
Thanked 11 Times in 10 Posts
Rep Power: 2620
ekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond repute
Re: Current Issues:

Did you test the battery as was suggested a couple weeks ago? It can be the battery and/or altenator.
__________________
Unlawful Gathering
Click for details!
2012 300 SRT
2011 GC Overland
2009 Modern Blue Pearl (for sale)
Headlights by DC Customs
Powered by PWR
Shifted by SHR
Tooned by Toona
Blinged by Billet Technologies
Reply With Quote
  #6  
Old 10-25-2012, 02:49 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 133988
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Re: Current Issues:

No all of my tools and equipment are buried in the garage. We're remodeling and well...it's a mess. Would a local shop carry it or should I try out a car electronic spot?
__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
  #7  
Old 10-25-2012, 02:51 PM
ekaz's Avatar
Member
My Jeep: 2009 7.0L SRT8
 
Join Date: Oct 2009
Location: Chicago
Posts: 562
Thanks: 1
Thanked 11 Times in 10 Posts
Rep Power: 2620
ekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond reputeekaz has a reputation beyond repute
Re: Current Issues:

Most auto parts stores will test the battery for free.
__________________
Unlawful Gathering
Click for details!
2012 300 SRT
2011 GC Overland
2009 Modern Blue Pearl (for sale)
Headlights by DC Customs
Powered by PWR
Shifted by SHR
Tooned by Toona
Blinged by Billet Technologies
Reply With Quote
  #8  
Old 11-05-2012, 02:34 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 133988
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Re: Current Issues:

Ok I'll go to local store and ask them to test.

I've noticed that when the dash cuts out, my voltage meter drops down from its normal position (around 14) to down around 12ish and then comes back up to 14. It then repeats for the next few minutes then disappears.

Updates regarding engine issue :

I turn the key once to activate the gauges and everything, the voltage meter moves to around 12 and then on a normal start, once it cranks over and idles the needle moves towards its normal position. When it decides to die, needle never moves from 12.

If I sit there and just crank it then let it die. After about 10/15 times it will start normal with no issues. I've been trying to get a video of both when it happens but no luck so far.

Also, I was sitting at a red light yesterday and Jeep just died. Could this be a fuel filter issue possibly?
__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
  #9  
Old 11-05-2012, 03:41 PM
donddon's Avatar
Member
My Jeep: 2000 4.0L WJ
 
Join Date: Jul 2012
Location: El Cajon, CA
Posts: 57
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 877
donddon is on a distinguished road
Re: Current Issues:

On a different car that I owned (KIA Amanti) I had the same issues with the idle, I had to turn it on and immediately put in gear and rev. Turns out I needed a new Mass Air Flow Sensor.*** May be the issue for you??? ***
__________________
Reply With Quote
  #10  
Old 11-05-2012, 04:38 PM
Member
 
Join Date: Jan 2012
Location: MD
Posts: 40
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 1067
Evan5469 is on a distinguished road
Re: Current Issues:

Definitely sounds like a battery or alternator going out. This could be causing all of your problems as well.

An alternator needs to be putting out a minimum of 12 volts to charge the battery. If you're running a system (you mentioned subs, so I'm assuming you are) then the alternator has extra requirements it needs to meet. With your lights dimming and gages not working correctly at all times I am 99% certain it is either the battery or alternator.

Also, another possible solution to your starting and not staying running/dying at a stop could be the IAC valve. I've had one that never gave a code that it wasn't working properly but I changed it out after dying at stops and it solved my problem. Just a thought.
__________________
2004 Onyx Green Pearl Grand Cherokee Limited 4.7 H.O.
-Addco Rear Sway Bar
Reply With Quote
  #11  
Old 11-05-2012, 06:09 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 133988
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Re: Current Issues:

Thanks to both of you for responding.

Quote:
Originally Posted by donddon View Post
On a different car that I owned (KIA Amanti) I had the same issues with the idle, I had to turn it on and immediately put in gear and rev. Turns out I needed a new Mass Air Flow Sensor.*** May be the issue for you??? ***
Sounds similar. I don't have to throw in gear, I just have to rev it.

Quote:
Originally Posted by Evan5469 View Post
Definitely sounds like a battery or alternator going out. This could be causing all of your problems as well.

An alternator needs to be putting out a minimum of 12 volts to charge the battery. If you're running a system (you mentioned subs, so I'm assuming you are) then the alternator has extra requirements it needs to meet. With your lights dimming and gages not working correctly at all times I am 99% certain it is either the battery or alternator.

Also, another possible solution to your starting and not staying running/dying at a stop could be the IAC valve. I've had one that never gave a code that it wasn't working properly but I changed it out after dying at stops and it solved my problem. Just a thought.
Correct running 2 12s.

I'm not getting any codes so good to know about the IAC valve. I'm gonna look into the battery first then alternator. How difficult to change the IAC?
__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
  #12  
Old 11-06-2012, 01:38 PM
TheStreet16's Avatar
Premium Member
 
Join Date: Feb 2012
Location: San Diego, Ca
Posts: 1,087
Thanks: 27
Thanked 29 Times in 27 Posts
Rep Power: 133988
TheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond reputeTheStreet16 has a reputation beyond repute
Re: Current Issues:

Finally got a video of engine idle issue. (clicky on the screenshots)

-I ran a check for codes while this was occuring, you'll see in the video that nothing pops up; just "done".



Continuation from first video. I just take my foot off the gas and death occurs.



As soon as I have some free time, I am going to have my battery tested. This is occuring more frequently and don't really wanna get stuck anywhere with a dead car.
__________________

__________________
RIP 12/20/2013: 2000 Green WJ



Now driving a 7.3L Powerstroke F-250. 5 speed with 4x4.

Always on the look-out for another Jeep.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Current leasing question Breitling65 Grand Cherokee - WK2 - 10 01-16-2011 01:17 PM
My current other rides ... JohnS Other Rides 9 08-16-2010 09:22 PM
Current pics of my Jeep ekaz Members Rides 20 03-04-2010 02:50 PM
Question about my current set up LTrainGC Audio, Video, Navigation & Electronic Modifications 8 02-25-2010 08:21 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.