???electrical problem? ??? - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 03-12-2016, 02:05 PM
New Member
 
Join Date: Mar 2016
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
kimbr211 is on a distinguished road
???electrical problem? ???

I have a 2004 GC last night while driving to work all my dash lights and gauges went on and off ,check eng, brake etc etc, flickering horn beeping interior lights then my head lights went on and off got to the parking garage and it just turned off would not turn back on. I went back out in the morning and it started and I drove home without insidence. I checked the battery and alternator all check out fine any suggestions desperate

Reply With Quote
Sponsored Links
Advertisement
 
  #2  
Old 03-12-2016, 07:14 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,424
Thanks: 18
Thanked 386 Times in 373 Posts
Rep Power: 529619
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: ???electrical problem? ???

Welcome to the garage.
Did you take it in to check the battery and alternator?
The flickering instrument lights and instruments going to 0 could be a sign of a problem with the PCI data bus. This can be caused by a shorted crank position sensor. Did the engine act strange at the moment the lights started to flicker?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 05-22-2016, 09:44 AM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,249
Thanks: 57
Thanked 10 Times in 10 Posts
Rep Power: 3760
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: ???electrical problem? ???

Quote:
Originally Posted by kimbr211 View Post
I have a 2004 GC last night while driving to work all my dash lights and gauges went on and off ,check eng, brake etc etc, flickering horn beeping interior lights then my head lights went on and off got to the parking garage and it just turned off would not turn back on. I went back out in the morning and it started and I drove home without insidence. I checked the battery and alternator all check out fine any suggestions desperate
I have a stupid electrical problem with my turn signals. They work for days and then they don't work for 24hr or 2hrs.
Reply With Quote
  #4  
Old 05-22-2016, 09:59 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,424
Thanks: 18
Thanked 386 Times in 373 Posts
Rep Power: 529619
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: ???electrical problem? ???

Most probably a loose solder inside the flasher unit. Could eventually be a bad switch stalk.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #5  
Old 05-22-2016, 09:59 AM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,249
Thanks: 57
Thanked 10 Times in 10 Posts
Rep Power: 3760
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: ???electrical problem? ???

I swapped switch assembly. Same issue.

It works randomly
Reply With Quote
  #6  
Old 05-22-2016, 07:06 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,424
Thanks: 18
Thanked 386 Times in 373 Posts
Rep Power: 529619
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: ???electrical problem? ???

So open up the flasher unit and check the solders.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 05-22-2016, 07:40 PM
hoffmanestates's Avatar
Senior Member
 
Join Date: Nov 2011
Posts: 1,249
Thanks: 57
Thanked 10 Times in 10 Posts
Rep Power: 3760
hoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond reputehoffmanestates has a reputation beyond repute
Re: ???electrical problem? ???

Quote:
Originally Posted by Frango100 View Post
So open up the flasher unit and check the solders.
Sounds easy. But with 14 hr work days it's impossible.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
06 Grand Cherokee - Electrical Problem wih Dash Cluster Architect Troubleshooting/Problems 59 01-06-2013 12:09 PM
Major Electrical/Computer Problem: All warning lights on markus316 Trouble Shooting/Problems/Service 7 01-09-2012 10:30 PM
Electrical or battery problem? titleist777 Trouble Shooting/Problems/Service 5 07-28-2011 01:51 PM
Electrical problem....dash lights up like a pinball machine - 2006 ltd hemi joebuzz Grand Cherokee - WK 5 07-06-2011 11:50 PM
=== Electrical problem Hac_PTR Troubleshooting/Problems Discussion 4 10-12-2010 12:26 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:55 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.