Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 02-14-2012, 10:44 PM
tkdgirl's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2011
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2147
tkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond repute
Engine running really rough

Wanted to make this a separate thread...

My 04 SE recently started running very rough and loud when accelerating to around 40 mph. When I'm at highway speed, and take the foot off the accelerator, it gets loud again and slows down very rough. It almost feels like what its like to drive in 2nd or 1st. Just replaced the TPS a few months ago and had the transmission flushed last Friday. The RPMs seem normal. My as mileage has plummeted. Got a new fuel filter late last summer.

Any ideas?

Just something to throw out, I''ve had issues with a caliper piston seizing. Would a permanently seized piston cause this issue?
__________________

__________________


2004 Grand Cherokee SE i6 | 2" BB with Daystars and brand spankin' new Bilstein 5100s | Summut Racing slotted & dimpled ultimate performance front rotors and power stop ceramic pads | JK Rubicon wheels w/ 245/70/R17 General Grabber AT2s

Reply With Quote
  #2  
Old 02-14-2012, 10:48 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,789
Thanks: 37
Thanked 59 Times in 58 Posts
Rep Power: 54180
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Does the vehicle pull to one side at all? If not than I doubt it would be a seized caliper. You would also probably hear a rubbing noise.

Are you sure it's not the tps? Does it shift ok? All fluid levels are ok?
__________________

__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #3  
Old 02-15-2012, 07:01 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,280
Thanks: 486
Thanked 53 Times in 51 Posts
Rep Power: 469562
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Engine running really rough

Never ever flush fluids. Only drain and refill. Flushing can cause damage. Just FYI.

Edit: And that's from Chrysler.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock
Reply With Quote
  #4  
Old 02-15-2012, 07:04 AM
tkdgirl's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2011
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2147
tkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond repute
Re: Engine running really rough

Quote:
Originally Posted by 01grand View Post
Does the vehicle pull to one side at all? If not than I doubt it would be a seized caliper. You would also probably hear a rubbing noise.

Are you sure it's not the tps? Does it shift ok? All fluid levels are ok?
It actually does pull to one side (to the drivers side, where there's a noise on my wheel when I do any 3/4 turn both forward and neutral).

It doesn't seem to shift very well under 40mph. But nothing like the craziness when the TPS went bad. It just feels like I'm driving in 2. Fluid levels are all ok- just had an oil change last Friday.
__________________


2004 Grand Cherokee SE i6 | 2" BB with Daystars and brand spankin' new Bilstein 5100s | Summut Racing slotted & dimpled ultimate performance front rotors and power stop ceramic pads | JK Rubicon wheels w/ 245/70/R17 General Grabber AT2s

Reply With Quote
  #5  
Old 02-15-2012, 07:05 AM
tkdgirl's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2011
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2147
tkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond repute
Re: Engine running really rough

Quote:
Originally Posted by lll2for3lll View Post
Never ever flush fluids. Only drain and refill. Flushing can cause damage. Just FYI.

Edit: And that's from Chrysler.
I probably had my terminology wrong. Of course, I did get the transmission fluid done at a oil change place...
__________________


2004 Grand Cherokee SE i6 | 2" BB with Daystars and brand spankin' new Bilstein 5100s | Summut Racing slotted & dimpled ultimate performance front rotors and power stop ceramic pads | JK Rubicon wheels w/ 245/70/R17 General Grabber AT2s

Reply With Quote
  #6  
Old 02-15-2012, 12:20 PM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,333
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524730
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Engine running really rough

After driving for a while check with your hand the temperature of each wheel. When a caliper is seized, the temperature will be much higher on the respective wheel.
Is the engine rpm higher then normal, that you think its just in 1st or 2nd gear?
Is the acceleration slower then it was before?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 02-15-2012, 02:30 PM
Escape's Avatar
Senior Member
 
Join Date: Jul 2009
Location: Michigan
Posts: 1,911
Thanks: 0
Thanked 26 Times in 25 Posts
Rep Power: 113084
Escape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond reputeEscape has a reputation beyond repute
Re: Engine running really rough

Quote:
Originally Posted by Frango100 View Post
After driving for a while check with your hand the temperature of each wheel. When a caliper is seized, the temperature will be much higher on the respective wheel.
Is the engine rpm higher then normal, that you think its just in 1st or 2nd gear?
Is the acceleration slower then it was before?
Just becareful, because if it is seized it will burn the daylights out of you!

Spray it with some windex or spit on it...if it sizzles DO NOT TOUCH.
__________________
[SIGPIC][/SIGPIC]
Forged, Stroked, Blown, Bottle Fed & More
Reply With Quote
  #8  
Old 02-15-2012, 06:33 PM
tkdgirl's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2011
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2147
tkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond repute
Re: Engine running really rough

Quote:
Originally Posted by Frango100 View Post
After driving for a while check with your hand the temperature of each wheel. When a caliper is seized, the temperature will be much higher on the respective wheel.
Is the engine rpm higher then normal, that you think its just in 1st or 2nd gear?
Is the acceleration slower then it was before?
Will do. My jeep buddy is checking it out tonight. He discovered the seized cali when putting on my new rotors/brakes last fall.

The RPMs are normal. It just sounds God awful loud, and I can feel it under my feet on the floor board. You know how you accelerate when you're in 2 or 1? It's just like that. The engine just seems to be working really hard. Yes, the acceleration does seem a bit sluggish.
__________________


2004 Grand Cherokee SE i6 | 2" BB with Daystars and brand spankin' new Bilstein 5100s | Summut Racing slotted & dimpled ultimate performance front rotors and power stop ceramic pads | JK Rubicon wheels w/ 245/70/R17 General Grabber AT2s

Reply With Quote
  #9  
Old 02-15-2012, 07:11 PM
Senior Member
 
Join Date: Feb 2011
Posts: 3,143
Thanks: 73
Thanked 42 Times in 36 Posts
Rep Power: 533848
Amelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond reputeAmelie has a reputation beyond repute
Re: Engine running really rough

For a minute I thought it might have been the Governor Pressure Sensor and Solenoid.
__________________
Reply With Quote
  #10  
Old 02-15-2012, 08:14 PM
tkdgirl's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2011
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2147
tkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond repute
Re: Engine running really rough

Crap. It's the CV joint on the front drive shafts. Completely shot. What do I need to buy and how expensive of a repair is this? Also, I have 4 o2 sensors. How did that happen?
__________________


2004 Grand Cherokee SE i6 | 2" BB with Daystars and brand spankin' new Bilstein 5100s | Summut Racing slotted & dimpled ultimate performance front rotors and power stop ceramic pads | JK Rubicon wheels w/ 245/70/R17 General Grabber AT2s

Reply With Quote
  #11  
Old 02-15-2012, 09:25 PM
tkdgirl's Avatar
Member
My Jeep: 2004 4.0L WJ
 
Join Date: Feb 2011
Posts: 114
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2147
tkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond reputetkdgirl has a reputation beyond repute
Re: Engine running really rough

FTW! The broken CV joint. I'm now driving a 2 wheel drive Jeep.


Still trying to figure out how I got 4 o2 sensors. I thought they were only on Cali Jeeps? I bought mine brand new in Michigan.
__________________


2004 Grand Cherokee SE i6 | 2" BB with Daystars and brand spankin' new Bilstein 5100s | Summut Racing slotted & dimpled ultimate performance front rotors and power stop ceramic pads | JK Rubicon wheels w/ 245/70/R17 General Grabber AT2s

Reply With Quote
  #12  
Old 02-16-2012, 05:19 AM
Frango100's Avatar
The BEAST from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,333
Thanks: 8
Thanked 32 Times in 31 Posts
Rep Power: 524730
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Engine running really rough

I changed this joint on my jeep last year. The rubber boot gets dry and cracks, letting the grease go out and roaddirt in. The coupling wears and causes noises. Never heard of that it would let the engine run rough though.
Bought mine at Rockauto.com, around 70 USD when i remember well. Easy to change. Its just one c-clip and with a puller you just pull it off the axle. The new one you just tap in place with the right size of socket on the center part.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 liberty running rough need help! Sweetz77 Liberty-KJ and KK 5 10-26-2013 02:46 PM
Weird idle/ rough running bry@n Trouble Shooting/Problems/Service 0 02-07-2012 09:39 AM
3.7 running rough, ideas? Cutthroat Grand Cherokee - WK 9 05-15-2011 09:05 AM
running rough snake678 Trouble Shooting/Problems/Service 1 04-10-2011 07:13 AM
jeep running rough Davie Troubleshooting/Problems 6 04-15-2010 07:39 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:58 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community