Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-22-2011, 04:43 PM
Member
 
Join Date: Oct 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
flyboy is on a distinguished road
EVAP code P0443

2001 WJ larado with 4.0L. Hi, can anyone help me with a little trouble shooting on this. the purge solenoid does not work unles I run power directly to it. My tech seems to think that there might be an open in the circut to it. he says he checked all the relays and fuses. Any one got any Ideas? The manual I have dosen't really address the problem. Need ideas fast these techs love to crank up the time on electrical problems.

Thanks flyboy
__________________

__________________
Reply With Quote
  #2  
Old 10-23-2011, 03:07 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652950
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Ill check to see if I can find for sure tomorrow, I am fairly certain there is a pcm update for this concern.

Sent from my SCH-I500 using Tapatalk
__________________

__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #3  
Old 10-23-2011, 06:41 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,796
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: EVAP code P0443

Fuse 21 (10A) on the junction block under the steering wheel is feeding the EVAP/PURGE solenoid. The ground is switched by the PCM. So check out this fuse first.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #4  
Old 10-31-2011, 09:00 PM
Member
 
Join Date: Oct 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
flyboy is on a distinguished road
Re: EVAP code P0443

Checked the 21 fuse, its good. I got power to the fuse but no power to the purge valve from the fuse. PCM indicating almost 14 volts output, too high. Looking to purchase a new PCM. any Ideas or is there possibly an update for this problem?
Thanks,
Flyboy
__________________
Reply With Quote
  #5  
Old 11-01-2011, 02:07 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,796
Thanks: 9
Thanked 75 Times in 70 Posts
Rep Power: 525726
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: EVAP code P0443

There should be constantly battery power on point 1 of the EVAP solenoid connector. If not, you have a wire breakage in between the fuse 21 and the purge solenoid. Point 2 of the connector goes to the PCM and the PCM will switch (pulse) it to ground depending on some other inputs.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #6  
Old 11-01-2011, 08:01 PM
Member
 
Join Date: Oct 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
flyboy is on a distinguished road
Re: EVAP code P0443

I will check it out and let you know
Thanks,
Flyboy
__________________
Reply With Quote
  #7  
Old 11-01-2011, 10:22 PM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652950
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: EVAP code P0443

I finally looked, no pcm update, must be newer wj (i remember it also being a 4.7l) anyway, possible suggestions would be if the purge solenoid was mouted upside down, there should be an arrow indicating up. Also if you (or the gas attendant here in OR) overfills your fuel tank you can get raw fuel into your evap system and cause issues like this.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
  #8  
Old 11-03-2011, 01:24 AM
Member
 
Join Date: Oct 2011
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1076
flyboy is on a distinguished road
Re: EVAP code P0443

Re checked the #21 fuse, found it burnt out so I replaced it. Also found an AC clutch fuse and an AC relay was bad, replaced them. When I turned the car off and restarted it the engine warning light was gone. hasen't come back. I think the mechanic at the shop had a slight vision problem, couldn't see well enough to complet the job corectly.
any way thanks Frango 100 and 2005JGC for the help.
Flyboy
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
P0174 Code?!? Jay Grooms Grand Cherokee - WK 7 05-22-2011 08:09 PM
Code P-1494 need help Wired Wrong Troubleshooting/Problems 5 04-01-2011 06:47 PM
P0420 Code? rojpon74 Troubleshooting/Problems 6 12-06-2010 11:11 PM
P0443 Problem, need some help akabigo Troubleshooting/Problems Discussion 10 10-20-2010 08:14 AM
Code Robert Palmer Trouble Shooting/Problems/Service 14 05-17-2010 11:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:56 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community