Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-27-2011, 06:40 PM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Mar 2011
Location: Holden Beach, NC
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1413
2004wjmedic is just really nice
Exclamation HELP! Transmission issues?

Hello Everyone,

I have a 2004 Jeep Grand Cherokee with the 4.7L. Today it's starting acting weird. It was fine this morning but then this afternoon when ever I would start off from a dead stop it would be "jerky" with the tack going up to around 1200-1500rpm and back down to idle two or three times and then start going like it hadn't done a thing. I'm confused about what this might be because once on the move the Jeep is just fine and shifting normally. I ran the key diagnostic check and it came back with no codes and just said "done". Low transmission fluid (I checked it and it did not smell/look burned but maybe a tad bit low but not to the add line) ? Throttle postion sensor? Torque converter? Hopefully it's nothing to serious. Any suggestion or ideas would be greatly appreciated.
__________________

__________________
[SIGPIC][/SIGPIC]
2004 Jeep Grand Cherokee 4.7 Quadradrive 20" WK2 Wheels
JL Audio XR650-CXI, JL AUDIO XR650-CSI, JL Audio C5-075ct, JL Audio 10w7v2, JL Audio HD900/5, Escort Passport 8500 X50 Blue Hardwired
Reply With Quote
  #2  
Old 07-27-2011, 10:01 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,822
Thanks: 9
Thanked 77 Times in 72 Posts
Rep Power: 525756
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: HELP! Transmission issues?

Did the tach fall back to idle with the accelerator pedal in the same position? The tranny didnīt shift in the meantime? If you have a scanner, you could check the TPS output. On mine its around 12 % in idle and should go up fluently without spikes up or down when pressing the accelerator pedal. When spikes are present, it probably is your TPS.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 07-27-2011, 11:08 PM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Mar 2011
Location: Holden Beach, NC
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1413
2004wjmedic is just really nice
Re: HELP! Transmission issues?

My foot & the pedal stayed in the same postion while the tach went up and then back down to idle This occurs two to three times and the tranny does not shift out of first when it does this. Once the Jeep gets over its fit and underway it seems to shift normally and to drive normally. This is what made me think that it was possibly the TPS. I don't have a scanner but I'm going to try and get it to the shop tomorrow.
__________________
[SIGPIC][/SIGPIC]
2004 Jeep Grand Cherokee 4.7 Quadradrive 20" WK2 Wheels
JL Audio XR650-CXI, JL AUDIO XR650-CSI, JL Audio C5-075ct, JL Audio 10w7v2, JL Audio HD900/5, Escort Passport 8500 X50 Blue Hardwired
Reply With Quote
  #4  
Old 07-28-2011, 09:02 AM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54330
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: HELP! Transmission issues?

Definitely sounds like how mine behaved when the TPS went out, but could be something else too. If it is the TPS its about a 15 minute job to replace, very easy.
__________________
Aaron

My Jeep: 2001 Grand Cherokee Limited, 245/65R17 Falken Rocky Mountain ATS, K&N drop in air filter, Bilstein HD's. De-badged, eagle-eye LED Tails & LED 3rd brake light, Addco front and rear sway bars, Superchips tuned & TM snip, interior 6k LED's, Gen3 ccfl projectors with Volt 6k HID lows, akebono brake upgrade with R1 Concepts premium rotors.
Reply With Quote
  #5  
Old 07-28-2011, 11:37 AM
Member
My Jeep: 2004 4.7L WJ
 
Join Date: Mar 2011
Location: Holden Beach, NC
Posts: 138
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1413
2004wjmedic is just really nice
Re: HELP! Transmission issues?

Thanks for all the comments! I took it into the shop today and they took it on a test drive and of course it behaved for them. I then took it on a test drive with them and it did it once. They said that it may be the TPS or a speed sensor but because it only did it once it was extremely difficult to diagnose it. So rather than just replacing parts and wasting money just to drive it until the Jeep throws a code. So thank goodness for an honest mechanic that isn't going to try and gouge me for money but it sucks that they couldn't figure it out today. I'll keep everyone updated.
__________________
[SIGPIC][/SIGPIC]
2004 Jeep Grand Cherokee 4.7 Quadradrive 20" WK2 Wheels
JL Audio XR650-CXI, JL AUDIO XR650-CSI, JL Audio C5-075ct, JL Audio 10w7v2, JL Audio HD900/5, Escort Passport 8500 X50 Blue Hardwired
Reply With Quote
  #6  
Old 07-28-2011, 12:06 PM
New Member
My Jeep: 1998 5.9L ZJ
 
Join Date: Apr 2010
Location: NorCAL
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
CaptinCork is on a distinguished road
Re: HELP! Transmission issues?

For what this may be worth. I have a 98 GC 5.9 LTD. Have replaced most everything major (including the TPS at 268K) on/in the 300K I owned it. The beast still performs well. Your description reads precisely as I experienced the TPS issue. My sensor acted up at approx 45 mph and again at 68 mph. Consequently at hwy speed (68 mph), I also noted the prm surge with the cruise control engaged. Made the diagnosis a little for difficult. On my 98, it never did throw a code. After the cruise control sys checked out I went for the TPS. Replacement was straight forward. Cleared up the issue. Good luck.
__________________
Reply With Quote
  #7  
Old 07-28-2011, 03:14 PM
01grand's Avatar
Super Moderator

My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2010
Location: Prior Lake, MN
Posts: 1,805
Thanks: 37
Thanked 62 Times in 61 Posts
Rep Power: 54330
01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute01grand has a reputation beyond repute
Re: HELP! Transmission issues?

Wow an honest mechanic, keep his number handy!

Sounds just like what happened to mine, it was acting funny, threw a code while camping out in the woods (luckily my dad had his code reader with). I cleared the code, and only had very intermittent problems for the next 9 months. Then one day on the way home from work it started acting up horribly, threw the P0121 (TPS error) code, and I stopped at Advance on the way home. $35 and 15 min. of work later it was good as new! Good luck, I hope whichever part it is doesn't fail at too bad a time! (not that there is really a good time for a failure haha)
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
89 YJ transmission Sodelcustoms Wrangler-YJ, TJ & JK 3 10-11-2011 04:14 AM
AC issues OnedoubleL Grand Cherokee - WK 4 05-18-2011 09:04 PM
Transmission Problem (need help!) cyprus Grand Cherokee - WK 9 03-14-2011 03:16 AM
so many issues spiros Trouble Shooting/Problems/Service 11 03-07-2011 03:31 PM
Which transmission do I have? magradze Troubleshooting/Problems 5 04-07-2010 01:54 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:28 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community