Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 08-05-2013, 12:04 AM
Shift.91's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jul 2013
Location: Calgary AB
Posts: 131
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 565
Shift.91 is on a distinguished road
Garage
Hey guys. First off, its a 2000 WJ with a 4.7L, cold air intake and straight pipe exhaust and the superchip programmer.
And here's my story!
Took my jeep for a 6 hour drive up north here, and somewhat into the drive started noticing that the transmission doesn't seem to want to stay in a gear. It jumps in and out of overdrive and sometimes into 2nd when I'm going 120kph also when going about 60kph it will go into 2nd and not shift up. I did notice on other trips that it likes to fluctuate between 2500 and 2700rpm. Almost like the torque converter is locking and unlocking within a few seconds. This trip is just wayyy worse.
Transmission fluid is at the proper level and doesn't smell or look burnt.

Engine is idling at 1500rpm and fluctuates somewhat between 1000 and 1700. Making it very hard to put into gear and without exhaust it's extremely loud. Did notice as well on startup that there is a puff of smoke from the drivers side in the engine bay, below the rocker cover, possibly an exhaust leak but haven't investigated further.

Now I did just put in the superchip programmer and put the economy tune in. And then the programmer decided to stop working so I couldn't put it back to stock. (Have to call Superchips). It did put my engine light on, so before the chip stopped communicating I retrieved "fuel injector circuit open" codes for cylinders 1-6. But no driveability issues indicating a misfire. I suspect there was an issue with the calibration file in the programmer.

Also, occasionally my cruise control would stop working. The light would still be on but it just shuts off and won't let me reset it for a few minutes.
Also I averaged for the entire 12 hour trip, 14mpg. With the "economy" tune. WTF?!

Off the top of my head, I'm thinking TPS or throttle body issue. Could be causing all my issues if the computer cant quite tell where the plate is. What do you all think?
__________________

__________________
'00 WJ Limited(Pre-SRT8)
4.7L; AFE Stage 2 CAI; Whipple performance intake manifold; SuperChips FlashPaq programmer; Staggered OEM SRT 20" wheels; Nitto NT420S performance rubber; Spyder projector HID headlamps and LED fogs; Blackout rear lamps; Full 5000k interior LED kit; Bilstein 4600 series shocks; StraightPipe exhaust; Carbon wrapped interior trim; Chrome/Leather shift knobs; Custom badging . . . More to come!:cool:
[SIGPIC][/SIGPIC]
Reply With Quote
  #2  
Old 08-05-2013, 02:22 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,910
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525862
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: High idle and trans issue

Yes, the TPS is most probably your problem.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 08-20-2013, 09:58 PM
Shift.91's Avatar
Member
My Jeep: 2000 4.7L WJ
 
Join Date: Jul 2013
Location: Calgary AB
Posts: 131
Thanks: 0
Thanked 3 Times in 3 Posts
Rep Power: 565
Shift.91 is on a distinguished road
Garage
Replaced the TPS, and so far haven't had any more issues!
__________________
'00 WJ Limited(Pre-SRT8)
4.7L; AFE Stage 2 CAI; Whipple performance intake manifold; SuperChips FlashPaq programmer; Staggered OEM SRT 20" wheels; Nitto NT420S performance rubber; Spyder projector HID headlamps and LED fogs; Blackout rear lamps; Full 5000k interior LED kit; Bilstein 4600 series shocks; StraightPipe exhaust; Carbon wrapped interior trim; Chrome/Leather shift knobs; Custom badging . . . More to come!:cool:
[SIGPIC][/SIGPIC]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle Kit k1967 Audio, Video, Navigation & Electronic Modifications 0 12-02-2012 02:25 PM
Hemi high idle MikeG Troubleshooting/Problems 9 06-26-2012 09:59 PM
High idle DKDunn Troubleshooting/Problems 7 05-04-2012 09:14 PM
High Idle Issue RaZX6R Engine Performance/Intake/Exhaust 12 07-13-2011 03:04 PM
High idle j-lien Engine Performance/Intake/Exhaust 3 11-14-2010 04:48 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:19 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community