Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-29-2010, 11:46 AM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: Apr 2010
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1611
ilirdino is on a distinguished road
I'm back again!

So, I've been enjoying working on the WJ. I did a backyard/garage fix for the drivers side blend door so that I have some warm air. I managed to fix the door seal so that it doesn't sag/fall down using a heat gun, some pliers, and gorilla glue. It's been fun. But, I've a few things that I need to resolve/understand and I'm hoping you guys can help.

First, my airbag light comes on periodically. When it happens, it's when I turn the steering wheel. Can anyone chime in on where I would look first to fix this issue? Has anyone experienced the same problem?

Second, I was just in the jeep and as I was making a left turn with the steering wheel turned fully to the left and I had an odd noise coming from below the vehicle. It was almost like there was something in the road that I had driven over and had slid across the underside of the jeep (although I know for a fact that there was not). Potential diagnosis?

Third, sometimes I'll turn her on and the RPMs will sit up around 3000 for approximately 20 seconds. Whenever I put it in park, it will idle between 900 and 1100 but will never stay consistent. It will surge, and then come down. And then a second later, surge up and fall back down. Clean the throttle body? IAC sensor? Both? And which sensor is the IAC, is the black or the white one by the throttle body?

Thanks so much in advance!
__________________

__________________
'99 Jeep Grand Cherokee Limited (4.7V8)
*K&N 77, Akebonos, and Flowmaster 50
**Addco Rear Sway, chrome grill, V3 Projectors, and HID lows next on the agenda
Reply With Quote
  #2  
Old 11-29-2010, 06:37 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,665
Thanks: 9
Thanked 56 Times in 54 Posts
Rep Power: 525472
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: I'm back again!

First item, no idea.
Second item, when you turn the steering wheel to one of the 2 end positions, the hydraulic steering pump has to go to max pressure, what it doesn´t like too much. Try to prevent to use the end positions as little as possible. Sometimes the pump will start to make noise, or even the serpentine belt can slip when the tension is somewhat low.
Third item, when you have idle surging problems, its always a good starting point to clean out the TB thoroughly, especially the idle air passage and idle air control stepper motor plunjer. When you look at the TB on the left side (in direction of driving), you will find the TPS (throttle position sensor) on the upper position and the idle air control stepper motor on the lower. Just remove the stepper motor and clean the whole thing thoroughly.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 11-30-2010, 01:29 AM
RYANSWJ's Avatar
Member
My Jeep: 2001 4.7L WJ
 
Join Date: Dec 2009
Location: Kirkland, WA
Posts: 412
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 2095
RYANSWJ is on a distinguished road
Re: I'm back again!

third question answer:

had the same problem like every other WJ owner its the TPS

Here is the link to Napa Auto Parts for your 99 JEEP WJ TPS


sorry can't help on the other questions
__________________
MY JEEP
Ryan's 2001 Jeep Grand Cherokee
30% Front Tint, Gen III, 6K Low, 5k Reverse, Quad Squad, V1 Radar, K&N 57 Series, Shorty Antenna, AutoStart

Reply With Quote
  #4  
Old 12-01-2010, 05:06 PM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: Apr 2010
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1611
ilirdino is on a distinguished road
Re: I'm back again!

After some research, I found that the airbag light could be related to the clock spring in the steering column. I've read that it delivers current to the airbags, cruise control, etc. Apparently, the airbags will not deploy if the light is illuminated and it is about a $300 fix at the dealer. I don't want to jeopardize my safety and the safety of my passengers, but I really have no plans of getting this repaired at the stealer. I think it is odd that my cruise control and steering wheel radio controls remain perfectly functional, though. Either way, I think I've diagnosed the issue. What sucks is that I don't have the money to have it repaired right now.

Thanks Frango for informing me about the intricacies of the hydraulic steering. I avoid use of the two end positions, but I was actually a passenger in my Jeep as my roommate dropped me off for class when I heard the odd noise. I guess it isn't anything to worry about.

I'm going to clean the TB and check out those sensors once the weather clears up. Hey RYANSWJ, are you certain the high/inconsistent idle is due to the TPS? I've heard that cleaning the IAC should do the trick and haven't read anything about the TPS being the issue (though maybe I haven't researched enough). Can you elaborate a little if you have a minute?

Thanks guys!
__________________
'99 Jeep Grand Cherokee Limited (4.7V8)
*K&N 77, Akebonos, and Flowmaster 50
**Addco Rear Sway, chrome grill, V3 Projectors, and HID lows next on the agenda
Reply With Quote
  #5  
Old 12-02-2010, 07:57 PM
cheapjeep's Avatar
Amber Instigator
My Jeep: 2004 4.7 HO WJ
 
Join Date: Sep 2010
Location: Vintondale Pa.
Posts: 3,079
Thanks: 95
Thanked 68 Times in 64 Posts
Rep Power: 331837
cheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond reputecheapjeep has a reputation beyond repute
Garage
Re: I'm back again!

No 3 sounds like a clockspring problem to me also. This might help.
__________________
Dave'04 Overland,I don't even remember what I did to it anymore.

Quote:
Originally Posted by TJXJWJ View Post
OK, fine...I'll admit...some amber lamps are good, and necessary.
Reply With Quote
  #6  
Old 12-10-2010, 07:01 AM
jeepy_ramone's Avatar
Member
 
Join Date: Oct 2010
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1374
jeepy_ramone is on a distinguished road
Re: I'm back again!

Here's a step by step pic guide for you. Good Luck.
http://www.links4jeeps.com/writeups/clockspring/
__________________
Reply With Quote
  #7  
Old 12-19-2010, 07:05 PM
Member
My Jeep: 1999 4.7L WJ
 
Join Date: Apr 2010
Posts: 51
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1611
ilirdino is on a distinguished road
Re: I'm back again!

I have a new question! Whenever I hit a pothole or drive over a speed bump I hear a squeaking noise coming from the rear/rear right. I recently had my Flowmaster 50 put on and I'm thinking it could be a bad mount or something? But what about a bad transmission mount? Maybe a bad shock? This is a recent issue that has just popped up a few weeks after having the Flowmaster installed.

Any thoughts?
__________________

__________________
'99 Jeep Grand Cherokee Limited (4.7V8)
*K&N 77, Akebonos, and Flowmaster 50
**Addco Rear Sway, chrome grill, V3 Projectors, and HID lows next on the agenda
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Im Back!! 00wj Members Rides 24 10-04-2010 10:29 PM
Back Shane Grand Cherokee - WK 5 04-21-2010 10:35 PM
Back In Business Sodelcustoms Grand Cherokee - WJ 6 02-02-2010 07:45 PM
My Jeep is BACK!!! Frankie Grand Cherokee - WK 20 01-04-2010 11:46 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community