Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 08-16-2010, 03:03 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 632
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 2830
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Is this a A/C blend door problem?

Quote:
Originally Posted by Duffer View Post
I picked up the part from the Jeep dealer and now I know what it cost $130. Jeep requires you to purchase the entire Heater/AC control assembly (i.e. all three controls) and not just the temperature control. At any rate, I installed it and so far I haven't see a recurrence of the problem, but it's way too early to declare victory.

The junk yard option is an intriguing idea, but I'd be concerned that you might be purchasing someone else's (old) problem. If you decide to go this route, I'd be interested in the cost, as then I'll know how much of a premium I paid to go through the Jeep dealer. However, I have already rationalized it in my mind, as at least I didn't have to pay outrageous labor charges to make this simple part swap.

I have a long road trip planned for the middle of August, so I'll have an opportunity to monitor the temperature over an extended period of use. I'll report the results after I return.
Has the issue returned since you replaced the part?
__________________

__________________
Reply With Quote
  #14  
Old 08-18-2010, 09:28 AM
Member
 
Join Date: Jul 2010
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1624
Duffer is on a distinguished road
Re: Is this a A/C blend door problem?

Sorry it took me this long to post the results of replacing the part. I wanted to wait until after my extended road trip to give the problem ample time to resurface -- if it was going to. But I'm happy to report that I have not seen a single reccurance of the problem since replacing the termperature control panel. So I'm going to declare victory and call this problem fixed.

For reference, the part number and description on Jeep dealer invoice is:
55115904AC "SP Control-A"

The cost was $130 plus tax.

Good luck to those of you still experiencing problem!
__________________

__________________
Reply With Quote
  #15  
Old 08-18-2010, 04:06 PM
Member
My Jeep: 2003 4.0L WJ
 
Join Date: Apr 2010
Posts: 632
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 2830
JeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond reputeJeepMe has a reputation beyond repute
Re: Is this a A/C blend door problem?

Quote:
Originally Posted by Duffer View Post
Sorry it took me this long to post the results of replacing the part. I wanted to wait until after my extended road trip to give the problem ample time to resurface -- if it was going to. But I'm happy to report that I have not seen a single reccurance of the problem since replacing the termperature control panel. So I'm going to declare victory and call this problem fixed.

For reference, the part number and description on Jeep dealer invoice is:
55115904AC "SP Control-A"

The cost was $130 plus tax.

Good luck to those of you still experiencing problem!
Thanks.
__________________
Reply With Quote
  #16  
Old 12-02-2014, 10:54 AM
New Member
My Jeep: 2010 3.7L WK
 
Join Date: Dec 2014
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
joshd is on a distinguished road
Re: Is this a A/C blend door problem?

hey guys i'm new here and I see that this is kinda an old thread but, I recently purchased a 2010 laredo wk w/ 3.7l v6. the problem started by me turning my red to blue temp on control knob from hot to mild and then when i went to turn it back to hot it would not work and all i got was cold air even when my temp. control knob was all the way in the heat direction.

I then noticed that my car was never getting up to warm running temp. so I change the thermostat hoping that would fix my no heat issue. It did not fix my heat blowing cold air.

Next I removed my glove box and in side right behind(towards engine compartment) the climate control unit i found where the little plastic piece that I can manually turn with a screwdriver to get the heat to work. upon learning of the scenario i then proceeded to test my other knob the changes what vents are being used, that knob still functions and i can see a similar "plastic piece" slowly turning as i adjust the position of the knob.

Does anyone know what exactly my problem is?

I know its something with the blend doors and blend doors actuator and the control knob for those parts.
__________________
Reply With Quote
  #17  
Old 12-02-2014, 11:13 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 5,295
Thanks: 9
Thanked 129 Times in 122 Posts
Rep Power: 526340
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Is this a A/C blend door problem?

You are posting in the WJ section now, you probably better ask this in the WK section, since there are quite some differences.
But it seems that your blend door actuator is toast.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Opinions, Possibly Blend Door? JeepMe Troubleshooting/Problems 11 05-01-2010 06:25 PM
Wj door problem? 2000 Grand Troubleshooting/Problems 8 03-06-2010 04:43 PM
possible blend door problem rlane Troubleshooting/Problems 4 02-23-2010 05:32 AM
Blend Doors jon022191 Troubleshooting/Problems 2 12-28-2009 11:16 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:00 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.