Jeep Grand Cherokee Laredo Code P1389 - Page 2 - Jeep Garage - Jeep Forum

Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 07-01-2014, 04:30 AM
Member
 
Join Date: May 2014
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 991
Chewy1974 is on a distinguished road
Re: Jeep Grand Cherokee Laredo Code P1389

Ok, so at this point I have visually inspected the original harness and got a second harness that I visually inspected as well as continuity tests. After replacing the original with the new harness the jeep still does the same thing. Starts, runs for a bit and dies with only the #26 fuse blown (fuel Injectors).
I have not seen any frayed wire or bare copper anywhere on either harness.
I do not understand what I might be looking for visually or why the fuse blows with a direct short somewhere.

Reply With Quote
Sponsored Links
Advertisement
 
  #14  
Old 07-01-2014, 09:08 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep Grand Cherokee Laredo Code P1389

For trouble shooting i would do the following: remove all three connectors from the PCM, remove the auto shutdown relay from the power distribution center under the hood and jumper slot 30 with 87. In this way you bypass the auto shutdown relay and put power directly to the injectors. If, with ignition in on, the fuse stays ok, then you know that the injector wiring and injectors are ok and that you have to check the wiring from the power distribution center to the PCM for chaving.
You can measure each fuel injector resistance and see if one is far lower then the others. Normal fuel injector resistance is about 14 Ohms.
The harness that you changed, is that the complete engine wire harness with fuel injector wires as well?
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #15  
Old 07-01-2014, 02:09 PM
Member
 
Join Date: May 2014
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 991
Chewy1974 is on a distinguished road
Yes, it is a complete harness with all main engine and trany conections.

I will try that test as soon as I have a bit of time.
Reply With Quote
  #16  
Old 07-03-2014, 11:28 AM
Member
 
Join Date: May 2014
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 991
Chewy1974 is on a distinguished road
I bridged the relay and the fuse did not blow and I have been unable to find any area where the wire might have rubbed through. Am I looking just between the fuse block and pcm or could chafing further along the harness cause the problem.
All my injectors test at 12.5 ohms.
Reply With Quote
  #17  
Old 07-03-2014, 07:21 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep Grand Cherokee Laredo Code P1389

You put a jumper on the relay slots 30 and 87 and switched the ignition in run and then the fuse doesn't blow? I will have a look in the wiring diagram, but i think that the problem must be in the PCM.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #18  
Old 07-03-2014, 07:36 PM
Member
 
Join Date: May 2014
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 991
Chewy1974 is on a distinguished road
That is what I'm thinking as well. Thank you for all your help.
Reply With Quote
  #19  
Old 07-03-2014, 11:31 PM
New Member
 
Join Date: Jul 2014
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Rep Power: 0
funjoh is on a distinguished road
Re: Jeep Grand Cherokee Laredo Code P1389

I just had the same issue, blowing fuse 26, cranked but no start. I checked all of the wiring, replaced the CPS, ASD relay, etc. I finally disconnected the alternator and it fired up and ran fine. Hooked the alternator back up and blow the fuse. I have replaced the alternator and all is good!
Reply With Quote
The Following User Says Thank You to funjoh For This Useful Post:
  #20  
Old 07-04-2014, 08:15 AM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep Grand Cherokee Laredo Code P1389

Quote:
Originally Posted by funjoh View Post
I just had the same issue, blowing fuse 26, cranked but no start. I checked all of the wiring, replaced the CPS, ASD relay, etc. I finally disconnected the alternator and it fired up and ran fine. Hooked the alternator back up and blow the fuse. I have replaced the alternator and all is good!
This is strange, that the alternator could blow fuse 26, since its not in the circuit of fuse 26. Maybe that a problem with the alternator field winding messed with the PCM field driver and could cause a short in the PCM. Eventhough your problem seems to be a bit different then from the OP (no start at all on yours vs starting and dying after some time with the OP), its still worth a try.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
  #21  
Old 07-04-2014, 09:53 AM
Member
 
Join Date: May 2014
Posts: 11
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 991
Chewy1974 is on a distinguished road
I did disconnect the alternator last night and yep it started and ran. Thanks again for everything.
Reply With Quote
  #22  
Old 07-04-2014, 12:57 PM
Frango100's Avatar
The beast from Brazil

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 7,324
Thanks: 17
Thanked 377 Times in 364 Posts
Rep Power: 529483
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Jeep Grand Cherokee Laredo Code P1389

Quote:
Originally Posted by Chewy1974 View Post
I did disconnect the alternator last night and yep it started and ran. Thanks again for everything.
That is good to know for fellow jeepers with the same problem.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2006 Jeep Grand Cherokee po700 code Midnightrida Troubleshooting/Problems 14 03-27-2015 07:43 AM
De-badge Jeep Grand Cherokee Laredo dhryan44 Tech Tips DIY/How To 11 09-29-2011 09:56 PM
04 Jeep Grand Cherokee Laredo Vito New Members - Welcome! 7 07-06-2010 03:47 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by FCA US LLC. Chrysler, Dodge, Jeep, Ram, Mopar and SRT are registered trademarks of FCA US LLC.