Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 05-04-2010, 10:58 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,826
Thanks: 9
Thanked 77 Times in 72 Posts
Rep Power: 525760
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Late transmission engagement

When selecting my transmission into R first time of the day or after many hours parked, it takes about 10 sec for the transmission to engage. I had red about a faulty checkvalve in the spin-on charge filter on previously used filters. Changed the filters/fluid a little bit more then a year ago (approx 30K km). Is this still a common thing to happen with this transmission, or do i have to look into some internal leakage? (545rfe)
__________________
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #2  
Old 05-04-2010, 11:01 AM
DJ BoNiOmArIo's Avatar
Senior Member
My Jeep: 2006 3.7L WK
 
Join Date: Jul 2009
Location: Lone Star State
Posts: 10,324
Thanks: 5
Thanked 3 Times in 3 Posts
Rep Power: 12355
DJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond reputeDJ BoNiOmArIo has a reputation beyond repute
Re: Late transmission engagement

I'm not sure bout the WJ but in my WK that lage engagement is caused because of the shifter top assembly unit.

just throwing it out there hope that can be a start point
__________________

__________________
[SIGPIC][/SIGPIC]
Reply With Quote
  #3  
Old 05-04-2010, 12:42 PM
Member
 
Join Date: Oct 2009
Location: Antioch, IL
Posts: 128
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1928
Hemi WK is just really nice
Re: Late transmission engagement

The WJ that I had did that and my WK does it too. The WK is even worse than the WJ was. I have taken it to the dealer at least 3 times now and all they do is change the fluid/filters but it hasn't helped.
__________________
Mike
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Late transmission engagement Frango100 Troubleshooting/Problems Discussion 0 05-03-2010 02:08 PM
Which transmission do I have? magradze Troubleshooting/Problems 5 04-07-2010 01:54 PM
Keeping Track Of The Points During The 2009 Late Model Mopar Events @ Etown QBNKID At The Track 11 12-02-2009 11:12 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:45 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community