Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - WJ > Troubleshooting/Problems

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 10-13-2012, 10:20 PM
New Member
 
Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Andy251976 is on a distinguished road
Losing power under acceleration :(

So i have a 2004 4.0L grand cherokee , as i was driving on the highway today i felt a light missfire type feeling as i satarted to climb a hill , so i put my foot down to see what would happen and the engine lost power , felt like running out of fuel,

When i floor the accelerator it will cick down but wont pull past 3000 rpm, this graduly got worse untill i got home

After letting it sit for 10 mins in started up fine had drove normaly for 5 or 10 mins then started to do the same thing again,

The engine light isnt on and there is no fault code

Anyone got any ideas ?

Thanks for looking
__________________

__________________
Reply With Quote
  #2  
Old 10-14-2012, 01:31 AM
Member
 
Join Date: Jun 2012
Posts: 435
Thanks: 36
Thanked 17 Times in 16 Posts
Rep Power: 1264
honda_fox3 is on a distinguished road
Re: Losing power under acceleration :(

Sounds pretty similar to what I was dealing with on my 04 4.7. I ended up replacing the fuel pump and pressure regulator/filter. If you keep driving it you will probably eventually get fuel lean codes or something similar codes.
__________________

__________________
Reply With Quote
  #3  
Old 10-14-2012, 10:44 AM
New Member
 
Join Date: Oct 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Andy251976 is on a distinguished road
Re: Losing power under acceleration :(

Thanks , yeah my plan was to drive untill i get a code or it breaks down
__________________
Reply With Quote
  #4  
Old 10-14-2012, 02:09 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,914
Thanks: 9
Thanked 92 Times in 87 Posts
Rep Power: 525867
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Losing power under acceleration :(

Some time ago i had similar issues with losing power at higher revs. It also had a slightly higher fuel consumption. After changing the filter/regulator all ok again.
I would start with this, because its a cheap part and you can easily access it, eventhough the quick disconnect connectors can be somewhat hard to remove.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
KYB Gas-a-Just shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
losing coolant jdubgrand Troubleshooting/Problems 2 07-04-2012 12:30 AM
Windows losing power?? 05WK Troubleshooting/Problems 19 06-15-2012 06:33 PM
Hemi Losing Coolant! Chaoul1 Grand Cherokee - WK 26 06-09-2011 07:40 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:44 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community